Sign in to follow this  
Followers 0
twirlz

lilo.conf

16 posts in this topic

ok here my problem... just complied the 2.6.6 kernel and im trying to get lilo to boot to if... i have gone to lilo.conf and added

image = /boot/newkernel/bzImageroot = /dev/hda1label = New 2.6.6 kernelread-only

that is what the howto said to config lilo incase my compile is fucked.

however when i run lilo i get a pop up telling me that lilo.conf is not completed. i click yes to over write lilo.conf and i reboot and there is no lilo option for my 2.6.6 kernel.

what am i doing wrong?

Thanks

0

Share this post


Link to post
Share on other sites

Uhm, I'm not really sure this is it but try using a label that doesn't contain spaces. It might work. Other than that I can't see what could be wrong, unless you changed something else. Hope this helps! :voteyes:

Edited by Access Excess
0

Share this post


Link to post
Share on other sites

you may have better luck with the command line, rather than some gui. What this sounds like to me, the gui either uses some default or failsafe config and when you click "okay" the gui uses that config not the one you add. i dunno, run lilo on the command line and post the output.

afaik lilo doesn't like whitespace in the label field either, like Access Excess suggested.

0

Share this post


Link to post
Share on other sites

The problem as mentioned by Access Excess is the space. you can not use space.

you may try "New Kernel" I haven't tried I just use New_kernel.

however when i run lilo i get a pop up telling me that lilo.conf is not completed. i click yes to over write lilo.conf and

It could not completed the lilo.conf as it found the space error.

0

Share this post


Link to post
Share on other sites

what's that command line arguement to make your new lilo.conf active? anyhoo, maybe you forgot to do that.

0

Share this post


Link to post
Share on other sites

sweet thanks guys for the help i will put a underscore in the label to see if that fixes it.

about the using CLI... i was in konsole for a majority of my compile and only used the gui when my howto said too... so i edited my lilo.conf file while in CLI

http://linuxforum.com/linux_tutorials/65/1.php

this is the howto i was using

0

Share this post


Link to post
Share on other sites

That is not gonna work

because when you make bzImage the path will be diff

for example my path is

# Linux bootable partition config ends

image = /usr/src/linux-2.6.4/arch/i386/boot/bzImage

root = /dev/hda6

label = linuxnew

read-only

I could copy it to the /boot/XXXX/ but at the time I was compilling the kernel I would make a lot of tests

so, to avoid copying every time I compiled my kernel I just changed the path of my bzImage in my lilo.

just check the path before you try to run lilo

0

Share this post


Link to post
Share on other sites

well i just got done doing mine and i get a kernel panic now

its saying root isnt /dev/hda1 it says append with the correct root= option

i know my root is hda1 so whats up

and also i compiled 2.6.6 to use the framebuffer but it doesnt on boot up and my lilo.conf is up to date and coorrectly setup so can anyone help

0

Share this post


Link to post
Share on other sites
its saying root isnt /dev/hda1 it says append with the correct root= option

This could be several things. First of all, check your hardware. If any of your drives aren't plugged in, aren't functioning correctly, etc, this could be a problem.

Also, you may have not compiled your kernel with the correct hardware drivers for your drive to function. If your drive is SCSI, make sure you include SCSI drivers. If its ATA, make sure you include the correct drivers.

and also i compiled 2.6.6 to use the framebuffer but it doesnt on boot up and my lilo.conf is up to date and coorrectly setup so can anyone help

Have you actually tried framebuffer? A lot of people associate the framebuffer boot logo you can activate with framebuffer. You might have framebuffer enabled and just have the boot logo disabled. If not. double check your kernel config. Make sure you have the right drivers for the right cards, and double check that your lilo.conf is set up.

0

Share this post


Link to post
Share on other sites

well i know what framebuffer and im using it now on my old kernel 2.4.22 im thinking i have some kinda moduales or something im just not sure what

0

Share this post


Link to post
Share on other sites
grub is easier, and better if you ask me

I don't pick favorite, its better to know both, I just use whatever will turn my computer on. I hate the kernel panics, being newer to linux I would always reinstall when I got one of those, but now I've become better at linux.

0

Share this post


Link to post
Share on other sites
well i just got done doing mine and i get a kernel panic now

its saying root isnt /dev/hda1

did it say it can't mount root or what?

most likely you didn't compile in the correct filesystems. as always, error messages help.

0

Share this post


Link to post
Share on other sites

well it is ext3fs and i did compile that in but i forgot raid so thats it im compliing the newone now

i also forgot vesa thats y my fbdev didnt work

Edited by I03rr0r
0

Share this post


Link to post
Share on other sites

i used the CLI option that RijilV suggested and it worked great.

Thanks

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0