Sign in to follow this  
Followers 0
1337

FTP server

19 posts in this topic

OK I'm using Bulletproof FTP to setup an FTP server. I'm behind a router, but I already set up the router for port fowarding. I was getting this whenever I tried to connect to it from the remote address (127.0.0.1 works fine) :

(000001) 4/4/2004 4:56:11 PM - (not logged in) (192.168.254.215) > connected to ip : 0.0.0.0

(000001) 4/4/2004 4:56:11 PM - (not logged in) (192.168.254.215) > sending welcome message.

(000001) 4/4/2004 4:56:11 PM - (not logged in) (192.168.254.215) > 220 myFTP

(000001) 4/4/2004 4:56:11 PM - (not logged in) (192.168.254.215) > disconnected.

Then it suddenly started working... and now it's back to that. Anyone know what's going on?

0

Share this post


Link to post
Share on other sites

are you forwarding both port 21 and 20? one is used for commands and the other for data.

0

Share this post


Link to post
Share on other sites

Should I have them forwarded to two separate ports? If so, which one should be entered in my ftp client to connect to my server?

0

Share this post


Link to post
Share on other sites

Hmm...I think maybe my ISP is blocking FTP. Anyone know Adelphia's policy on this? Workarounds? :devil:

0

Share this post


Link to post
Share on other sites

workaround is easy, just point some other port to point 21 internally

0

Share this post


Link to post
Share on other sites

Hmm...that's what I was doing internally, port 333 fowarded to 21. Must be something else then, huh?

<edit>

Just read the ToS. Wow, I broke several of these. FTP server IS prohibited. I found this to be amusing: chain letter e-mails are also prohibited ^_^

</edit>

Edited by 1337
0

Share this post


Link to post
Share on other sites

Dang, thats probably why it never worked for me :lol: :omfg:

0

Share this post


Link to post
Share on other sites

isn't passive mode for ftp similar to the RealVNC viewer with listening sort of setup?

0

Share this post


Link to post
Share on other sites

normal ftp has a callback type function to the client. it establishes a secondary connection. if the client trying to connect is behind a firewall, it will connect then you can't do anything, won't even finnish the ls.

should be that you forward only port 21 to the ftp server, because port 20 is the callback initiated by the server, so if the server has access out through the router everything is cool. but if the client is behind a router or firewall, you have to enable passive mode in the ftp client, which will tell both the client and server to use the one tcp connection for all data transfer. no callback, other than that, there may be some strange firewall in place by your isp

0

Share this post


Link to post
Share on other sites

Chequesome (as he is preferablly called, if i remember right) and i have been working on this. We have gotten very close and have even logged in, but never have been able to retrieve local directories. I have come to the conclusion that it is Adelphia.net that is to blame, but what do i know... :P

0

Share this post


Link to post
Share on other sites

like i said, if you aren't in passive and you need to be, it will connect and not return an ls

do any services work? or just ftp fails. try http, ssh, telnet, and the like.

0

Share this post


Link to post
Share on other sites

yea, i httped and it just connected w\no dirs. So it connects...

0

Share this post


Link to post
Share on other sites

that is kinda wacky, if they had a firewall that blocked incomming data,then you should get no connect. but if you get connect, then nothing, I have no idea what kind of crazy things their firewalls are doing.

it could be that their firewall filters out fully formed uninvited incomming tcp packets, so it goes through the handshake and then all data gets blocked. which means you can port scan the hell out of everyone and get a load of results, and you can connect, but then can't do anything.

get source for an ftp server, after the handshake, have the server establish a fake outgoing connection just to fool the firewall rules then everything should be let in.

This (like all my solutions) is probably overly complex. There is probably a simpler way to do this we just don't know it yet.

0

Share this post


Link to post
Share on other sites

sounds to me like a bizzare packet filter that is seeing the ftp activity. try an encrypted ftpd alternative.

0

Share this post


Link to post
Share on other sites

yes, but http also does not work, so they would be scanning for a list of common protocols. but i agree, try setting up an ssh server or something to that effect and logging into that.

0

Share this post


Link to post
Share on other sites

At one point I had it working for an hour and someone downloaded something off it. It would only work if PASV mode was disbled though, so I dunno.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0