Sign in to follow this  
Followers 0
systems_glitch

Dial-Up on a Teltone Line Simualtor

2 posts in this topic

link to album: https://imgur.com/a/EI0e7JH

 

I ended up with this little Teltone TLS2 "Test Line Simulator" from an equipment pick-up last fall. It's basically an analog two-line PBX: it's microcontroller driven and provides dialtone, ringing, and will let you call between the two ports. One port is station 40, the other is station 29. There's a switch for ground start or loop start for each port, presumably that's to allow for testing old PBX trunks that use ground start. I'd verified that it works with two telephones, but hadn't tried modems with it.

 

TIGHutkh.jpg

 

I plugged a 2400 bps external modem into a SPARCstation 2 that was on the bench and set it up as a modem line. Pretty basic setup, just update /etc/gettytab for your line specs and /etc/ttytab to enable getty on the chosen serial port. It'd been so long since I had to set up a modem port on SunOS 4.x, I forgot about running ttysoftcar (TTY Soft Carrier detect) so the line wouldn't auto-answer at first. Closeup of the hardware, sit back and enjoy der blinkenlights:

 

hWAw6NDh.jpg

 

SS2 connects to the main network over 10base2/ThinNet :P The "client" end is a Leading Edge Model D (DOS PC) with an internal modem:

 

7EA2ZjEh.jpg

 

Works fine! Even attached a screen session and IRCed over the link!

0

Share this post


Link to post
Share on other sites

this is hot.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0