Sign in to follow this  
Followers 0

HPR - HPR1106: Of Fuduntu, RescaTux (or the Farmer Buys a Dell)

1 post in this topic

This is another one of my How I Did ItPodcasts (or How I Done It if you rather) where my goal is to passalong the things I learn as a common Linux user administering my homecomputers and network, and engaging in the types of softwaretinkering that appeals to our sort of enthusiast.I'd been thinking for a while aboutreplacing the small computer on my dinner table. I had been using anold HP TC1000, one of the original active stylus Windows tablets, ofcourse now upgraded to Linux. With the snap in keyboard, it had aform factor similar to a netbook, with the advantage that all thevulnerable components were behind the LCD, up off the table and awayfrom spills. It had served my purpose of staying connected to IRCduring mealtimes, and occasional streaming of live casts, but Iwanted more. I wanted to be able to join into Mumble while preparingmeals, I wanted to be able to load any website I wanted withoutlockups, and I wanted to stream video content and watch DVDs.I was concerned that putting a laptopon the table was an invitation to have any spilled beverage suckedright into the air intakes, and I never even considered a desktopsystem in the dining room until I saw a refurbished Dell Inspiron 745on (I wouldn't normally plug a specific vendor, but nowGearXS is putting Ubuntu on all it's used corporate castoff systems).This Dell had the form factor that is ubiquitous in point-of-sale, avertical skeleton frame with a micro system case on one side and a17” LCD on the other, placing all the electronics several inchesabove the surface on which it is placed. I even found a turntableintended for small TVs that lets me smoothly rotate the monitor toeither at my place on the table or back towards the kitchen where Iam cooking. I already had a sealed membrane keyboard with anintegrated pointer and wireless-N USB dongle to complete the package.Shipped, my “new” dual core 2.8Ghz Pentium D system with 80Gbhard drive and Intel graphics was under $150. [The turntable was $20and an upgrade from 1Gb to 4Gb of used DDR2 was $30, but both wereworth it.] Since the box shipped with Ubuntu, I thought installingthe distro of my choice would be of no consequence, and that is wheremy tale begins.I'm going to start my story towards theend, as it is the most important part. After the installation of fourLinux distros in as many days (counting the Ubuntu 10.04 LTS the boxshipped with, a partial installation of SolusOS 2r5, Fuduntu andfinally Lubuntu 12.04), I discovered I couldn't boot due to Grubcorruption (machine POSTed, but where I should have seen Grub, I gota blank screen with a cursor in the upper left corner). A. I thought I would do a total diskwipe and start over, but DBAN from the UBCD for Windows said itwasn't able to write to the drive (never seen that before) B. Started downloading the latestRescaTux ISO. Meanwhile, I found an article that told me I couldrepair Grub with a Ubuntu CD, so I tried booting from the Lubuntu 12.04 CD (using the boot deviceselector built into the hardware). Same black screen, preceded by amessage that the boot device I had selected was not present. Samething with the Fuduntu DVD that had worked the day before. With theexception of UBCD, I couldn't get a live CD to boot. C. Now having downloaded the RescaTuxISO, and suspecting a problem with the optical drive, I usedUnetbootin to make a RescaTux bootable thumb drive. RescaTux ( has a pre-boot menu that let's you choose between 32 and 64 bitimages, but that was as far as I got, nothing happened when I made myselection. D. At this point, I am suspecting ahardware failure that just happened to coincide with my last install.This is a Ultra Small Form Factor Dell, the kind you see as point ofsale or hospital systems, so there weren't many components I couldswap out. I didn't have any DDR2 laying around, but I did test eachof the two sticks the system came with separately with the sameresults. I then reasoned a Grub error should go away if disabled thehard drive, so I physically disconnected the drive and disabled theSATA connector in the BIOS. I still couldn't boot to a live CD.Deciding there was a reason his machine was on the secondary market,I hooked everything back up and reset the BIOS settings to thedefaults, still no luck. E. As a Hail Mary the next day, Iburned the RescaTux ISO to a CD and hooked up and external USBoptical drive. This time, I booted to the Live CD, did the two stepgrub repair, and when I unplugged the external drive, I was able toboot right into my Lubuntu install. Now booting to Live CDs from theoriginal optical drive and from the thumb drive worked. RescaTux FTW.Now a little bit on how I got in thismess. As I said, the Dell shipped with 10.04, but I wanted somethingless pedestrian than Ubuntu (ironic I wound up there anyway). I triedHybride, but once again, like my trial on the P4 I mentioned onLinuxBasix, the Live CD booted, but the icons never appeared on thedesktop (I think it's a memory thing, the Dell only shipped with agig, shared with the integrated video). After Hybride, I reallywanted to be one of the cool kids and run SolusOS, but the installhung twice transferring boot/initrd.img-3.3.6-solusos. I castedaround for a 64bit ISO I had on hand, and remembered I'd reallywanted to give Fuduntu a try. Fuduntu is a rolling release fork ofFedora, with a Gnome 2 desktop, except that the bottom bar isreplaced with a Mac style dock, replete with bouncy icons (cute atfirst,but I could tell right away they would get on my nerves).However, I found I liked the distro, despite the fact I found thedefault software choices a little light for a 900Mb download (GoogleOffice, Chromium, no Firefox, no Gimp). Worst of all, no Mumble inthe repos at all (really Fuduntu guys? While trying to installMumble, do you know how many reviews I found that can be summed up as"Fuduntu is great, but why is there no Mumble?").Unfortunately, I put Mumble on the back burner while I installed andconfigured my default set of comfort apps from the repos (Firefox,XChat, Gimp, VLC, LibreOffice, etc). [bTW, with the anticipatedarrival of a 2.4ghz headset, I hope to be able to use the new machineto join the LUG/podcast while preparing and dare I say eatingdinner.] I visited the Mumble installation pageon SourceForge, and found they no longer linked to .deb files andfedora .rpms, as they assume you can install from your repositories.Thinking someone must have found an easy solution, I hit Google. Thebest answer I found was a page on the Fuduntu forums( ), thatsuggested downloading the Mumble and a dozen prerequisite library.rpm's from a third party site called I, and found when I looked up each library, I got a dozendifferent links to versions of the file. Then I saw a link thatseemed to offer the promise of simplifying my task, if I subscribedto, I could add their whole catalog as a repo. Whileresearching the legitimacy of, I found them mentioned inthe same sentence as RPMFusion as an alternate repository for Fedora.I decided to install the RPMFusion repos as well, thinking I mightfind some of the needed libraries in there. I registered with pbone,and discovered I would only have access to their repository for 14days free, after which it would cost $3 a month (after all, hostingsuch a service must cost money). I figured the free trial would atleast get Mumble installed, and went through the set up. Among thequestions I had to answer were which Fedora version I was running (Ipicked 17, since Fuduntu is rolling) and 32 or 64 bit. pbone.netgenerated a custom .repo file to place in my /etc/yum.repos.ddirectory. At this time, I'd already set up RPMFusion. The fun started when I ran 'yumupdate'. I got "Error: Cannot find a valid baseurl for repo:rpmfusion-free". It turns out ( the location of the RPMFusion servers are usually commented out inthe .repo files, Fedora must know where they are, but I guess Fuduntudoes not. I uncommented each of the baseurl statements (there arethree) in each of the RPMFusion .repo files (there are four files,free, non-free, free-testing, and non-free testing). I then re-ran'yum update', this time I was told the paths for the RPMFusionbaseurl's didn't exist. I opened up the path in a browser andconfirmed it was indeed wrong. I pruned sub directories from the pathone by one until I found a truncated url that actually existed on theRPMFusion FTP server. I looked at the .repo files again and figuredout the paths referenced included global environment variables thewere inconstant between Fedora and Fuduntu. For instance, $release inFedora would return a value like 15, 16, or 17, where in Fuduntu itresolves to 2012. I figured if I took the time, I could walk up anddown the FTP server and come up with literal paths to put in theRPMFusion .repo files, but instead I just moved the involved .repofiles into another folder to be dealt with another day. I again launched 'yum update'. Thistime had no errors, but I was getting an excessive amount of newfiles from my new repo ('yum update' updates your sourcesand downloads changed files all in one operation). It's possible therolling Fuduntu is closer Fedora 16, so when I told I wasrunning 17, all the files in the alternate repo were newer than whati had. In any case, I had no wish to be dependent of a repo I had torent at $3 a month, so I canceled the operation, admitted defeat, andstarted downloading the 64bit version of Lubuntu. I know I said Iwould rather have a more challenging distro, but because of it'slocation, this needs to be a just works PC, not a hack on it for halfa day box. I would have like to have given Mageia, Rosa, or PCLinuxOSa shot, but too many packages from outside the repos (case in point,Hulu Desktop) are only available in Debian and Fedora flavors. Youknow the rest, I installed Lubuntu, borked my Grub, loop back to thetop of the page.

Go to this episode


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0