Sign in to follow this  
Followers 0
dinscurge

fluxbox/text install os for old lappy

46 posts in this topic

do you guys know any distros that have like a text/fluxbox/jvm install>? i need to install on a pIII mobile 1ghz with 256mb ram which cannont run xfce, has 40gb hd so would like a regularish distro. i would rather stay away from the obvious fluxbuntu as i would rather have debian than ubuntu but the debian disk is only xfce/kde/gnome, so is the gentoo disk i have. and the laptop wouldnt run solaris text console. any suggestions welcome, am running "damn small linux" atm but would like more customization.

edit: also it doesnot have a floppy drive otherwise i was gonna l33t use tomsrbt

Edited by dinscurge
0

Share this post


Link to post
Share on other sites

Debian does indeed have a text-only install -- look for their "netinst" ISO image. This image boots into a minimal text install environment, and pulls all needed files from your Internet connection.

As far as other distros with text-only installs, Arch Linux and Slackware both use text mode as the default (only?) installation method. Arch Linux is 686 optimized, and since you have a Pentium III, it'd work fine for that.

XFCE and/or Fluxbox will run fine with hardware of that spec. For Linux stuff, those specs aren't really all that low.

0

Share this post


Link to post
Share on other sites

Get the gentoo 2008 minimal cd, which will drop you into a text-only install,

and then you will have to emerge fluxbox.

0

Share this post


Link to post
Share on other sites
Debian does indeed have a text-only install -- look for their "netinst" ISO image. This image boots into a minimal text install environment, and pulls all needed files from your Internet connection.

As far as other distros with text-only installs, Arch Linux and Slackware both use text mode as the default (only?) installation method. Arch Linux is 686 optimized, and since you have a Pentium III, it'd work fine for that.

XFCE and/or Fluxbox will run fine with hardware of that spec. For Linux stuff, those specs aren't really all that low.

I've never tried a text-only install, but the netinst iso image provides the graphical installer

0

Share this post


Link to post
Share on other sites
I've never tried a text-only install, but the netinst iso image provides the graphical installer

You're right -- I meant the netinst-businesscard image, which is 35 MB. There's also an ultra-minimal ISO, available from the netboot directory in the apt tree -- this one is only 8 MB,and pulls even additional kernel modules from the Internet.

0

Share this post


Link to post
Share on other sites
As far as other distros with text-only installs, Arch Linux and Slackware both use text mode as the default (only?) installation method.

Slackware only has a curses-based (text-mode) installation indeed. There's also a minimal USB installer that lets you select alternative installation media, like *grabs Slackbook* a DVD, CD-roms, an FTP server, an NFS server, et cetera. It's all pretty straightforward.

Fluxbox is actually included.

For a low-memory window manager, I'd go with ratpoison, but that's just personal taste.

Edited by G-Brain
0

Share this post


Link to post
Share on other sites
Debian does indeed have a text-only install -- look for their "netinst" ISO image. This image boots into a minimal text install environment, and pulls all needed files from your Internet connection.

As far as other distros with text-only installs, Arch Linux and Slackware both use text mode as the default (only?) installation method. Arch Linux is 686 optimized, and since you have a Pentium III, it'd work fine for that.

XFCE and/or Fluxbox will run fine with hardware of that spec. For Linux stuff, those specs aren't really all that low.

tried xfce debian and it crashes my ati card no idea which one it is, so basicaly it loads the computer actually loads the environment it just crashes the gpu so it doesn't display it. i tried the business card for debian could install it but couldnt load it cuz the lowest option was xfce?

0

Share this post


Link to post
Share on other sites
Debian does indeed have a text-only install -- look for their "netinst" ISO image. This image boots into a minimal text install environment, and pulls all needed files from your Internet connection.

As far as other distros with text-only installs, Arch Linux and Slackware both use text mode as the default (only?) installation method. Arch Linux is 686 optimized, and since you have a Pentium III, it'd work fine for that.

XFCE and/or Fluxbox will run fine with hardware of that spec. For Linux stuff, those specs aren't really all that low.

tried xfce debian and it crashes my ati card no idea which one it is, so basicaly it loads the computer actually loads the environment it just crashes the gpu so it doesn't display it. i tried the business card for debian could install it but couldnt load it cuz the lowest option was xfce?

Why cant you just not install a window manager when you install and then install one of your choice later? IIRC you dont need to install a window manager when installing debian.

0

Share this post


Link to post
Share on other sites

which menu option do i use for that? first time ive used debian for anything besides xfce/gnome/kde

0

Share this post


Link to post
Share on other sites

got debian running with no desktop inv. i did a

apt-get install fluxbox

and now it returns the error

Error: Couldn't connect to XServer

when i do "fluxbox". if i try blackbox or jwm which i have also installed it returns

Failed to open display

Edited by dinscurge
0

Share this post


Link to post
Share on other sites

I'm not sure if this will fix it but try

apt-get install xorg-server

0

Share this post


Link to post
Share on other sites
I'm not sure if this will fix it but try

apt-get install xorg-server

That should work. It sounds like the x-server isnt installed, but wouldnt installing fluxbox (or any wm) install xorg as a dependency?

0

Share this post


Link to post
Share on other sites
I'm not sure if this will fix it but try

apt-get install xorg-server

That should work. It sounds like the x-server isnt installed, but wouldnt installing fluxbox (or any wm) install xorg as a dependency?

i guess not idk the only way i could figure out how to install debian without a gui was just hit install and dont install the desktop environment so it only loaded the base systemm which didnt have xorg i guess

0

Share this post


Link to post
Share on other sites
I'm not sure if this will fix it but try

apt-get install xorg-server

That should work. It sounds like the x-server isnt installed, but wouldnt installing fluxbox (or any wm) install xorg as a dependency?

i guess not idk the only way i could figure out how to install debian without a gui was just hit install and dont install the desktop environment so it only loaded the base systemm which didnt have xorg i guess

So, is it working now?

0

Share this post


Link to post
Share on other sites

edit: yeah it didnt install xorg when did from cd its downloadin it now so probably gonna work

Edited by dinscurge
0

Share this post


Link to post
Share on other sites

still crashing the gpu when i do

xinit

probably a problem with debian/kernel/xorg mabey it workes fine with dsl for flux

Edited by dinscurge
0

Share this post


Link to post
Share on other sites

Post what happens when you run

exec startfluxbox

0

Share this post


Link to post
Share on other sites
Post what happens when you run

exec startfluxbox

Error: Couldn't connect to XServer

0

Share this post


Link to post
Share on other sites

There is a list of problems that could be causing this. For instances:

  • Is GDM installed?
  • Make sure in ".xinitrc" file there is a line that reads "exec fluxbox"
  • Make sure your system is all up to date, apt-get install updates
  • Try rebooting your box and then try running fluxbox. (That cured my problem while back)
  • There could be missing packages or even corrupt ones. You can look for corresponding packages with synaptic.

If no luck, post your /etc/X11/xorg.conf and your /var/log/Xorg.0.log.

0

Share this post


Link to post
Share on other sites
There is a list of problems that could be causing this. For instances:

  • Is GDM installed?
  • Make sure in ".xinitrc" file there is a line that reads "exec fluxbox"
  • Make sure your system is all up to date, apt-get install updates
  • Try rebooting your box and then try running fluxbox. (That cured my problem while back)
  • There could be missing packages or even corrupt ones. You can look for corresponding packages with synaptic.

If no luck, post your /etc/X11/xorg.conf and your /var/log/Xorg.0.log.

there wasn't any updates, gdm wasn't installed and it said that neither xorg.0.log or xorg.conf existed

no such file or directory exists

tried restarting after installing gdm it autoloaded xinit and crashed gpu right away

Edited by dinscurge
0

Share this post


Link to post
Share on other sites

Well, what does exist in /etc/x11? Try creating an xorg.conf file...

Xorg -configure
mv xorg.conf.new /etc/X11/xorg.conf
startx

0

Share this post


Link to post
Share on other sites
Well, what does exist in /etc/x11? Try creating an xorg.conf file...

Xorg -configure
mv xorg.conf.new /etc/X11/xorg.conf
startx

i dont know

typed in

/ect/x11/xorg.xonf

said file/directory didnt exist

and yeah i cant check now it autoloads x all i can do is turn it on log in and it crashes the gpu so the screen turns off but the cpu stays on.

0

Share this post


Link to post
Share on other sites
/ect/x11/xorg.xonf

Err...I hope that isn't literally what you typed in to the terminal.

You can boot into single-user text mode by appending the word "single" to your GRUB boot parameters.

http://www.cyberciti.biz/faq/grub-boot-int...ngle-user-mode/

Then use ls /etc/x11 and ls /var/log and tell us what shows up.

Edited by Spyril
0

Share this post


Link to post
Share on other sites

for /etc/x11 it returns no such directory or file

for /var/log it returns 18 logs

http://www.thinkwiki.org/wiki/ATI_Rage_Mobility_M3 wonder why its crashing my ati m3 says its supported by xorg

when i tried "Xorg -configure" it put it in "/root/xorg.conf.new" so im guessing the one you were looking for was in "/usr/%usernamme%/xorg.conf"?

Edited by dinscurge
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0