Sign in to follow this  
Followers 0
Ragnarok30

Nmapping my network nodes

7 posts in this topic

Hey guys,

Haven't posted in a while, but I've been reading. I need your expert advise.

I've just watched a video tutorial on how a man in the middle attack is done. This was done by Hak5. Now I understand the concept of it. Here is my problem.

I have Ubuntu box connected through Ethernet to my linksys router. My Laptop running Vista is connected wirelessly to the network. Now from my wireless laptop, I attempt to ping scan my own gateway of 192.168.1.1 to my router. Doing a ping scan I expect to see the different workstations (1) on the network, but I don't. It only shows me the mac address of my linksys router.

I'm using Cain to scan it also, but it does the same.

What am I doing wrong that I don't see my Linux box on my network?

0

Share this post


Link to post
Share on other sites

Maybe the linux box has itptables turned on? Hard to give more advice since you've not given a lot of details. If you post the output of nmap it might help.

0

Share this post


Link to post
Share on other sites

Ok, I'm on my *Nux box now and I'm trying it the other way with the same results.

user1@user1-desktop:~$ nmap -sP 192.168.1.1
Starting Nmap 4.53 ( http://insecure.org ) at 2008-07-21 22:40 EDT
Host 192.168.1.1 appears to be up.
Nmap done: 1 IP address (1 host up) scanned in 0.167 seconds

Isn't it suppose to tell me the other computers on it too?

0

Share this post


Link to post
Share on other sites

You are only getting one result back because you are only specifiying one address

try

nmap -sP 192.168.1.*

This will perform a ping scan from 192.168.1.1-192.168.1.255

0

Share this post


Link to post
Share on other sites

You are awesome dude. Thank you thats exactly what it was.

While you guys are still listening. I'm in Cain, and I'm performing the man in the middle with my wireless laptop. It worked for a 10 seconds, and then, I dunno, it blocks internet traffic to the victim PC. Anyone know about that?

0

Share this post


Link to post
Share on other sites

You have to enable your vista box to do ip forwarding

Edited by Remix
0

Share this post


Link to post
Share on other sites

I figured it out. It was my own dumb fault. Just a firewall problem that was blocking traffic. Thanks for the help though.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0