Sign in to follow this  
Followers 0
SgtOneill

Hacking Router with THC Hydra

2 posts in this topic

Hello everyone. Its my very first post here.

Im loving this foruns, i've learn alot and i decided to participate.

so heres what im trying to do.

I downloaded and installe THC hydra on my Mac book pro a couple of days ago, and now im testing it to learn how it works.

I've encountered a few "problems".

First i tried to use a list of users / pass that were on a file.

i typed hydra -L net.txt -P net.txt -v 192.168.1.1 telnet

i got the error Segmentation Fault several times till i discovered the problem was the files i was using. I deleted half of the content on the files and it worked, or at least it didnt gave that error. I believe the dictionaries were way too big? maybe i made some other mistake?

second, im now trying hydra again on my router but with a single user and password (that i know wich ones are)

i typed hydra -l ADMIN -p ADMIN -v 192.168.1.1 http-post-form http://192.168.1.1/

and i ge tthe following:

Hydra v5.4 © 2006 by van Hauser / THC - use allowed only for legal purposes.

Hydra (http://www.thc.org) starting at 2007-10-03 23:38:54

[DATA] 1 tasks, 1 servers, 1 login tries (l:1/p:1), ~1 tries per task

[DATA] attacking service http-post-form on port 80

[VERBOSE] Resolving addresses ... done

[sTATUS] attack finished for 192.168.1.1 (waiting for childs to finish)

select: Bad file descriptor

-------------------------------------------------------------------------------------------

i googled for Select: Bad File descriptor and i didnt find any useful info about that. what did i do wrong here?

and last but not least, i know my router has no user name, its actually null, only has a password. Can hydra brute force without a user name? i tried "hydra -l -p admin" but doesnt work.

thanks in advance.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0