Sign in to follow this  
Followers 0
nightfox

Using Laptop As Firewall

4 posts in this topic

I am trying to setup a laptop as my wireless access point and firewall. Basically, I have an account with a local wireless ISP but have only one STRONG wireless card. So I am setting up my laptop to connect to the internet with a wifi card and provide access to the rest of the network through LAN. (I also put some packet filtering software to force my connection to be through VPN but that aspect is properly configured). I am having major issues in the basic networking department.

I setup my wireless connection as a shared connection ( allow other network users to connect through internet connection) and went online.

ipconfig gave

Ethernet adapter wifi_card:

Connection-specific DNS Suffix . : xxxxx

IP Address. . . . . . . . . . . . : 192.168.101.21

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 192.168.101.1

(i get a new ip every time i connect to this isp)

I then setup my lan connection and in the section of TCP/IP properties I chose to set manual IP adress

192.168.101.1

and subnet mask

255.255.255.0

I then connected a crossover to a switch hub and from there ran a straight CAT5 to the client PC

In the LAN settings of the client PC I put

IP adress ........................: 192.168.101.xx where xx= arbitrary num ie: 40

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 192.168.101.1

I cant get online with the client, the router PC is online. I don't have much networking background but am trying to learn so any assistance would be appreciated. I am under the assumption that I am choosing incorrect IP adress.

Thanks

0

Share this post


Link to post
Share on other sites

Are you using Windows? (from the ipconfig bit I'd assume you are)

If so, you need to enable connection sharing. In Windows 2000/XP, go to Network Connections in the Control Panel. Right-click the connection your internet connection comes in on (wireless, in your case) and go to Properties. Click the Advanced tab, and you should see an option for Internet Connection Sharing. If you need more information:

http://www.annoyances.org/exec/show/ics

0

Share this post


Link to post
Share on other sites

I cant get online with the client, the router PC is online. I don't have much networking background but am trying to learn so any assistance would be appreciated. I am under the assumption that I am choosing incorrect IP adress.

Thanks

Yeah ICS is what you'll want to use as it basically turns the system into a router. I think you could also accomplish this by bridging the lan to the wireless (in windows xp).

0

Share this post


Link to post
Share on other sites

Crossover to a hub? Thats wrong in my book. Cables are:

like to like is a crossover (e.g. NIC to NIC or switch to switch)

like to different is a straight through (e.g. NIC to switch)

Other cables exist, but those are the main two. If you are certain you need a crossover cable for some strange reason than check the pin outs on the end. They can mess up easily if it is a home made cable.

Edit: I just reread your post. I may have gotten confused with your cabling. If the cabling defiantly works then disregard my stupidness.

Edited by qwertyman66
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0