Sign in to follow this  
Followers 0
Guest Possibly_sundevil

rtl8180 woes

24 posts in this topic

hey.

i'm a somewhat experienced (not a total n00b) user.

i can get my way around.....

:help:

i picked up a $20 wireless nic based on the realtek 8180 chipset.

i'm having a helluva time getting the running.

:(

i was running redhat 9, but am now running mandrake 9.1

i'm on a sony vaio laptop

p3 650 with 128 megs of ram

if someone can lend me some advice.....

i've recompiled the driver with for my kernel and have insmod'd it.

but i can't get the dang thing to light up and connect!

i know i'm being a little vague right now, but i don't wanna run through the whole narrative of my experiences with this card unless someone thinks they can help.

i've done a lot of reading on the various boards and discovered that getting this card to work under linux is bitch, but it is doable.

works fine under xp....but i'd rather not go there :blink:

0

Share this post


Link to post
Share on other sites

I myself have a card that is similar, Realtek Rtl8180 , is what cardctl info states it is. Branded, its an Edimax EW7106P, with Linux drivers that *should* work, however, I have yet to get any to work. I hate the fact that all these companies claim linux support, and then when you get the drivers, they are all redhat. RedHat may be a distrobution of linux, but it ISN'T linux itself. Please companies, help us out here.

Also, I will never ever buy from a company which the hardware doesn't have support any more. I am sick of being stuck in windows just to use some new fangled device that looks cool, but in reality just plain sucks.

0

Share this post


Link to post
Share on other sites

mycard ctgl reports

Socket 1:

product info: "Realtek", "Rtl8180"

manfid: 0x0000, 0x024c

function: 6 (network)

realtek supplies redhat and suse drivers.

i tried running redhat 9 and got nowhere

i switched over to mandrake and recompiled the driver.

that worked fine.

also insmod -f reported no errors.....

but now what?

i still need to config the card and get it running.

but nothin seems to work.

its very frustrating!

thankfully i have a land-lan-line (say that 10times fast) that works under linux so i can post this w/o booting into winblows.

but that doesn't do me much good

:help: :help: :help:

0

Share this post


Link to post
Share on other sites

Well, you are lucky, I got em to compile, but they would never actually work with the card. Now you use iwconfig to set it up. If you don't have the iwconfig program, use MDK's package management tool to install the wireless-tools package. Or get it off the web, in source form and install it that way.

To actually connect, you would use something like this...

iwconfig ethX(or wifiX or wlanX) option setting.

e.g.

iwconfig eth1 channel 3

Also, the last setting you should make is setting the essid. Once you set the essid, it "goes live"

and then you ifconfig eth1 up

but in order to set it up, the device must not be up.

What kernel are you running?

0

Share this post


Link to post
Share on other sites

2.4.21-0.13mdk

it took me a while... but ....

download the redhat9 drivers (as they use gcc3) and recompile it after adding the kernel to the makefile.

it should compile and give you the driver.

then /sbin/insmod -f should do it.

now to try yer suggestion.

maybe between the 2 of us,we'll figure this damn thing out

:unsure:

0

Share this post


Link to post
Share on other sites

i tried installed wireless_tools rpm and i get message that everything is installed.

but when i ls /usr/local/sbin the directory is empty.

what the hell?

0

Share this post


Link to post
Share on other sites

arghhh

so i finally got wireless_tools to install and ran iwconfig.

here's what i got:

lo no wireless extensions.

eth0 no wireless extensions.

Warning: Driver for device wlan0 has been compiled with version 0

of Wireless Extension, while this program is using version 15.

Some things may be broken...

wlan0 IEEE 802.11-DS ESSID:off/any Nickname:""

NWID:off/any Frequency:infGHz Access Point: FF:BF:21:00:00:00

Bit Rate=-1.07375e+06kb/s Tx-Power=-1073745692 dBm Sensitivity=1162167625/0

Retry:on RTS thr=-1073745692 B Fragment thr=-1073745692 B

Power Management-1.07375e+06kb/s:on

some things may be broken?

no shit!

:wacko:

how do fix it????

any ideas?

0

Share this post


Link to post
Share on other sites

I don't remember exactly what that means. You might need to recompile the driver, but, if it somewhat works, then why fix it?

No, seriously, I am not too sure, let me ask around. I tried those drivers, but I shall try them again. On a side note, got my cisco 350 working with kismet finally (updated to firmware 4.25.30) and using the sources from the 2.4.19 kernel in the pcmcia-cs package, which is quite fun to do in gentoo, manually modifying packages as you emerge them.

0

Share this post


Link to post
Share on other sites

thanks for asking around.....

this thing is driving me batty.

i messed with it all day. the driver compiles, i can force load it ...

but nothin beyond that.

the card doesn't light up or anything.

lsmod says the driver is loaded.

...

idunno :(

0

Share this post


Link to post
Share on other sites

progress?

:huh:

i recompiled the driver (hoping some kind of voodoo would kick and fix things)

insmod-ed it

and ran the wlanup script that came with the drivers....

the card lit up!!!!

woo hoo

then, before i can do anything....

kernel panic!

:grr:

:pissed:

here's the wlanup script

#Load module

/sbin/insmod -f rtl8180_24x.o

/sbin/iwpriv wlan0 enable

/sbin/ifconfig wlan0 172.20.14.180

echo "$(/sbin/ifconfig wlan0)"

not sure what caused the crash.

the driver?

:wacko:

0

Share this post


Link to post
Share on other sites

Sounds like it - and I am not going to make any progress personally, as my friend got a new laptop today (still trying to convince him to let me slap linux on it heh) and he needed a wlan card, so i gave that to him since he's being a windows slappy

0

Share this post


Link to post
Share on other sites

oh well.

thanx for letting me gripe.

perhaps i'll cave and buy a name brnad card with real support :P

i just hate not being able to do something that 'should' work

i'll probably keep fighting it

:ninja:

0

Share this post


Link to post
Share on other sites

I'd say keep fighting it - don't give up... hehe

You know you are close, not sure what is causing the kernel panic, have you tried checking the log? or what the KP says when it happens?

0

Share this post


Link to post
Share on other sites

I have a Netgear 802.11b card that includes the RTL8180 chipset. I run Debian unstable.

When I ran 2.4.40, I could use the pre-compiled rtl8180_24x.o with no problem. The moment that I upgraded to 2.4.21 it stopped working. Interestingly, it will insmod but is not reachable after that.

A recompile gave me the same error reported here: No problem insmod'ing, but no luck accessing. I did *not* get a kernel panic, though.

Hope this helps someone!

0

Share this post


Link to post
Share on other sites

Well I had the same problems. The RTL8180 drivers is in a kind alpha stadium, it's terribly unstable. The main problem I think is the pre-compiled module, it seems to cause the problems whenn you are trying to compile it for an other kernel than which it was compiled for (and that's Red Hat's Standard Kernel 2.4.18-3). The next problem with the drivers is that it's not supporting the standard wireless LAN extensions of Linux. That's why you only get garbage when you're trying to get any status via iwconfig or iwpriv or something like that. The only way to configure it is via some private wireless extensions provided by the driver. I hope Realtek is working on this problems...

However, I've got the best experiences (in stability) with that card under linux-2.4.21-pre3. What you have to do:

1) download linux-2.4.20 sources (e. g. from here: www.at.kernel.org/pub/linux/kernel/v2.4/linux-2.4.20.tar.bz2)

2) download the linux-2.4.21-pre3 patch (e. g. from here: kernel.atnet.at/pub/linux/kernel/v2.4/testing/old/patch-2.4.21-pre3.bz2)

3) patch the kernel, configure and compile it

4) use the SuSE 8.2 driver from Realtek and compile it with that kernel (don't forget to edit the Makefile to point to the right kernel directory)

attention: it can be that the driver reports an error during compile (something like that timer_t is already declared). To fix that open the rtl8180_type.h and comment the line out where the error was reported (with "//")

5) edit the wlanup and wlandown scripts provided with the driver

That should it be...

if you have further questions or need help you can contact me under fabius@webmasters.co.at

greetings,

Fabius

0

Share this post


Link to post
Share on other sites

I just bought a cheap bundle from acer with a lanrouter and a pcmcia-card.

It's just mysterious what I found while trying to get it work.

I took the drivers from realtek (2003-09-04) for the gcc3.2.2 and compiled it as described in the readme. (On Gentoo with 2.4.20-gentoo-r1)

After "iwpriv wlan0 enable" I got it work, but with about 75% Packet loss. My dmesg repeated a message like

RTL8180: Roaming...

RTL8180: Select a BSS and Join it at channel 6.

RTL8180: wlan_sta_tbl_add return false!

RTL8180: ----------------------------------------------------------

RTL8180: wlan0 Link status:

RTL8180: Channel number = 6

RTL8180: beacon period = 100

RTL8180: BSSID = 0x00:0x02:0x72:0x03:0x2e:0x63

RTL8180: SSID = local

RTL8180: Capability = 0x11

RTL8180: AID = 0x01

RTL8180: Operational rate = 0x0F <bit 0~3 = 1~11 Mbps>

RTL8180: ----------------------------------------------------------

in almost the same interval as my router's traf-LED is lights up.

for me the wlan_sta_tbl_add function seems to have a prob to log in the right BSS.

But why? I tried to change some values with iwpriv to set the channel etc. but there's always the dmesg-answer:

RTL8180: Use RTL private command [channel]

My english is not that good, but I thought that the driver tells me to USE the private command, but what's wrong with "iwpriv wlan0 wlan_para channel=6" ??? :huh:

And why is there no way to view the things I've configured ?

Das anyone know if the support becomes better the next weeks?

Eagle

0

Share this post


Link to post
Share on other sites

I just received my generic wireless card that uses this chipset. I thought it had the ADMTek chipset instead. I can't get the card to work in Linux. It can't get the BSSID correct. The BSSID should be the address of the router but it gets some random number (different every time) and it won't let one set it as an argument.

That 'Use RTL private command' message tells you that you are using that command. It tells you you have done something that works. This took me a while to figure out but I could see the results when I enabled the card.

It has no public configuration, for which reason iwconfig does not work. One must use iwpriv for all purposes.

One must also set the ssid, for example:

iwpriv wlan0 ssid=MyHomeNetwork

the docs nor the help screen tell one this.

0

Share this post


Link to post
Share on other sites

The new Linksys cards (WPC11 Version 4) are based on the Realtek Rtl8180 chipset I think. I had a WPC11 Version 3 and it was Prisim 2 and it worked find in linux. That card died on me and I went and just picked up another linksys. It ended up being a version 4 based on the realtek chipset so I just said "fuck dat" and I purchased a used Orinoco Silver card and now i'm very happy.

0

Share this post


Link to post
Share on other sites

hi all,

i have SUSE8.2 with an updated kernel 2.4.20. I compiled the realtek sources for suse and it worked (but with low performance). With KDE3.1.3 running i had often 48Kb/sec data traffic. ;)

realteks private part was compiled without wireless extensions and with kernel built in support for wireless (i don't know how).

I have compiled a new kernel for using apmd AND my wireless card. Result:

apmd runs fine, the wireless card hangs himself up after some time with a strange error message i naver had the days before:

TX low ... skb SPACE_CIRC=1

Befor this error i have placed some file in my /etc/sysconfig/network/ an the rtl8180_24x.o in /lib/modules/{Kernel}/ and a symlink in /lib/modules/{Kernel}/wlan-ng to this file.

Now this card is enabled by starting the hotplug and pcmcia facility. I pathed the wlanup/down also.

Does anyone have information about the TX bandwith problem??

jochen

0

Share this post


Link to post
Share on other sites
The new Linksys cards (WPC11 Version 4) are based on the Realtek Rtl8180 chipset I think. I had a WPC11 Version 3 and it was Prisim 2 and it worked find in linux. That card died on me and I went and just picked up another linksys. It ended up being a version 4 based on the realtek chipset so I just said "fuck dat" and I purchased a used Orinoco Silver card and now i'm very happy.

Note that linksys will exchange a ver 4 card for a ver 3 card. I'm in the process of figuring out how exactly to do that, but the box contained a not stating that one can exchange the card.

0

Share this post


Link to post
Share on other sites

Ok, so it isn't as easy as it should be. Running RedHat 8.0, 2.4.18-13 i had the same problems as described here. Getting the latest drivers from realtek, i noticed the file called rls_notes_822. This said these drivers [specifically the object they don't want us to have the src of] were compiled against 2.4.20-8 kernel.

So installed this kernel and now i can use the card as wlan0, no errors in /var/log/messages. I downed my eth0 and tried connecting to my lan, works fine. It only seems that the dns can't be found. Have to work that one out still.

It would be nice if realtek at least provides the object for all the kernels if they don't want to put the driver under gnu. Btw, i still get the kernelwarning when loading the driver, so hope that doesn't cause the dns problem.

So it works, but only for this kernel, that sucks big time off course, i got this card because when looking for linux-supported hardware that was available in my local shops, someone posted a message somewhere that this one worked fine. Thanx.

aavanderhoek@planet.nl

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0