lowlevelup

mplayer fullscreen, video won't stretch

5 posts in this topic

I've been trying to get mplayer to stretch the video to full screen. when I hit the "f" for fullscreen there just a black boarder. any ideas how to fix this?

0

Share this post


Link to post
Share on other sites

Try to change video output driver and see if it helps:

'mplayer -vo help'

This shows what drivers that were compiled:

'mplayer -vo $driver_name movie.avi'

This runs video with assigned driver. Then test the FullScreen function or you can type:

'mplayer -fs $driver_name move.avi'

Goodluck

0

Share this post


Link to post
Share on other sites

You could also launch the file in terminal with the zoom switch. Works everytime. ;)

'mplayer -zoom movie.mpg'

two things I like to throw into ~/.mplayer/config instead of typing that everytime ....

# zoom image for full screen

zoom=yes

# disable verbosity in terminal

really-quiet=yes

0

Share this post


Link to post
Share on other sites

thanks RightCoast, zer0dB i only have the one video driver :wacko: i need to recompile it with more drivers

0

Share this post


Link to post
Share on other sites

when you recompile, youre also going to want to use the xv video option, that allows for video stretching.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now