Dr. Z2A

Problems connecting to wired network

7 posts in this topic

Ok I have been connecting to my parent's wifi for internet on my laptop for a long time but they recently took it down and put a solely wired router in its place (they don't understand that crack is pretty much the only thing to do around here besides go on the comp, but thats beside the point). I tried connecting wired down to the router and found that I cannot connect wired down, it only does wifi. Heres my /etc/conf.d/net:

config_eth0=( "dhcp" )
dhcp_eth0="nodns nontp nonis"
config_eth1=( "dhcp" )
dhcp_eth1="nodns nontp nonis"

Can anyone tell me how I would configure my comp to be able to connect through both wifi and a wired down connection or what other information I would have to give if that config file isn't enough?

0

Share this post


Link to post
Share on other sites

I read that post three times, and I still don't understand what you're asking exactly. Post the details of your hardware/network. As it stands, the only thing I gathered was that you're using Gentoo.

Edited by pinhead
0

Share this post


Link to post
Share on other sites

yea need a bit more information I couldn't understand your post either

0

Share this post


Link to post
Share on other sites

something i found that works when i cant get wifi to work, is to drop the wired device (eth0 in mycase) or its possible that youre wired device isnt even running. check (as root) your ifconfig and if its not up try,

ifconfig eth0 up

then try and pull an ip using

dhcpcd -d eth0

see what happens.

you probably know these commands, but better to be safe than sorry.

good luck

0

Share this post


Link to post
Share on other sites

ok my wifi works great. I am trying to connect with a cable. When I remove the wifi card and start my computer with an ethernet cable plugged into it I get something like "error: netmount unable to start" or something like that when I am booting. I need help to be able to connect to the net with an ethernet cable. I don't really know what other information to give.

0

Share this post


Link to post
Share on other sites

you dont need to restart to use the wired conection. you can just use

#cardctl eject

and the machine thinks the pcmcia card is ejected. man cardctl

Can you post the output of:

#ifconfig -a

and:

#route -n

also if you can still use the wifi connection try emerging ethtool and show us the output of:

ethtool eth0

try

/etc/init.d/net.eth0 restart

dont wory about netmount unless you are using network file systems. My problem is usually related to correct ethernet adapter drivers(modules), or gateway/dns issues. First thing I try to do is ping the default gw, then ping my nameserver, etc.

Lastly, can you post the entire boot output of dmesg please.

If all else fails boot off a gentoo livecd and do a lsmod to see what modules it has loaded. The most common ethernet ones are e100, eepro, mii (media independant interface), and 3c59x. GL

Edited by b8zs
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now