sh4rk80Y

Wifi help

7 posts in this topic

I have a d-link DWL-G650 wireless card that I got for my laptop. It came with a program that comes with its own minimal program that recognizes some wireless connections. First off if I connect to a wireless connection I cant seem to get internet connection, like just open web browser and get google. Possibly could be somthing with my internet settings I dont know what though (btw Im running windows 98se)

I Also tried downloading some other programs like netstumbler and ethereal but they do not recognize my card. What could I do to fix this? Also if I boot up a live cd of linux Knoppix and try to use its wireless it does not work I know I will need to install drivers of some sort to get it to run on linux but im not very linux literate so im not sure how to go about this...

any help or comments would be great thanks..

0

Share this post


Link to post
Share on other sites
I have a d-link DWL-G650 wireless card that I got for my laptop. It came with a program that comes with its own minimal program that recognizes some wireless connections. First off if I connect to a wireless connection I cant seem to get internet connection, like just open web browser and get google. Possibly could be somthing with my internet settings I dont know what though (btw Im running windows 98se)

I Also tried downloading some other programs like netstumbler and ethereal but they do not recognize my card. What could I do to fix this? Also if I boot up a live cd of linux Knoppix and try to use its wireless it does not work I know I will need to install drivers of some sort to get it to run on linux but im not very linux literate so im not sure how to go about this...

any help or comments would be great thanks..

Use the latest drivers from support.dlink.com. Disable any other network adapters installed on the machine. After you connect wirelessly, can you pull an IP? Can you ping your AP?

http://www.wildpackets.com/support/downloads/drivers has the Atheros driver, but I don't think that will do much good in 98... 2000 and XP have built in wireless utilities, and it will work well in those OSes.

For Linux, I think you want the MadWiFi drivers. Should work out of the box in knoppix.... google madwifi for more info

Try iwconfig and see if it list ath0. If so, the drivers are there and you just need to configure your wireless settings.

0

Share this post


Link to post
Share on other sites

ok ill give those things a shot if I can figure it out ill help out other people if I know what im doing and talking about.

0

Share this post


Link to post
Share on other sites
I have a d-link DWL-G650 wireless card that I got for my laptop. It came with a program that comes with its own minimal program that recognizes some wireless connections. First off if I connect to a wireless connection I cant seem to get internet connection, like just open web browser and get google. Possibly could be somthing with my internet settings I dont know what though (btw Im running windows 98se)

I Also tried downloading some other programs like netstumbler and ethereal but they do not recognize my card. What could I do to fix this? Also if I boot up a live cd of linux Knoppix and try to use its wireless it does not work I know I will need to install drivers of some sort to get it to run on linux but im not very linux literate so im not sure how to go about this...

any help or comments would be great thanks..

Use the latest drivers from support.dlink.com. Disable any other network adapters installed on the machine. After you connect wirelessly, can you pull an IP? Can you ping your AP?

http://www.wildpackets.com/support/downloads/drivers has the Atheros driver, but I don't think that will do much good in 98... 2000 and XP have built in wireless utilities, and it will work well in those OSes.

For Linux, I think you want the MadWiFi drivers. Should work out of the box in knoppix.... google madwifi for more info

Try iwconfig and see if it list ath0. If so, the drivers are there and you just need to configure your wireless settings.

Okay using linux I was able to get some sort of Madwifi driver on it. I tired iwconfig and under ath0 there is some information. But now once I try and open the settings for wireless, or lots of other types of settings I was trying out I need a root shell password. Its a live cd Knoppix is there a default pass for this? Somthing like this actually happened to me before when I tried installing red hat on a computer and I couldnt boot linux beacuse I needed some sort of password too.. curiously just wondering is this related? But mainly what would I put for root pass to change settings.

0

Share this post


Link to post
Share on other sites

Here ya go man.

http://www.knoppix.net/forum/viewtopic.php?t=11500

And its been a long time since a Red Hat install for me. But I am pretty sure you choose a root password during the install, and you just forgot what you put. I know I have done it too. Everyone, I'm sure has done something like that once.

HTH

0

Share this post


Link to post
Share on other sites

great thanks for that link..

edit: just wanted to say that linux now recognizes my wireless card! (thanks) also found out that the reason I couldnt go online before when I thought was connecting before was my signal wasn't strong enough for connecting. The wifiLan thing on linux is showing a way weaker signal than that other program it came with running on windows.

Edited by sh4rk80Y
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now