• entries
    12
  • comments
    5
  • views
    21,730

Quickie... Linux Laptop Now Online

Sign in to follow this  
Followers 0
mirrorshades

800 views

Got it.I poked around the mailing list for wpa_supplicant for a bit... and while I didn't discover a specific fix for my problem, I did find that you can run wpa_supplicant from the command line with the "-dd" option for extremely verbose output. Dumping the output to a file, I found the following section that sounded kind of familiar to what I had seen with the wpa_cli app:

CTRL-EVENT-EAP-STARTED EAP authentication startedEAP: EAP-Request Identity data - hexdump_ascii(len=0):EAP: using real identity - hexdump_ascii(len=0): [NULL]EAP: buildIdentity: identity configuration was not availableCTRL-REQ-IDENTITY-0:Identity needed for SSID l33tEAP: EAP entering state SEND_RESPONSEEAP: EAP entering state IDLE

There was more stuff around it, but that basically repeated itself a couple times each minute. On a whim, I added the following line to my wpa_supplicant.conf file:

identity="/etc/ssl/certs/cert_19delta.pem"

One reboot later, everything was working like clockwork. The documentation for wpa_supplicant.conf is pretty spartan regarding the "identity" parameter, something along the lines of "an identity to be used for authentication". I had probably read it a number of times, but it never stood out as significant.Either way, all seems to be well at this point. Later I'll post copies of the various apps and config files, in the event that anyone wants to reproduce my work for their own environment. (Assuming anyone else but me is actually, you know, reading this thing....)


0
Sign in to follow this  
Followers 0


0 Comments


There are no comments to display.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now