• entries
    98
  • comments
    26
  • views
    78,098

Turning Touchpad Tapping Off so it stays off in Fedora 8

Sign in to follow this  
Followers 0
xKLAATUx

156 views

Turning Touchpad Tapping Off so it stays off in Fedora 8 The default touchpad settings of Fedora 8 "Werewolf" on an iBook G4 are frighteninly sensitive. The merest brush of the touchpad sends the cursor flying to the opposite corner of the screen. A slightly heavier brush against it and you've clicked on something by accident. It is enough to drive a former Mac user nuts. Under Ubuntu, it is quite simple to configure the touchpad settings with Gsynaptics. But for some reason, with Fedora+iBook it was quite difficult. Adding "SHMConfig" "on" to my xorg.conf rendered no results, and GSynaptics would not start. In the end, the answer lies in some serious xorg.conf modification, and since this is the only iBook I've tried Fedora on, I can't really say whether duplicating the following xorg.conf settings will definitely work for any Apple laptop or just the iBook G4 models or all iBooks but not PowerBooks...et cetera. However, this is my new xorg.conf, which seems to properly configure my touchpad so that it does not take Taps as Clicks. The first time I did this, it also seemed to have the side effect of disabling my fancy Desktop Effects (wobbly windows, desktop on a cube, and so on). I was willing to sacrifice the desktop effects since it really can't hurt to have that spare memory for more important things....but it was odd and annoyed me. I backed up the xorg.conf file, screwed it up to force an auto re-generation of the file, and then just pasted in the touchpad section. From then on, the touchpad worked properly and I also had my desktop effects. Here is my working xorg.conf: --------------------------(BEGIN) # Xorg configuration created by system-config-display Section "ServerLayout" Identifier "single head configuration" Screen 0 "Screen0" 0 0 InputDevice "Keyboard0" "CoreKeyboard" EndSection Section "InputDevice" Identifier "Keyboard0" Driver "kbd" Option "XkbModel" "pc105" Option "XkbLayout" "us+inet" EndSection Section "Device" Identifier "Videocard0" Driver "radeon" Option "UseFBDev" "true" Option "UseFBDev" "true" EndSection Section "Screen" Identifier "Screen0" Device "Videocard0" DefaultDepth 24 SubSection "Display" Viewport 0 0 Depth 24 EndSubSection EndSection ------------(END)


0
Sign in to follow this  
Followers 0


0 Comments


There are no comments to display.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now