• entries
    98
  • comments
    26
  • views
    87,856

About this blog

memory.dump

Entries in this blog

xKLAATUx

Documentation, for me, is a really important issue. You can see how as computer programmes become more complex and specialized to certain markets, how vendors are intentionally not documenting the application, so that third party vendors are then able to sell the "missing manuals" for an additional fee.There's an argument that could be made that technically the software company does not have an obligation to teach people how to use the program; instead theirs is to document what exactly it does, rather than how it is done. I do not agree with this for two reasons; firstly, because often people have paid too much for the software in the first place and deserve to learn how to use it for that price, and secondly because documenting how to use the application really is part of documenting what the application does, since the Results is the reason for the software's existence (that is to say, no one buys a software because it is ABLE to do something but in order to get something done BY it -- it's why we have Save, Print, and Export buttons).Many forms of documentation are guilty of this kind of thing, not just the manuals of proprietary software applications. Some *nix man pages are horribly written, without any clear indication of what the program actually does, giving instead a list of all the obscure options people can use on an application they know nothing about. Online tutorials sometimes do the same thing, assuming that the reader is pretty much exactly where the writer is, using jargon and shortcuts that would bring a noob following along to a grinding halt.I do the same thing in some of my tutorials sometimes. I try not to, but it's an easy trap to fall into.And there's the question of how far back must the author of a manual or tutorial regress to ensure that the reader is with them. Do I have to start simply how to launch the application? or must I tell the person how to turn their computer on, or maybe give them buying advice first, and so on and so on to further levels of absurdity.Realistically, a few steps of regression is all it takes, depending on what kind of tutorial is being written. If it's a tutorial on advanced color correction in Blender, then I must assume that the user has progressed in Blender enough to have edited some images together. I should NOT assume that they have ever used Blender plugins or the node compositing window.Just imagine opening a man page that read a little bit something like this.......(this is not a real man page but an example I made up, inspired by many real ones I have been subjecteded to)

Gamma and Luma Curve ToolAdjusts the gamma and luma of an imagecurve [in file] ... [options] ... [out file]-k adjusts the knee-s adjusts the shoulder-i use IRE values only--cont (contrast) is the multiplier for the value and expands the signal the center. If contrast is set to 0, there is no effect.  When contrast is 256 all values are multiplied by 2 (twice as bright). If the contrast is 512 all values are multiplied by 3. If cont = k*256 for some integer k (and zero gain) then Y becomes Y + k*(Y-128) (idem for the chroma). Although it is possible, it doesn't make sense to apply this setting to the luma of the signal.

OK while I'll admit that that makes a fair mount of sense to me, i personally doubt someone new to the process will get much information from that. What most users who really want to use it would hae to do is to map out a study plan for themselves with notes "find out what gamma is, find out what luma is, what's a knee and shoulder, what is IRE and how do I use it" - to say nothing of the question of what kind of values are we looking for here? percentages of IRE? the exact IRE you are aiming for? and wtf is all that stuff about contrast??Yes, the above man page documents accurately what the tool does and i can absolutely see it being a good rereference page (maybe man pages should be renamed "ref pages"?) for people who already know how to use the tool, but as far as proper documentation goes, it's not helpful at all.Good documentation -- for a good example, see the Image Magick software package. It's a CLI tool for image adjustment an even generation. That in itself is bizarre enough but to make matters worse there are 5 or 6 little apps within the Image Magick umbrella. Yet the man pages are informative and clear, and EXTRA documentation for people very unfamiliar with the program, is available as local .html files that can be easily viewed in any browser. It's the kind of documentation that you would, these days, usually have to pay $30 dollars for, or if you were crazy and bought the version of the book with the "Free Software Inside!!!!!" cd tucked in the back, you'd pay $50.Someone is obviously using these tools. So someone knows how to use them. And one of those people, who uses the software and knows it, is able to write proper documentation -- even a poorly written, grammatially incorrect document is a good start! To use the software we are working so hard to create, to say nothing of promoting its prolifieration, we MUST document and we must document WELL.Think of this -- given the choice between a well-documented proprietary software and a poorly documented free software, people will choose the proprietary. They may have to steal the proprietary software via a warez site, and they may have to pay $30 for the manual at their local book store, but at least they can learn it. If there is no such recourse for free software, then you can't possibly expect people to invest their time in trying to figure it out.Super Positive Winning Examples from our Free Software effort:Inkscape - between its own documentation and the absurdly prolific http://screencasters.heathenx.org tutorial site, inkscape has a lock down on howtos. Besides that, its a rocking app. Eat your heart out, Adobe.Blender - most of this is quite well documented and many tutorials are available on it. It is a very pro-level app, but I dont see how there is any more documentation on it than, say, Shake or Motion. There is a bit more on Final Cut by comparison, but Blender is still emerging as a video editing solution.GIMP - lots of tutorials, well documented app...but you know that when you are in the bookstore and you see a GIMP instructional book on teh same shelf as the Photoshop Classroom-in-a-Book series, that the GIMP has definitely arrived.Image Magick - very good, and logically laid out, documentation for new and experienced users alike.and so on and so on. I'm sure there area others but these are the ones I have most experience with.The point is, long live proper documentation! Read it, write it, correct it, contribute to it, make it easily accessible and tailor it to different user level needs. It's important!

xKLAATUx

change PATH in OS X

to change PATH in OS X:

$ cd ~ && vim .profile

In vim (or you can use nano if you want), add to the .profile document:

export PATH=/opt/local/bin:/opt/local/sbin:$PATH

...or whatever directories you are trying to add to your path. (the /opt/local/bin stuff is helpful becuase if you're running MacPorts like I am, you can just type in the name of the ported app you are trying to launch and it knows where to look.)That's it. You'll have to close your current terminal window in order for this to kick in.

xKLAATUx

mobileMe

Spewing forth more grumpiness about all things Apple... For a job I have a .mac account. No really, I do! I'm not paying for it but am advised to use it to transfer files to other people on the production crew (why we can't just use normal ftp is beyond me). So anyway, I use that email account to keep in touch with the people on the production (or post production, as the case may be) -- until the dark day that Apple decided to switc their service from ".mac" to "mobileMe".MobileMe is some kind of more-web-2.0-than-web-2.0 interface and was not in any way finished before it was released. The site is practically unusable on a Mac, and it's completely useless on Linux. Why? Because mobileMe checks what you're running, and so unless you disguise yourself with User Agent misinformation, you're not getting into your account from your Linux box.So when I first discovered this, I decided to go ahead and identify myself as another OS, and I chose Vista; logically that would be the one OS that Apple would discriminate against the most, right? They're classic arch enemies, everyone knows that. PC vs Mac and all that.Um, no, actually, Vista + IE 7 is fine. MobileMe licks that. Lets you right in. Linux OS with the kHTML based Konqueror? doesn't like that. Linux OS with Firefox? doesn't like that either.Bad decisions, Apple.In case you think I'm just ranting uselessly because I have betrayal issues with Apple, please don't just take my word for it. Refer to Apple themselves, who in an unprecedented move, is now blogging about the status of MobileMe, conceding that in fact, it's not ready for publc use yet:http://www.apple.com/mobileme/status/What's the worst part about this? Is it that they are discriminating against Linux? No. Big deal, what Linux user aside from me will ever go to mobileMe with the intention of signing in to use its services? (and no, even I won't be doing that any more in spite of what my fellow workers are saying; I'll just have all the mail forwarded to another address and use an ftp server and everyone else on the team will just have to learn how to get their Mac to talk FTP)Is it that Apple seems fine with Vista users over Linux users? Nah, who cares? Let the Vista users sign in freely; what's the difference between one Proprietary OS and another, really?The worst thing is that this shows a little about how Apple regards its customers. The .mac online service is sold as something that someone can use as their all-in-one online solution; email, webspace, and various media services. It costs money. The post production team I'm working with was relying on those services for a smooth workflow. It kind of hurt a little when all their email aliases disappeared on them. It also hurt when their email just went down at critical moments. It really hurt one guy when he had to re-install his entire OS because his OS refused to believe that the webDAV "iDisk" that he was paying for was actually his (he had to keep signing in as a guest, but then could only access the folder with guest access). But what hurts most of all, I think, is the realization that the data they are working really hard to produce, is in the hands of, and at the mercy of, this service. Something tells me we'll be migrating from that particular solution...

xKLAATUx

I've submitted this to Apple through their "feedback" webpage, although I couldn't quite find a completely accurate category for it, and I certainly won't be hearing back from them about it, so I'm posting it here as well because it annoys me, and I'm tired of people telling me OS X is perfect.Bug: When an application is installed as Admin User, and launched for the first time as Normal User, the application continues to ask whether User is aware that it was downloaded from the Internet every time the User opens the app.To Replicate:1. Log in as Admin User (the true Admin; the first user you created when you opened the computer)2. Install an application; Firefox, Adium, Cyberduck, Inkscape, Gimp...whatever.3. Do not launch those apps.4. Log out Admin User, Log in as a normal Non-Admin user5. Launch one of the apps you've downloaded. It will warn you that it was downloaded from the Internet.6. Close application. Re-launch. Same warning dialogue box.7. You can repeat this for weeks on end; the dialog box will never remember that you are fine with the origin of the application.8. Log out Normal User, Log in Admin User.9. Launch an app, OK the warning dialog.10. Log out Admin, Log in Normal. Launch app. No more warning dialog.This is not a security "feature" but a bug. A feature would be to present the User with the warning, and then the opportunity to Authenticate as someone with Administrative Privileges and make the dialog box go away for ever. No, this is a problem with where the system is trying to save the preference file dictating whether or not that application has been launched before. They need to adjust that, or else provide a secure way for the User to OK the app. Remember the old Apple ad in which Apple makes fun of Windows for having constant warnings -- "Accept or Deny" -- all the time? Well, this feels a lot like that.I tried taking informative screenshots but only just now realised that there is no date in the Mac OS X time/date display. (OS X's only been out for five or eight years or whatever...and I still can't get used to the fact that they don't give you an option to put the date in the time/date bar.....!)blogentry-14173-1217433253_thumb.pngThree weeks agoblogentry-14173-1217433261_thumb.pngTwo weeks agoblogentry-14173-1217433269_thumb.pngand it's still there this week...

blogentry-14173-1217433253_thumb.png

blogentry-14173-1217433261_thumb.png

blogentry-14173-1217433269_thumb.png

blogentry-14173-1217433253_thumb.png

blogentry-14173-1217433261_thumb.png

blogentry-14173-1217433269_thumb.png

blogentry-14173-1217433253_thumb.png

blogentry-14173-1217433261_thumb.png

blogentry-14173-1217433269_thumb.png

xKLAATUx

dynamic dns

HOWTO set up Dynamic DNS to your Linux BoxHOWTO Make Your Mac a Web ServerI've posted two Dynamic DNS howto's on a site, with lots of screenshots so it's pretty easy to follow. Neither are completely perfect but together they give a pretty good overview of how to do the whole dynamic dns thing. An HPR episode covering the Linux tutorial is forthcoming, as well.They're really basic, too; it's just that I know nothing of networking and just figured this stuff out. I'm sure someone out there will find this useful (unless I really am the only person who didn't know how to do this already).One was done on my Linux box, on how to set up Dynamic DNS so you can SSH to your home computer from where ever you are. This tutorial resulted in my desire to...SSH to my home computer from where ever I happened to be.The other is how to put your computer on the world wide web...which I didn't want to do with my own computer because I don't know enough about security yet to subject my own data to the internet. The answer? subject a computer at work to the internet! So all the screenshots on the Howto Make Your Computer a Web Server were taken on a Mac at work, and in fact relies heavily on the fact that in OS X Apache is already installed. On a Linux box, were I to ever try this, I'd isntall Apache with the Linux Reality Home Server mini-series close at hand.Enjoy. Hope it helps some noob out there.

xKLAATUx

ChrisInDallas in IRC asked me in what way Leopard was broken. I told him I'd have to write a blog about it because the answer would be too long. This is the beginning of that blog post; although I know it will be something that will grow over the course of a few days, as I see past all the hacks I or other people have had to do in order to unbreak it.Where applicable, I note whether I have filed bugs on the complaint.How broken is Leopard? Well, people use it everyday and are happy with it, so I guess not really that badly. On the other hand, the next OS X release is called Snow Leopard and is by Apple's own admission at WWDC basically one big bug fix. In other words, this is the "real" Leopard. I gather that the current one was just an anti-Vista thing. Snow Leopard will feature bug fixes PLUS it will be 64-bit. Oh wait, I thought the current one was advertised as 64-bit? Well, it was...but this time it's actually going to be 64-bit.Virtual Desktops At first, using this is pretty nice, because you think - finally, even though I have to use a Mac for this job, I can at least have Virtual Desktops! But after a few days, you start getting the feeling that Apple just basically saw the Virtual Desktop thing on someone's Linux box, didn't really try it out themselves before borrowing the idea, and shipped it. Forget about X11 non-integration, their Virtual Desktops can't even handle its own native Cocoa space. Clicking on an icon in the dock will zip you away to another desktop whether you like it or not...seemingly at random, too. Actually it apparently bases the location of the app on where your last click was in that app. So if I have a file manager window ("Finder") open on Desktops 1 and 3, if I was last in desktop 3 but now am in Desktop 1, and I click on the Finder thinking it will reveal the Finder window there on Desktop 1....no, it will throw me over to Desktop 3 because that's the instance of the Finder that received the most recent click.Other problems include not being able to prevent applications from whisking you away to another desktop; if you're typing in one application and, say, Safari completes a download and wants to tell you about that, you will simply be interrupted, taken over to the Space that Safari is notifying you in, and you have no way of preventing that.Et cetera.Your Vista Flavoured Warnings Have ArrivedPop up dialogue boxes (that steal your window focus, naturally) notifying you that an application was downloaded from the internet - are you sure you want to run it? Well...yes, I want to run it, just like I wanted to run it yesterday and the day before and the day before that. When will it stop notifying me that I downloaded Firefox and Adium and Gimp and CyberDuck and Audacity and all the Free Software I use at work - from the internet? Where is the little preference box that makes this nonsense stop? And why isn't my FIRST acceptance of this notification being logged in a .plist somewhere?ACLThis is not well documented yet, but Apple is using an ACL structure for its files now - akin to SE Linux. It's very low-level code controlling access to files, superceding (or preceding) regular Unix File Permissions. This doesn't seem like a problem until an innocent user backs up their system with the much touted TIME MACHINE and then attempts to restore. Quite often all will go as expected, no problems. But for some people (myself included, but also a friend of mine, and a few other cases online that I've seen) the attributes of the ACLs will insist that the new computer setup just does not have permission to do anything with those files. The solution seems to be to enable root, log in, move the files around, get the attributes re-assigned, and then you're good to go...but doing this recursively through your entire backed up system is no small task. Hopefully this won't ever happen to most Leopard users because it's a real pain. No bugs filed yet, as I feel more regression and research is required.FinderAs a File Manager, Finder is a no better than, say, Nautilus (just kidding, Gnome fans). Seriously, it does not compare to Konqueror. To be fair, little does - that's why Konqueror is Konqueror...but this Finder thing has been around for a LONG time and even the Mac community has banded together to insist that it improves. Don't believe me? Google "fix the finder" or "fix the fucking finder" and see how many hits you get. Some examples, some old some new to show just how long this has been going on:http://www.roughlydrafted.com/RD/Home/FB94...6D7C658A01.htmlhttp://forums.macrumors.com/showthread.php?t=215412http://alek.xspaces.org/2005/05/04/FTFFhttp://www.macnightowl.com/2006/06/the-leo...rface-for-real/http://www.shoulddothis.com/suggestion_details/1051http://joechip.net/brian/2006/11/27/ftff-m...fucking-finder/http://theappleblog.com/2007/04/09/hey-app...button-already/Some of the better points:The GREEN button...what is it supposed to do? because it doesn't seem to do anything consistently. It seems like a "re-size my window to any random dimension" button.FTP support. I can browse my webDAV volume with one click (the $100 iDisk) but not an FTP server? Um, stupid. Solution here.Stop making invisible files! Having been through teh moving-away-from-Mac-to-Linux thing, I know first hand now just how much meta data OS X litters your stuff with. And you know what? I'm not talking about just a little here and there, I'm talking about A LOT of extra data. Going through my data now on an XFS volume, I have freed up almost a quarter of the drive just by doing an rm -rf ._*And so on...X11 This is a well-known and now mostly solved problem, but OOB Leopoard featured a very broken (as in, would not launch, would not do what it is supposeed to do) X11. My take on the situation was always that Apple seems to think it's fine to take credit for Free Software in their system, because they advertise it like it's features that they may as well have invented, but when they break a Free Software element, they are quick (and they were, read the X11.apple mailing list) to disavow themselves of any responsibility. Nice position to be in; you take credit for the stuff that works and blame upstream for the stuff that doesn't.QuartzWMThis is that resource-hungry but ever-so-marketable graphic layer that's flopped on top of all that pure, beautiful Unix code. It's the public face of the Mac. It is the QuartzWM (window manager, plus Dock and Dashboard). The Finder is, strictly speaking, the File Manager, even though most Mac users kind of interpret it all as the same thing, which makes sense because it all feels like the same thing...but I digress. QuartzWM cannot be turned off. You can move components of it from the /System/Library and it will prevent the Dock and Dashboard and Desktop from functioning, but you still can't get away from that Cocoa layer. (Yes, super-geek, you can boot into Single User mode but everything's turned off so you won't be networked any more so have fun reconstructing your system with GNU tools and fw-cutter drivers and so on).X11Did I say this issue was fixed? Well, it is, but X11 has always been very tenuously integrated. To this day, running an application within the pure Unix environment that is X11 on a Mac requires fancy Cocoa (obj-C) and QuartzWM wrapping. And it doesn't always work very well. Focus-stealing problems abound. Apple's Virtual Desktops still don't understand X11 and will just change desktops randomly while you're working in GIMP or Inkscape or whatever X11 app you're sporting. The xterm, which I frequently use instead of the Cocoa Terminal.app (simply because I always have X11 open anyway) does not share a clipboard with the rest of the system, so copying and pasting into it is basically not possible. Dragging and Dropping is of course out of the question. Quitting an X application from the QuartzWM often causes minor crashes. Honestly, it's almost easier to just install VMware or Parallels and run your Unix(-like) OS in a VM instead of dealing with the way Leopard does(n't) deal with X11.LibrariesThis is one of those things that you don't hear complaints about from your average Mac user, and admittedly this is a pretty specialized problem...but it's indicative of deeper problems, I think. Here's a quote from codeSpeak.net:Apple regularly ships new system releases with horribly outdated system libraries. This is specifically the case for libxml2 and libxslt, where the system provided versions are too old to build lxml.While the Unix environment in Mac-OS X makes it relatively easy to install Unix/Linux style package management tools and new software, it actually seems to be hard to get libraries set up for exclusive usage that Mac-OS X ships in an older version. Alternative distributions (like macports) install their libraries in addition to the system libraries, but the compiler and the runtime loader on Mac-OS still sees the system libraries before the new libraries. This can lead to undebuggable crashes where the newer library seems to be loaded but the older system library is used.OK, so my dad doesn't care about this. It's probably not gonna effect his iPhoto or iTunes (well unless he tries to download a fancy Python-based plugin, I guess). But for some of us (myself included) this is actually a problem that appears regularly enough to require interesting workarounds.XcodeOK this isn't broken, but I wanted to mention it because I saw a surprised blog post from a developer about this and it made me chuckle a little. Apparently not everyone realizes that Xcode, the Apple developing platform, is an IDE for ONLY Cocoa programs. (Well, there are some exceptions; you can write the code in Xcode but your GUI set is limited to the Cocoa Interface Builder.) So don't open up the Dev Tools on your new OS X machine and expect a full-featured, flexible IDE like Eclipse...heck, or even like emacs. No bugs filed.CompilingIt's hard to compile stuff written for other *nix systems on a Mac, just warning you. Again, not broken...but Darwin is not the BSD kernel. It is not the Solaris kernel. And it certainly isn't the Linux kernel. No bugs filed, because it's not a bug. I guess I could enter it in as a Feature Request to change what kernel they use...File SystemsApple will be supporting ZFS soon (that's one of the new features of Snow Leopard), but until then the File System support is a joke. Microsoft and Apple are OK to use, but both their File Systems are arguably really bad! I hate the vfat format..seems like a bad joke...and HFS+ has broken down (lost contact with its journaling components, or just ditched it header files for no reason) too often for me to trust it. This is why you don't see REAL mass storage using these formats! So why shouldn't I be able to just pop in a drive formatted as XFS or ext4 or whatever, and have the Mac read it? No good reason, and the fact that I can't weakens the platform. For a while Mac seemed to have some support for UFS, although I could never get that to work...and then they had read support for ZFS...apparently in Snow they'll have it all...but only for ZFS. That's one file system out of quite a few good ones out there. That's a bug, in my mind, not just a feature request. No bugs against this from me, yet...SpacesWhy isn't Spaces -- their virtual implementation of virtual desktops -- turned on by default? EVery time i install OS X I have to go and set up Spaces?? It was a hugely advertised feature of the release, but it's not actually on OOB. Bugs have been filed.Remote Set UpI pity the sys admin (great or small) who has to install Leopard onto multiple machines. Managing this OS remotely was just NOT in the design. Sure they have Apple Remote Desktop, and sure that does some things remotely. But not that much, and to this day even Mac supporters who have to administrate OS X networks - for real - have issues with the lack of remote administration. And no, OS X server release does not fix most of these issues. Remote management of the server is also fairly well broken, to the point that physical presence is necessary for a lot of important administrative tasks. Many bugs against this have been filed, not by me but by others.Remote Set UpThis has been fixed but there are discs out there that were packaged before the fix, so it's worth noting. The initial run of Leopard featured a bug that would in some cases reset the administrator's password to an unknown value when upgrading to Leopard. The only fix to this, once it has occured, is to boot from the installer DVD, enable root, log in as root, and change the administrator's password.Compression ToolControl-Click on a file in the Finder and a contextual menu offers to compress it into a zip file for you. The problem? it generates an invisible file called ._MAC OS X or something like that in the archive along with your files. Not a big deal, right? Well, not until it crashes someone's Windows or Linux box. Not that it does crash other systems reliably, but it has happened enough times to me that just .tar.gz from an xterm when possible. (It's not always feasible, depending on where the files are being posted, though; some servers I deal with at work won't allow .gz or .bz2 files so I have to .zip). Bugs have been filed.Insert New Drive == You Must Mean Use This Drive as Aa Backup DriveHelpful prompts are great. I think they're really user-friendly and actually make an OS feel polished, like the programmers were really thinking of the User when they implemented something. But this is ridiculous; I plug in a drive that OS X doesn't remember, so it wants to either Initialize it (ie, erase) or it wants to use it as a Backup Drive for Time Machine. Can't you imagine a number of times that you might want to insert a drive NOT for the purpose of using it as a dedicated backup drive? But with just one click you can turn an empty drive into a Time Machine drive -- it won't kick in right away and you can deactivate time machine, but the computer still sees that volume as a time machine volume, whether you like it or not. Yes, you can reset everything and undo stuff with a bit of effort, but it's a pretty nice annoyance. (See the Vista-Like Dialog Boxes complaint above.)The good news:Really solid solutions for ALL of this can be found here or here or here.

xKLAATUx

Linux on a Mac?

I have to say that running Linux on a Mac laptop isn't necessarily the greatest way to run Linux. It's the best thing to happen to the Mac in its lifetime, I'm sure, but it's just not terribly pleasant for a few really minor reasons.There's no physical right-click. This is kind of Linux's fault for implementing the whole Right-Click thing, but it's also the Mac's fault for not just slitting the stupid trackpad button into two-halves already and providing for a right-click.Broadcom. These are the wireless cards Satan sent ot Earth to curse mankind, and for whatever reason, Apple uses them in their Airport-branded cards. Not only are they not versatile cards but they also don't have open drivers. Depending on how new or old the Broadcom chip is, it may be really hard or fairly easy to get it working.Keyboard. This might be a PC vs Mac thing that carries over into Linux vs * but after you get used to having thngs like "Insert" and "Print Screen" and useful keys like that on Linux, you start to miss them on a Mac running Linux. The Insert key especially makes it really easy to paste things into your terminal, so I miss that when I'm on a Mac using Linux.I think that's it. Otherwise they're great machines. I need to test drive A LOT more laptops with Linux before I start championing any platform for the job....although I will say my eeePC is pretty nice.

xKLAATUx

It's not easy dying hair. A few punky types will resort to the spray-in stuff, but that's temporary and acts too much like hair spray. I'm talking about real dye that you apply and it goes everywhere and stains your skin and your whole bathroom until your parents or roommates get so angry they move out. But how to do this correctly? Well, I've been dying my hair for a while now, so I kind of know a thing or two about it, so let me share tips:

Regardless of the shade of your hair, you're really going to want to bleach it first. It's not the colour that you need to get rid of, it's the oils and natural texture of the hair that you need to zap. Getting hair bleach from either a beauty supply store or just from the same box, hopefully, that you get the coloured dye in, is essential. If the dye you get doesn't include bleach with it, then you'll need to go to a beauty supply place and get some on your own. It's not as intimidating as it sounds; the beauty supply store know everything and if you just ask them what you need they will hook you up. But if you must know, the stuff you need is called Blue 40 (or something like that). I don't know why it's called "Blue" because all it does is bleach your hair.

I probably don't need to say this...but do not use laundry or household bleach. Bad idea. Hair bleach is something completely different and it's just an unfortunate twist of semantics that we call "bleaching" hair by the same word as "bleach" for household use.

So bleaching not only zaps what natural colour is in your hair, but also it causes you hair to be porous and dry, which is what the artificial colouring wants. If you think that you ahve light enough hair and you think you don't need to bleach it, and you try to colour your hair wihtout bleaching it first, then you will find that the color lasts all of 10 days. The dye just doesn't take hold on non-bleached hair. Trust me!

Most hair bleach bottles tell you how long to leave them in your hair. It's never long enough. I don't have very dark hair naturally, but I always leave it in for as long as they tell dark haired people to leave it in, and that just about does the trick. It will sting the scalp a little, although supposedly there's a way to do all of that without really touching the scalp. I could never figure it out, and if it takes me longer than 4 minutes to put the bleach in and go about my business, it's too complicated. So I just slather the bleach in (with gloves) and go sit in front of the computer for an hour.

Eventually the hair becomes an ugly yellow, and feels like straw. So, go wash out the bleach, wait until your hair is dry, and then break out the coloured dye.

Slather the skin around your hair with Vasoline or something similar. It will save you a lot of embarrassment later on.

Put gloves on - and fairly sturdy ones, too. Really cheap gloves will tear and you'll get coloured dye all over your hands. Again, embarrassing. Luckily if this happens you can just say you're too punk to care, which is what I usually do, and it usually works. But not on girls. They know better. They know you just screwed up and will laugh at you, inside. You'll be ridiculed. So either use sturdy gloves or stay at hom for the next week.

OK, so you've got gloves, so start putting the dye into your hair. Some people will have a friend do this for them. Some people will take hours doing it to make sure it's perfect. Me? I just slather it in. If I miss a spot, I call it my Style. If I get dye all over my ears -- it's ok because I've got vasoline protecting them! Actually, I'm pretty sure that for a few days after I dye my hair I look like a mess, with colour on my neck and ears...so take my advice, if you want to look cool then you ought to be careful and take more than 5 minutes to make it happen. Enlisting a friend might be helpful. I wouldn't know cuz I've never gone to the trouble.

Leave the dye in for longer than the box suggests, too. You want the dye to really cling to your now-porous hair.

Once it's all settled in, wash out the dye. Some people can do this in a sink...but that's way too hard for me. I just wash it out in either the shower or under a bathtub faucet, even though it stains everything it touches. Again, I don't care...but my roommates have been known to scold me for it.

A LOT of dye is going to wash out. For a long time. The important thing is that the color has been absorbed into the hair, though. The excess will continue to stain your towels and pillows for weeks to come. Enjoy!

The best brands for hair colour that I've found so far are:

Splat! -- a brand I'd never heard of but found by accident in a Rite-Aid, a West Coast pharmacy. They only have blue and red, though.

Manic Panic -- not the be-all and end-all of hair dye that its reputation would suggest, but it does work better than, say, Punky Colours.

And if you can't find either of these, just go to a beauty supply store. Really, those places have all kinds of supplies...although it's not, in spite of the name, guaranteed to make you beautiful.

Good luck!

xKLAATUx

configure vim

I read on Roland Wolters blog a great tip that I am now placing in my own so it's handy.if you're on a system that's not working the way you want it to, then you may make a .vimrc file in your ~ directory with the following arguments:set laststatus=2syn onfiletype indent onset aiset nuset icand so on. whatever you like for your vim. Don't know what you like? probably whatever you're used to; go to your ~ and look for a .vimrc and grap a copy of it. Drop it onto a USB thumbdrive or whatever. It's just really handy to know, especially if you're dropped into a computing situation where the system isn't pre-configured the way you are used to it being configured. I got so used to how vim worked on most default linux systems that I was really thrown off when I was using vim on the Mac at work. Hence, this post.

xKLAATUx

more KDE Tips

I don't know the exact expression I'm looking for, but it's something like "I'll abandon KDE 4 after you pry it from my cold, dead hands" or something violent and morbid like that...and yet, strangely positive.Yes, KDE 4 has some bugs. But you know what? So does OS 10.5 Leopard and yet people are running and loving it... How buggy is Leopard? oh, only so much so that at the latest WWDC they announced that they're releasing a REVISION of Leopard called Snow Leopard...basically a bunch of bug fixes...which is why they'll be giving this revision away FOR FREE. Apple never gives anything away for free!! but apparently that's just how bad they feel about Leopard...So KDE 4 is my primary desktop on my main laptop and here are some things that I've found make it work like, I think, it was intended to work.kill the desktop iconsI get the feeling that desktop icons on KDE4 may not be entirely intended. Of course, somewhere Aaron Seigo may be hacking away at trying to make them proper, but I'm one of those people who really just prefers a clean desktop anyway, and so I say get rid of desktop icons on your KDE 4 system. You'll feel cleaner for it, and it'll save you the trouble of dealing with KDE 4's wonky implementation of the concept.How do you do this? First get all the files that were/are on your desktop into some other directory. Preferably where they belong; put Documents in Documents, Music in Music, Movies in Movies....or dump them all in your big pile of junk...however you organize your stuff, do it now.Then right-click on the desktop > Configure Desktop. At the bottom of the Configure Desktop window, you'll see two checkboxes: one for Show Icons and one for Align to Grid. Uncheck them both.Move Your System Tray into a PlasmoidThe Kicker down at the bottom of the screen is great for four things:1. K Menu2. Task docking3. Desktop Switcher4. Device Notification5. Date and TimeNotice that System Tray is NOT present. For whatever reason, the kicker is having a hard time keeping up with different system applets. I start Pidgin, and a new icon appears, but then a system update alert pops on and moves stuff around...and suddenly I have blank boxes where applets used to be, and all kinds of mess. Not fun. These little applets seem to like it better if they are there own malleabel plasmoid (aka "widget"). So right click on the general System Tray section of your Kicker (depends on what distro you're running as to where this is located) and REMOVE system tray.Now go to the upper right corner of your screen to add a new widget, select Add New Widget, and find the choice for a system tray. This will drop all those applets into a snazzy looking bar on your desktop, which you can position anywhere you please. I have mine in the upper left corner.Learn to Tweak Settings in Config Files...or just delete config files. Should anything happen to your KDE 4 desktop, like the Kicker getting mangled because you're screwing around with it too much, or whatever, you can always do a couple of things to fix it. The quick and dirty way is to mv ~/.kde/share/config ~/.kde/share/config-old which renames the directory containing all your little config files for KDE 4 so that if you log out and then log back in, KDE 4 regenerates all your config files. This puts you back at the default configuration, of course, so if you've made changes then you get to make them all again....but we're assuming that if you've done this then your current configuration was bad beyond simple repair.If, on the other hand, you just feel like something is just a wee bit off, then cd ~/.kde/share/config and have a look around. Lots of little config files (or in Mac terms, ~/Library/Preferences files). Since anything you screw up here can always be regenerated automatically, so it's safe to take a few chances.More tips as/if I stumble upon them. For more tips on making your KDE destop really fun to use, see my earlier post in which my friend Skirlet and I went through the System Settings and figured out what everyone forgot to set - like drop shadows and effects and stuff like that....

xKLAATUx

GIMP wishlist

I needed a place to keep track of GIMP shortcomings, and this is gonna be the place.To preface this: this is NOT a list of complaints or gripes, it's just a wishlist, and things that I notice are missing from GIMP that are present in Photoshop. I use GIMP exclusively, but I used to be Photoshop certified and I used it A LOT. When I'm recommending GIMP to people who are used to Photoshop, I figure it's good to know what's NOT there. Plus, if I ever get involved with the GIMP project, I'll have this nice list of improvements that could be made.This is also kind of a list that I might use if I ever get around to comparing Pixel with GIMP.But my primary goal is to list things that GIMP can add to their feature list so they can smash Photoshop once and for all :)So...1. Text tool needs HUGE improvement; shouldn't need a new dialogue box just to do text. Text should be able to be typed right into canvas. It's probably worth noting that this is pretty well implemented in Inkscape already, in which you can type into and manipulate the path of the text, live. However, even in inkscape you have to open up an entirely new dialogue box to try out new fonts.1a. Text bounding box - I want to restrict my text within a certain area and then be able to change the width and height of that area later on and have the text adjust with the new shape of the area.1b. Individual text attributes; if I have a long sentence and want one word in the middle of it to be italics and the word after it to be a different font, I should be able to do that without a huge workaround involving duplicating the text layer, deleting every word but the word I want to effect, etc..1-bottom line- Text tool really needs to be a little embedded text editor like gEdit or Kwrite or whatever. If it is not, then it is not a real text tool to be used for design. Not today, anyway. Photoshop has had a really dynamic text tool since version 7, and they're at the equivalent of 10 or 11 now.2. Dynamic Text transformation - text shouldn't need to be rasterized when being rotated or stretched or whatever.3. Mass deletion of layers - there should be a way to select two or three or ten layers all at once in the layer window, and delete them.4. Mass visibility of layers - even photoshop doesn't have this: select lots of layers, right click, and set as invisible or visible.5. layer grouping - should be able to place multiple layers into a layer folder.6. constrain selection tool dynamically. i know you can SET the selection tools to contrain themselves to a certain aspect ratio, and that works for me... but honestly it would work better if I could do that with the press of a key, in the moment.7. Ability to restrict movement to 15 degree angles - one should be able to hold some hotkey down (traditionally it's shift, in a lot of programs of varying types) to force the mouse to drag things only in straight lines within 15-degree angle increments. As far as I can tell, the only way to move something in an absolutely straight line is with arrow keys in GIMP. (I don't mean the paintbrush or pencil; I mean selection tools and move tool and things like that.)8. Single window interface. Again, learning from Inkscape (and I think the new Krita does this, too, although I ahven't tried it yet), the one window interface works really well. I wouldn't have known it, because of course photoshop is not a single window program either...but the multiple windows of gimp just get lost in the shuffle on all the monitors I use it on. I'm not saying lock anyone into a single window, but I think I'd like to try it. Palettes could be brough up as needed, tool bars would be quickly accessible. Something to try.9. more to come as i find things. i <3 gimp.

xKLAATUx

slackware 12 on sony vaio vgn-n250n - a love story _________INSTALLATION ___________ So I downloaded and installed Slackware 12. First, I backed up the stuff I had on the computer just in case I screwed it all up. I didn't have much personal data on there, so it all fit onto one CD-RW. My harddrive was already partitioned, so I didn't have to do anything except define for the installation which partition I would be using. In my case, it is the /dev/sda1 partition. Linux also wants a SWAP partition; that is, a small partition for, what we in the Mac world would call Virtual Memory. I already had a swap partition, so I just pointed Slackware 12 to it. It is worth noting that I might have three distros of Linux running on my notebook but I only need one SWAP. I also have a tiny little partition at the front of my drive to serve just as the Master Boot Partition. This is where the boot loader exists, so that I can choose what partition I actually want to boot into. This is akin to holding the OPTION key down during starting Mac OS X and choosing whether one wants to boot into one partition or another, or into OS 9 back in the old OS X days. Other than these details, installation was as easy and friendly as installation on any system, minus the pretty graphics. __________SETTING UP X________________ The system was installed. I logged in as root and began setting up a GUI environment because I figured it’d be somthing easy that I could get out of the way quickly. Because of my NeXTbook project, I was really familiar with X11. And setting it up in Slackware 12 was, as expected, pretty easy. Compared to what I was having to do with my NeXT project, it was actually really easy. Slackware 12 includes a xorgsetup script that prompts the user for screen resolutions and refresh rates. Sony does not publish any of this information - I have read through all their documentation and can attest that it is nowhere on their site or in anything I received with the computer itself. To find it all out, I had to reboot into Ubuntu, look at the auto-detected settings that Ubuntu had generated, write those down, and enter them in as my set up in Slackware. Thanks, Sony. As I mention in my previous post, the “FINDER” post, in Mac OS X the Window Manager is quartzWM. I guess we would generally or flippantly call it Aqua. Anyway, whatever it’s called it generates and controls everything we see onscreen. If one tries to run X11 on the Mac, quartzWM does its best to control X11, and getting X11 away from quartzWM is a real trick (which I have figured out and will detail in the forthcoming NeXThack episode of The Bad Apples). We generally think of everything we see as THE DESKTOP or THE FINDER, but they are very separate programs; see my previous post for details. The Finder, proper, is the “File Manager” of OS X and simply gives us access to graphic representations of our files. There is a published hack to Quit the Finder and have no access to one’s files except through line commands in the Terminal. So, on my Slackbook my Window Manager is Fluxbox (which, unlike many window managers for linux, does not model itself at all after Wind0ze but is much more like NeXTstep). I have not configured a file manager for it yet, because I happen to know that I have many choices, so for now I will access my files via my xTerm (Terminal). __________WIRELESS CARD DRIVER_________ Now I had to install the wireless drivers. As I said above, I found that the drivers I needed were included on the Slackware DVD, as were some very clear and helpful instructions (much more helpful than Intel’s documentation included with the drivers). So I installed the drivers easily, without a hitch. Well almost: By now I was familiar with the usual Unix installation commands: % ./configure % make % make install Intel’s documentation told me to install the ipw3945d daemon by simply entering %make But that was wrong. I trusted them at first, and it didn’t work, so I went back and typed % make % make install And that worked. Otherwise, it all went smoothly. I rebooted to verify that the ipw3945abg card was really being recognized, and by reading the screen during bootup, I saw that everything was loading fine. Very exciting! But, strangely, when I tried to telnet into my freeshell account, nothing happened. Well, obviously my card was being recognized, but it wasn’t actually being used; it wasn’t on my LAN. Hm. _________GETTING NETWORKD_____________ I did a lot of research and found out that there were three commands relating to getting one’s networking device up and running. These are: % iwconfig # which is wireless-specific % ifconfig # which is for all network devices % modprobe # which loads a “module” into the kernel; in Mac terms, it would load an “Extension”. So I learned from a 2004 posting on a linux forum that once a wireless card driver is installed, all you need to do to bring it to life is to type this series of commands: % modprobe ipw3945 # which brings the module into the kernel. I know the name of the module is ipw3945 from the driver documentation % iwconfig eth1 essid XXXXX # assigns the card to a network; name is defined by me in the Airport Setup Utility % iwconfig eth1 channel 10 # because I set my Airport to be on Channel 10 % iwconfig eth1 key XXXXXXX # where key = the HEX code (or whatever) and NOT the ascii text I typed into my Airport Setup Utility. This, I discovered only after much poking around in the Airport software, in which there is a small, insignificant-seeming button that tells you “Oh, and by the way, if you’re not using an Apple you need to enter THIS code, not the passphrase you just created”. Oh. OK. % ifconfig eth1 up # to bring the network device up % dhcpcd eth1 # to receive the DHCP information from the wireless router. And this series of commands worked perfectly. I was suddenly online; I started the GUI, took a look at Firefox - and sure enough, everything was fine. I was ecstatic, and decided to take it one step further and create a shell script that would do all of those commands for me so that all I’d have to do is type one word. And so I did; I wrote a little script, made it executable: % chmod u+x ipwscript and tried it out. All I hade to do was type “ipwscript” and I was online in milliseconds. Well, at this point I pretty much figured I’d reached the pinnacle. Little did I know...... _____________ADD USER ACCOUNT______________ There’s a script program included with Slackware that prompts you as root to create a user account. I looked up in my Unix reference book to see if there was another way of doing this - I’m sure there is, but it doesn’t really matter. Obviously any usable Unix system is going to provide you a way to create a user account, so I just used the Slackware script. It made creating a user account very easy; as easy as doing it in Mac OS X except, again, without the graphics. To test everything out, I rebooted and logged in as user. X started up fine, but when I opened up Firefox, nothing happened; I was not online. So I typed in my magic script “ipwscript” and....again, nothing. Apparently the commands contained in my script were root-only commands. I struggled with the “sudoers” file in an attempt to give myself as User permission to initiate iwconfig, ifconfig, and modprobe — but it didn’t work. So I need to study “sudoers” permissions more. But in the meantime, I had the choice of either learning sudoers or just fixing the whole wireless problem altogether; obviously one shouldn’t have to type in those iwconfig commands (even if I did hack it down into a one-word trigger) if one doesn’t want to. So I did some research and discovered that what we Mac pros would call our “Login Items” is, in Linux, a collection of configuration and init files contained in the /etc/rc.d directory. ___________AUTOMATION________________ The /etc/rc.d directory contains two kinds of files. There are rc.XXXXXX files, and there are rc.XXXXXX.conf files. The conf files are what we edit, providing data that will be read by the rc.XXXXX files, which are basically scripts themselves and are executed during bootup. The first thing to do is to tell the computer that there is a wireless card in existance. To do this, add to /etc/rc.d/rc.modules this: /sbin/modprobe ipw3945 OK, that loaded the module or the Extension. The next thing to be loaded during bootup are the iwconfig The default /etc/rc.d/rc.wireless.conf looked like this: INFO="Any ESSID" ESSID="Any" ;; And so I changed it to read: INFO="Any ESSID" ESSID="XXXXXX" KEY=XXXXXXXXX ;; These changes essentially knocked out the need to do all of my iwconfig settings. So I rebooted and <Either I cannot spell or I am so unoriginal that I re-used a lame internet meme that has no value whatsoever to these forums and have been wordfiltered>ched as it booted. Everything seemed to be loading just fine. It was detecting the card, it was bringing it into the kernel....but when I tried to get online, it didn’t work. I typed: % iwconfig and looked at the results. It was all perfect; everything that was there when I was online was there now. So the problem had to be with the ifconfig and dhcpcd steps of my little getting-online command sequence. So I typed: % ifconfig eth1 up % dhcpcd eth1 and sure enough that brought me online. So, how to get THESE commands to occur automatically during boot? Further research was required, so I typed % ifconfig and compared the results of “ifconfig” while I was online to the results of it while I could not get online. Everything looked the same, except that when I couldn’t get online there was an entire line missing; this line contained the INET ADDR, the BCAST, and MASK. To fix this, I opened /etc/rc.d/rc.inet1.conf and - sure enough - noticed that the variables reserved for eth1 were all empty. So...... I plugged in the numbers for: IPADDR (ip address; not really sure if I need this because it’s overridden I think by DHCP but...whatever) NETMASK (the usual 255.255.255.0...whatever that means) and I changed USE_DHCP="" to read: USE_DHCP="yes" Save. Reboot. And I'm online automatically as Root and as User. It was a beautiful, wonderful thing.

xKLAATUx

A friend and I were sitting around playing with KDE 4. This sums up our notes on the topic:KDE 4 is a wicked desktop. The best traditionally (thereby conveniently excluding Fluxbox) graphic-driven desktop, IMHO. It's modern, it's sleek, it's ultra functional, and competes against the best of them. Don't get me wrong, XFCE is cool and GNOME has a very respectable dignity, but KDE 4 is something that excites and interests me.The weird thing is, of the few distributions I've seen that actually are edgy enough to include KDE 4 at all, none of them (SUSE, Kubuntu, Fedora) really have KDE 4 configured in a way that I think does it justice. This didn't make an impression on me until I heard a duo of rather vocal podcasters decry KDE 4 and Fedora 9 for some not very good reasons...but they did mention that KDE 4 didn't have enough contrast and didn't seem usable.Not usable? I've been using it since it was released, and powerfully. Not enough contrast? Well, change it!Ah yes, but how? Well, here's how to configure your KDE 4 desktop to your tastes. And I'm not talking config files or anything fancy, this is just really simple GUI stuff. It's just that KDE 4 is SO different that it seems many people (myself included until I attended the release event) can't find some of the simple built-in tools to configure the environment. You just forget to look for a control panel.First of all, it's not called a control panel any more. Here's where it's located....go to the K-Menu (different distros may brand things differently, so it may be an "F" menu on Fedora or a "K" on Kubuntu or whatever). The quickest way to get there is to hit Alt-F2 to RUN COMMAND (see? already I'm throwing out tips) and type in the word "system" -- the default selection should be the Application called System Settings, so hit RETURN and it will open.The other way to find the System Settings is to simply type into the search bar in the K-Menu. Type "System" and select from the results. OR you can just navigate to it: K-Menu > Applications > Settings > System Settings.Next window you'll see is the System Setting window, and it is basically your preferences for your [K] desktop environment.GIVE KDE MORE CONTRASTLook & Feel > Desktop > Desktop Effects > ShadowAdd a drop shadow to the windows. By default there is one already on it but on all screens I've seen, it's just too light. Here are the magic settings I use:X Offset = 1Y Offset = 1Shadow Opacity = 81% (quite a jump from the default of 25%)Shadow Fuzziness = 7Shadow Size = 4Look & Feel > AppearanceLots of customizing here, seemingly straight out of KDE 3.5.x You can change the colour scheme if you'd like, the icon set to something less pale than the default icon set Oxygen, apply themes, and so on. Knock yourself out.Look & Feel > Appearance > StyleChange the titlebar style and the style of all the widgets, like the scroll bars and checkboxes and things like that. So if you're just not diggin' the Oxygen feel, you can use any other style you prefer.Look & Feel > Window Behaviour > Window BehaviourConfigure how you can move windows from desktop to desktop, what a title bar does when you double click, etc.Computer Administration > Keyboard & Mouse > Keyboard ShortcutsYes, you have lots of keyboard shortcuts available to you. You can define them. You can learn what they are. For instance, ctrl-F9 shows you all the windows you have open on one desktop, and ctrl-F10 shows you all windows on all desktops. Ctrl-F8 zooms out for a bird's eye view of all your desktops. And you can configure more.Look & Feel > Desktop > Desktop Effects > *Take another look at this. All the cool compiz-style effects that come natively in K-Win are found here. Lots of cool and even useful effects are here; having a dialogue box dim its parent window is nice, having an in-focus window blur the windows behind it is sometimes nice, fades and scales, translucency, etc.So anyway, you get the idea. Basically the bottom line is to look in KDE 4's K-Menu for something called System Settings and tinker around in there. All the important stuff is thereHave fun.

xKLAATUx

So whilst watching Star Wars The Empire Strikes Back for the nth time, I was relishing the scene in which Darth Vader and Boba Fett are discussing what might happen if Han Solo is killed by the Carbon Freeze process. And it struck me that with all the Empire's wealth, why didn't the Emperor just cut Boba Fett a big fat cheque so they wouldn't have to bother with the whole Han Solo thing, much less spend time arguing over who's gonna deal with Jabba the Hutt should Han Solo die during being frozen in carbonite. Well, I guess teh Empire was probably just like any other governing power and had a lot of red tape to get through. Vader was probably improvising when he brought in Boba Fett and wasn't sure if he could get the proper tax forms and stuff to actually employ Boba Fett. So I understand.And I still say that Boba Fett got out of that pit in ROTJ. We didn't see it, but he flew right back out and went on to have quite a few anarchistic, mercenary kind of adventures. Or am I stepping on someone's expanded universe?Well, back to the movie.

xKLAATUx

Rsync.It's a small but effective, and really easy program that comes on every *nix system.The best back up plan is:1. simple2. quick3. painlessTo make it simple, get ONE big cheap USB harddrive (USB so it will be cheaper) and back up all your stuff to it.To make it quick, keep the harddrive close at hand, so that you can plug it in and let it do its thing.To make it painless, establish a cron job that will automate the rsync backup. If not cron, then at least a shell script so all you have to do is type in ./backup and watch it do its thing.How to do all this?Buy the harddrive: buy.com or tigerdirect.com or newegg.com or whatever.Keep it close at hand.How to use rsync:rsync -av /home/yourname /mnt/backupdriveThis copies everything in your home folder to the backupdrive. It's that easy. Obviously it'll be fairly slow the first time you do this because EVERYTHING is getting copied. From then on, only the new stuff will be copied.Make it a cron job:The most straight-forward way of doing this is to simply open /etc/crontab in a text editor. Let's say vim...

# vim /etc/crontab

and add this kind of text:

0 0 * * 0 username rsync -av /home/yourname /mnt/backupdrive

...which is telling the Computor to run that rsync command as a user (hence, username in the 6th column) every Sunday at midnight regardless of what month it happens to be.The way a crontab entry works is easy.Minute (0-59) | Hour (0-23) | Day of Month (1-31) | Month (1-12) | Day of Week (0-6 with 0 being Sunday) | username | command to run<EOF...sort of...>That's probably all one needs to know.....except that lately Linux distros are using a middle step in accomplishing this and just fill their default crontab with commands to run cron.hourlycron.dailycron.weeklycron.monthlyWhat's all that? Have a look in /etc and you'll see directories called cron.daily and so on; and inside these there may or may not be scripts with actions to be run daily or weekly or whatever. So what you can also do, if you want to play nice with the distro creators (and why not? they were smart enough to make an entire distro that you use daily, so they must know something, right?) then you'll create a shell script, make it executable and place it in the appropriate cron.* directory.It doesn't have to be a complex shell script. It can just be as simple as:

#!/bin/bashrsync -av /home/yourname /mnt/backupdrive

And that's it. Now make sure your computer is on every Sunday night at midnight, and that your backup drive is plugged in and mounted, and you should be good to go.

xKLAATUx

This is Avant-Garde

Random films that are, in varying degrees, "avant-garde"...whatever that means. Compiled by Dr. Terri Ginsberg, my avant-garde film professor.

Impressionism, Vorticism, Photogenie:

The Smiling Madame Beudet (Dulac, 1923)

The Fall of the House of Usher (Watson/Webber, 1928)

J'Accuse (Gance, 1919)

Dada, Graphic Cinema, Futurism:

Ballet Mecanique (Leger/Murphy, 1924)

Anemic Cinema (Duchamp, 1927)

Paris Qui Dort (Clair, 1924)

Constructivism and Formalism:

Kino-Eye (Verov, 1924)

Battleship Potempkin (Eisenstein, 1925)

Surrealism:

L'Etoile de Mer (Man Ray/Desnos, 1927)

Un Chien Andalou (Bunuel/Dali, 1929)

Le Sang d'un Poete (Cocteau, 1930)

Beat:

Shadows (Cassavetes, 1959) + all other Cassavetes films....

Pull My Daisy (Alfred Leslie, 1959)

Trance:

At Land (Deren, 1944)

Guns of the Trees (Mekas, 1961)

Flaming Creatures (Smith, 1963)

Lucifer Rising (Anger, 1964)

Mythopoeic and Lyrical Films:

Dog Star Man (Brakhage, 1961-1962)...and all other Brakhage films

Castro Street (Braillie, 1966)

Structural and Matieralist Films:

Eat (Warhol, 1963)

Word Movie (Sharits, 1966)

Wavelength (Snow, 1969)

Zorns Lemma (Frampton, 1970)

Radical & Art Cinema:

Land without Bread (Bunuel,1932)

David Holzman's Diary (McBride, 1967)

Unsere Afrikareise (Kubelka, 1961-66)

In the Year of the Pig (de Antonio, 1969)

Gently Down the Stream (Friedrich, 1983)

Invisible Adversaries (Export, 1976)

Dyketactics (Hammer, 1974)

Tongues Untied (Riggs, 1989)

Final Solutions (Tartaglia, 1990)

Mujeria: Primitive and Proud (Hildalgo, 1992)

Zyklon Portrait (Schogt, 1998)

xKLAATUx

SoX is the Image Magick of audio.

To mix two audio tracks together from the command line, simply do this:

$ soxmix file1.ogg file2.ogg mixed.ogg

that's it!

There's a lot more that can be done with sox, and hopefully i'll add more to this post accordingly.

xKLAATUx

A friend of a friend contacted me and asked where a laptop could be recycled.

I told him I would be glad to "recycle" the laptop for him and explained that I could put linux on it and it would be great. He warned me it was in bad shape but I didn't listen. People think computers are in bad shape the minute they can't sign onto AOL.

So I show up to pick up the latop and he brings out a brown paper shopping bag with the laptop in it and I look inside to see pieces of laptop. Shattered, crushed, torn asunder. Totally smashed. It was gruesome.

I asked him what had he done to it?

He told me that his computer expert friends told him to smash the hard drive to protect himself from internet hackers who might steal his identity I said oh.

Funny thing...someone dumb enough to smash a perfectly fine laptop instead of donating it to someone who can put it to good use is also too dumb to know wtf a harddrive is. Turns out he smashed everything BUT the harddrive. As I sorted through the pieces of the poor dead Dell, i find the ram chips and the harddrive both utterly untouched. Perfect condition.

Next step? Plug the harddrive into a sled and steal that guys identity. Now he's asked for it!

Well maybe not, but come on.... should we really be telling people to destroy their computer equipment for fear of the evil haxxors? There aren't college students out there who could use the computer? or kids in some part of your own town that could use it? What losers.

xKLAATUx

Who knows what kind of authentication gmail wants you to use to check your gmail account? Well, now I do, so here's how to set up your gmail account in the default mail client of your Nokia N770 or N8x0The account settings are straight-forward. Username, password, pop.gmail.com and smtp.gmail.comWhen you reach the end, click the Advanced Button. Here are the settings for gmail:IncomingPassword Authentication: NormalSecurity: SSL (POP3S)Incoming port: 995OutgoingSMTP auth: Loginusername XXXXXXXpass XXXXXXXXOutgoing port: 25That's it. You're welcome.

xKLAATUx

What This Documentation Covers:Part 0 - Introduction to sbopkgPart 1 - Introduction to SlackBuilds.org Part 2 - sbopkg overview a. Download & Install b. First RunPart 3 - Walk-ThroughPart 4 - Command-Line UsagePart 5 - Configuration File** Please read Chess Griffin's official documentation **man sbopkgman sbopkg.confPart 0 - Introduction to sbopkgSlackware has a package manager and it is you.Luckily, you have lots of tools that can help you manage your packages. One resource you have are SlackBuilds at slackbuilds.org (often abbreviated as sbo). A new tool has been written by Chess Griffin and a number of Fine Contributors called sbopkg.As Chess describes it:Sbopkg is a command-line and dialog-based tool to synchronize with the SlackBuilds.org repository.....Sbopkg will allow the user to browse his or her local copy of the repository, read the ChangeLog, and view the README, SlackBuild, .info, and slack-desc files for each package. Sbopkg will also allow the user to select packages to build and it will download the source code, check the md5sum, and build a Slackware package.What does sbopkg NOT do?It will not check dependenciesIt will not automatically install the packageIt will not track what has been installedHow does a SlackBuild work?I don't know. It just does.Part 1 - Introduction to SlackBuilds.orgTo better understand how sbopkg will help you, it is good to understand how a SlackBuild traditionally works.Traditionally, you would do this:1. Download the SlackBuild2. tar -xzvf SomeProgramScript.tar.gz4. Download the Source Code for someprogram4. tar -xzvf SomeProgramSource.tar.gz5. mv SomeProgramSource/ SomeProgramScript/ 6. cd SomeProgramScript/7. su(password)9. chmod +x someprogram.SlackBuild 10. ./someprogram.SlackBuild11. cd /tmp12/ installpkg someprogram_sbo.tgzHow would you like to skip steps 1 - 10? Well, that's what sbopkg does!Part 2 - sbopkg overviewa. Download & InstallCurrently, sbopkg can be found at http://code.google.com/p/sbopkg/Download the latest version (let's assume it's sbopkg-0.0.4-noarch-1.tgz) to your Desktop. Open a terminal:% su(password)# installpkg sbopkg-0.0.4-noarchAnd now it's installed!In /etc/sbopkg/ there is a file called sbopkg.conf.sample which you should edit to suit your machine.Since it's wise to keep a good sample file around, make a copy of this before editing it, and rename it sbopkg.confNow open sbopkg.conf in your favourite text editor. The manditory change is the default location for your local SlackBuilds.org repository, which is initially set to /home/sbo. You will need to set this to something more like /home/username/sboOther settings can be tweaked as well; if you wish the Slackpkgs that you will be building with sbopkg to be stored somewhere other than in /tmp then you can set TMP= to whatever folder you'd rather store them to. And so on. If you have no special requirements, however, most of the defaults can be kept.Save the changes and quit the text editor.b. First RunTo start sbopkg, simply become root and type In sbopkgAn ncurses interface will appear.RsyncThe first selection will synchronize a local folder on your computer (made during installation) with what packages are currently available on the SlackBuilds.org website.ChangelogThis displays the most recent updates and changes made to the packages in the SlackBuilds repository.BrowseHere you are able to browse through all of the packages available in the SlackBuild repository. The packages are subdivided into general categories, like Academic, Desktop, Development, Games, Graphics, Libraries, Misc, Multimedia, Network, Office, and System.Within each category you'll find a plentiful selection of applications you might want to install. Cache[/]Holds the source tarballs that are downloaded and saved when a package is built. NOte taht this does not hold the actual packages; these are built and saved in /tmpLogThis shows you the exact verbose feedback of the packages you have or have attempted to create with sbopkg. You can read your logs at any time, and you may also choose to delete them or not.ExitPredictably enough, this quits the sbopkg program.Part 3 - Walk-ThroughThe best way to learn how to do this is to do it. So let's take a fairly complex example, such as the vector graphics application Inkscape, and install it step by step.To begin, we run sbopkg as root:% su(password)# sbopkgIf this is the first time we are running sbopkg, we'll want to start with Rsync. This will update our local copy of the SlackBuilds. We also may want to look at the ChangeLog to judge whether or not an Rsync is in order.The next step will be to select the package we want to install. Select Browse, and then the Category you wish to peruse. In this case we'll choose Graphics.In the Graphics category, locate Inkscape and hit Return. You'll be taken to an information screen about that package. The first option is the README file; skip over this; no one ever reads them anyway. Oh wait, actually, don't skip it. Read it! Read it carefully! This file tells you what your system needs to have on it before attempting an installation of the software you really want to install.From the README file, we see that Inkscape requires libsigc++, glibmm, gtkmm (which in turn depends upon cairomm), gc, and PyXMLFrequently, a packages dependencies are also found as packages in SlackBuilds. So we'll leave Inkscape alone for a moment and go install the dependencies first.To navigate out of the Inkscape information screen, his return to Exit, and then Cancel to return to Graphics, the Cancel again to return to the list of Categories.Now that we're in Categories, navigate to Libraries. Here, you will find all the Inkscape dependencies you need. It's a good rule of thumb to install the dependencies in the order they are listed in the README file.This means that first we'll select Libsigc++, listed here as libsigcxx. Press Return to go to the information screen. Read the README. You can also look at the .info file on this item, which will give you version and maintainer information.You can both view and edit the SlackBuild script itself. To view it, select SlackBuild. To Edit it, select Edit. Be aware that this will create a libsigcxx.SlackBuild.sbopkg file in your local copy of the SlackBuild. This is so that any edits you make are easily deleted with the Delete option.Finally, there is the option to Build a package. This will run the libsigcxx.SlackBuild (or your edited libsigcxx.SlackBuild.sbopkg if one exists).Once this is finished, you may continue to do the same process for each dependency, but in this case, since even the dependency gtkmm has a dependency (cairomm), it's not a bad idea to go and actually install the resulting package before continuing on to the next dependency.Installing a Slackpkg is as easy as opening a new tab in your terminal or changing to a new virtual terminal and using the Installpkg tool:% cd /tmp ; ls% su(password)# installpkg nameofpackage_SBo.tgzSlackware installs the package for you, and you can continue to resolve dependencies.If you come across a dependency that is not available via SlackBuilds.org, you may have to use a little known internet tool known among the elite hackers as Google. :^) This should help you find the dependency, which you can download and install manually with the typical ./configure and make && make install commands. You may also want to visit the software's official site, often given in the README in the Information window in sbopkg.After you have installed all dependencies, you are ready to resume the SlackBuild of Inkscape.Return to the Graphics category, find Inkscape again, and select Build.This will create a Slackpkg in your /tmp directory. Once the build is confirmed by sbopkg, you may Exit sbopkg.At this point all you have left to do is cd into /tmp and installpkg. That's it!Now go find another cool free app to install, and have fun! Part 4 - Command Line UsageIf that the fancy ncurses interface is just too much eye candy for your text-only console sensibilities, you may also use sbopkg straight from the command line. This is well documented by Chess Griffin in the sbopkg man page, accessible via this command:% man sbopkgThe syntax for the CLI version of sbopkg is:sbopkg [options]To do an rsync from SlackBuilds.org to your local SBo repository, use this command:# sbo -rTo view the most recent SlackBuilds.org changelog, use this:% sbopkg -lTo find a package and read its README file, use this command:% sbopkg -s NameOfPackageShould you wish to search for and build a package from your local SBo repository (ie, after you have done an rsync of SlackBuilds.org to your local system) use this command:# sbopkg -b NameOfPackageIf you need to manually specify where the directory containing your local SBo repository is, then use this flag:-d /path/to/directoryShould you need to override your default configuration file and point sbopkg to a different configuration file, use this:-f /path/to/non-default/config/filePart 5 - Configuration FileThe default installation of sbopkg installation looks for a local repository in /home/user/sbo with the version of Slackware set to the latest stable version of Slackware (12.0 at this time).However, should you wish to modify these settings, it is as simple as editing /etc/sbopkg/sbopkg.configThis is very well documented by Chess Griffin here:% man sbopkg.configYou can also use the command line option (-f /path/to/non-default/config/file) to direct sbopkg to a different configuration file.[EOF]

xKLAATUx

If you're reading this, you've probably just read my HOWTO Install Slackware post. This article assumes you have read that. Or that you've managed to install Slackware on your own.First, have you rebooted after the install? Slackware doesn't force you to do this after you install, so be sure you do that before you start attempting to set up your system or else you'll be attempting to set up a system running on an installer disc.So reboot, and login as root using the passPHRASE you created whilst installing.Oh look you have mail! Type "mail" to read it._____________SYSTEM__________________________WIRELESS CARD DRIVER_________This where I can only do so much to explain things; getting wireless to work can be difficult because there are so many wireless cards out there and so few have linux drivers. I got a Centrino system, meaning that all internal parts of any great significance are intel. Intel happens to offer freely available drivers for Linux.On other machines, however, I have had to do weird firmware hacks. But interestingly, the concept is the same with both. The one thing I have never had to use is Ndiswrapper, so I can't help you there. But for firmware cutting explained, read my post about putting Fedora on an iBook. That was fun.The following example is what I had to do in Slackware 12. But if you are using certain wifi cards, such as the one in the example (the Intel 3945) then in Slackware 12.1 everything will work without much involvement from you. Oh, sure, you will have to bring the card up with ifconfig commands (later in this post) but in terms of installing the firmware and stuff like that, no worries, it's all included. You can find out if your card is already being recognized by typing in# iwconfigand see what results you get. If nothing, then your computer doesn't know you have a wireless card and you do need to install something. If, however, you get a result (most likely it will be called wlan0) then it is being seen by the kernel and you are free to get online.So here's what I did...and even though it might not be the same process for you, the steps are similar; find the drivers, figure out where the firmware blobs go in the system, compile the daemon, set up your default network.Because I had an Intel card, I found that the drivers I needed were included on the Slackware DVD in the "extra" directory, as were some very clear and helpful instructions (much more helpful than Intel

xKLAATUx

If you're reading this you already want to install Slackware. If you are reading this to be convinced to install Slackware, stop here because I'm not selling anything. Just telling anyone who wants to know how they can install Slackware.I'm assuming you can download the iso and burn it on your own. Or purchase it.Warning: I am not an expert in Linux or Slackware. Just a normal user having a lot of fun. If I get something wrong, it's only because it worked for me so I don't know any better. Don't get angry with me because I am misinforming you. This is just a record of what I did to install Slack on my Sony Vaio, and kind of a way, hopefully, for you to see what the mythical Slackware Installation is really like. I think you'll be pleasantly surprised to find it's actually a really simple installation processs, without lots of GUI messages and weird questions to confuse you.HOWTO:Before we even start, we should turn on the computer in question and boot into the BIOS or OpenFirmware or at least some kind of System Profiler. It really really helps to know everything about the computer BEFORE you start installing. So just do that first. Write down important stuff, like what is your computer's internal clock set to? what How much RAM? hard drive? video card? video memory? what brand of modem? network card? etc. Get ALL the information you can find.OK, so upon first boot, you'll be presented with an option to choose what kernel you'd like to boot your installer with. Usually the default kernel is fine, so just press RETURN or ENTER. However, if you have special needs, like a kernel with speech synthesis (mom, that's for you) or if you're running a Pentium Pro machine (...dad) or whatever. If you're doing those things, you'll need to type in the name of the kernel you need.The next screen verbosely explains to you how to go about installing in three easy steps:I. log in as rootII. format your drive.III. type in "setup"OK, so here we go: I. log in as roottype root and press return. no password easy. ok, we're a third of hte way done.II. format your drive.To format your drive, I think the most user-friendly way to go would be cfdisk.But if you just go typing cfdisk, the computer will think you want to try to format the currently mounted root partition....currently the DVD you're running the computer on. That's not gonna work, now is it?.So you'll need to direct the computer to the device you actually want to format. This seems to vary slightly depending on how your computer was put together. For my laptop it was cfdisk /dev/sda but for others it may be something else.Easiest way to figure this out is to type cfdisk -l which lists all the drives currently attached to your computer. Those are your choices. If you try to cfdisk one of them and it tells you that the drive cannot be written to or erased, then you're still trying to erase your DVD. Try the other one. There shouldn't be a number after the sda or hda or whatever. You want to look at the whole device, with any and all partitions already existing on it.cfdisk is a menu-driven drive formatting program. It's easy to figure out. If you see partitions that you no longer need, you can Delete them. Once they're deleted, move up or down to the next partition and Delete that one...or whatever you want to do. Basically you're clearing out partitions to create what is generically called FREE SPACE.Once you have enough FREE SPACE to install Linux onto, you can make a partition out of that free space. To do this, you select New. It will ask you how large you want the partition to be, in Megabytes. Type that number in, choose whether you want it to be Primary or Logical (let's just go with Primary, shall we?).You'll also want to make a small-ish partition for SWAP space, sometimes known as Virtual Memory (basically harddrive space for when physical RAM starts to become scarce). This is done by, again, selecting to create a New partition, giving it a Gb or two (double your physical RAM is the rule of thumb i've heard).Now you need to assign them a Type. So go to the main partition that you'll be installing Slackware onto and select Type. It will list a long, long menu of different file types and you'll need to type in the corresponding numerical choice. Just type 82 for Linux and 83 for swap.You'll also want to make the big partition bootable. Just select the bootable option and hit return.Now Write the partition to the disks.If you're doing some fancy dual-boot or something you'll have to deal with that yourself. But if you've ever partitioned a drive before, I think you get the idea.Once you hit Write, the partition table is written to the drive and you are returned to your root shell prompt.OK now we're two thirds of the way done. Easy, right?III. type in setupWhen you type in setupan ncurses interface opens up. First selection is to read the Help. You might as well read it.Next selection basically dumps you on the track toward getting this installation really happening. When I said earlier that we were two-thirds of the way done, I was kidding. But don't worry, the rest of the stuff is a nice eye-candy (ncurses style) ride through verbose installation options.1. So, first you'll have to add a swap partition. You've already created one, of course, but you need to let the installer know that. So show it to the swap partition you've made, which should be easily recognizable because it'll be the size you typed in, and it will be the /dev/xda# that it was assigned during cfdisk. Be sure, obviously, that you're not assigning your 100gb partition as swap....or the partition that you have another OS on ((if you're dual booting).2. Next you'll tell the installer know where the drive that you want to actually install Slackware onto is....this is called the root mount point and it's represented by a mere /Just select the drive you want to install Slackware onto and it'll format it for you. It'll ask you if you want to check for bad blocks but usually I say no to that.It will ask you what kind of FileSystem you want to use. Let's just go for ext3 because it's kind of a really really common Linux filesystem. But feel free to play around with others if you want. Whatever you choose will be fairly invisible to you because it's pretty low level stuff. I say go for ext3 to avoid any variables later on as you try to do fancy things with networking and things like that. I would save playing around with other filesystem types for later. But what do I know?You;ll also be asked for confirmation about the root mount point being added to /etc/fstab. This is simply giving the computer the ability to actually mount the drive. FYI.3. Now you'll be asked from where you wish to install. The DVD is the right choice. Again, if you're doing a fancy netinstall, you're reading the wrong HOWTO (although it's actually not that hard, so just try it as long as you have a functional network connection...). Slackware will offer to scan available drives for its installation media, and so far that's never failed for me. If it doesn't work you'll have to tell it where the cd/dvd drive is...and that requires that you know the device names of all your drives. Remember when you did the cfdisk -list a while ago? I guess i should have told you to commit that information to memory. Well, if you need to go get that information, you can just hit escape and Cancel until you get back to the main Setup Menu, at which point you can bail out and get dropped back to your root terminal. Gather the device names, write the down, and start up the Setup again. You can pick up where you left off or just start fresh, whichever you feel more secure about.So ...you'll be prompted to select what packages you want to install. If you're used to Linux or if you're not but you want a really good first Linux experience, I suggest installing everything it recommends. It's easier to scale back later than not install stuff you'll want later. At least, that's my theory...but I think if you're reading this, you should just go with me on it. If you're going to set up some kind of headless server with Slackware, you ought to be reading someone else's HOWTO, not this one.Slackware will tempt you to try to not install everything...it will give you the option of an Expert mode as well as a Newbie mode. Don't trust it! Just do the recommended installation of 4.5+ Gb of glorious apps, useless games, vague documentation, printer/scanner support...et cetera. It's easier now and it saves you from a lot of configuration later on. I personally wonder if one of the reasons so many people say that Slackware requires so much setup is because they tried to be clever during initial installation. After you are more familiar with what you do and do not need, you can strip it from the system or re-install or whatever you feel the obsessive compulsive urge to do. But otherwise, trust Pat.4. Here, Slackware now installs all the good stuff on your drive. Wow...it's still just so easy!One thing I highly recommend is sitting in front of the computer and staring at it while it installs everything. It seems like I'm being sarcastic here but I'm serious; the more you look at this garbage, the more it starts to make sense. And you start to get familiar with packages adn what they do. So if someone is raving about KDE4's kdebindings, you have some idea of what that does and why it is important.(Warning: may cause epileptic fits)5. Next, Slackware is going to ask you if you want to create a USB Flash Boot. If you've got a spare pendrive lying around that has no data on it, go for it. It takes maybe 5 seconds, and can come in handy later on if you have to bootstrap your system. After it finishes, it will offer to make additional boot sticks...no need to do this, necessarily.6. Modem Configuration. What's a modem? From what can tell, a common choice would be /dev/ttyS4 which would be a normal everyday non-evil PCI modem. The good news? If you choose incorrectly, you can always change this later if you are banished to dial-up and actually have a need for such a thing.7. LILO is the linux bootloader, by all accounts inferior in many ways to GRUB, yet the bootloader of choice for Slackware. I actually like LiLO because it doesn't get changed by the system the way GRUB can be changed. I imagine this is why Slackware uses it. The first time I used GRUB with other distros and updated a kernel, I was shocked and horrified to find that my GRUB menu had been changed without my intervention, and of course many partitions were misdiagnosed, so I had to go in and change it all manually. Seems like it's easier to just have LILO not change until you change it...Anyway, go for the SIMPLE install. It will autodetect whatever kinds of OS's you may have on any of your devices, and create a simple LILO menu for you.8. Frame Buffer. This is apparently a little risky, because some equipment doesn't support it. But if you're using quality, new equipment, you probably can support a frame buffer. All this means is that you get to see some little graphics on screen plus your text console, so instead of just seeing text you'll see a penguin at the top of the screen. Things like that. I choose the highest resolution available because I know I've got a brand new computer with the latest Intel video card, etc. Do what your heart tells you to do.9. You have the option of inserting default extra parameters here. More than likely, you won't need to do this -- unless you had to pass extra parameters to get up to this point. Quite possibly whatever you did to get this far, you'll want to also do here. Again, typically for modern systems you're not going to have to do any fancy bootstrapping hackery here.10. Where do you want LILO to be placed?This is tricky. If all you are doing is installing Slackware and nothing else, or if this is the first install of a planned dual-Linux install, you may as well put Lilo in what is called the Master Boot Record (MBR) because it either needs to be there or it will be replaced by GRUB or something when you install your other Linux OS. The time this gets really tricky is if you are dual-booting with Windows or OS X, both of which really don't want Linux to exist at all, much less to have something in their MBR.In that event, you will need to do one of two things:a. install Lilo to the Root mountpoint. This means that OS X will boot via the default Apple bootloader, and if you press OPTION while booting, it will recognize that indeed you have two OS's on this machine. If you elect to boot into Slackware, you will THEN see the LILO options. And all will be well with the world (aside from the fact that you have that nasty old OS X on your drive...)b. Install Mac OS X (or windows?) FIRST. Once it's installed and all up-to-date, THEN install slackware and put LILO on the MBR. This way, Linux has the last laugh and manages all the OS's on your system. In my experience this has been tricky with OS X because if you do a major OS X update and it decides to reclaim the MBR, you could be without any easy way of getting to your Slackware OS. So if you're going to dual boot with these proprietary systems, you may want to just put LILO on Root.Keep in mind that I do not have even a working knowledge of Windows or how it does anything. But my advice on OS X is fairly solid, from a fair amount of experiences with Mac vs. Linux.11. Next you'll need to choose what kind of Mouse you'll be using. Look at the port to which you would normally connect your mouse. What kind of port is it? I'll bet it's USB. Guess what you'll be choosing here? (obviously use common sense; if you are doing this on a desktop and there are ps2 ports, please choose PS2, or if you'll be using a WaCom tablet, choose that. you get the idea.)12. GPM is the very cool ability to use your mouse even when in a virtual console. I'd install it were I you.12. Network Configuration. This is entirely up to you. If you know what you're doing here, go for it...or skip it and do it later. If you don't know what this is all about, read on:We'll say yes here to set up our network.First choose a hostname. What's a hostname? Let's say it's your computer's name; it can be pretty much anything you want. In this example I'll choose "groucho"Now we choose our domain name. This is the network upon which your computer lives. Let's choose marx.orgAnd if we have other computers we want to configure so we can share files back and forth with ease, we would give THEM all the domain name of marx.org but they would each get their own unique hostnames, such as "Harpo", "Chico", and "Karl"You'll be asked to set up an IP address. More than likely you are dealing with DHCP so you'll choose that...basically unless you have either a static IP address (again, if you do, you may be more advanced than this article) or you are hardwired to the net with an assigned IP from your internet provider, you're doing the DHCP thing. That's your safest bet, I think. If in doubt, talk to your internet provider and find out.14. Were you assigned a special DHCP hostname? If so, you'll enter it on the next screen. More than likely, you were not, so just hit RETURN. Again, if in doubt, check with internet provider.15. Startup services. Yikes! This is where you have to choose what little programs you want to have started when you are booting up and logging into your computer. Most "user-friendly" OS's have a fair amount of services starting up while you log in, so you don't have to worry about whether the computer will know what to do when you plug in the printer or an external hard drive or whatever. Well, having unused services running every time you turn on your computer not only wastes your CPU cycles but it's a bit of a security thing. But if you're just at home, using your computer for every day things and want certain things to work invisibly in your favor, you may want to, for instance, leave on the HAL daemon (Hardware Abstraction Layer), you may or may not want to start up CUPS (print server) and things that you want to have on all the time. I used to turn on a printer service, but everything else I leave as is. But if you have a SAMBA network going on and want access to that quickly and on-demand, I can imagine you might turn that on as well. Obviously none of these necessarily need to really be on now; you can always just start the services when you actually need them. 16. Your system clock. Is your internal clock set to UTC? Usually it is not. Unless you have gone in and set it to Universal Time, it's probably running as a local clock. So probably the answer is NO. But if you know otherwise, select YES. See how that works?17. What Window Manager will You Choose?Slackware comes with about six or seven window managers you can choose to install. I say throw them all in. Your hard drive is big, your system is robust. Take it all. You'll like it in the long run, becuase you'll have lots of choices and lots of fun things to play around with. If you absolutely don't want something, you can de-select it and continue, but I advise you to take it all.18. Root password. They call it a password but what they mean is a passPHRASE. Make this good. This is the key to your system's security. Numbers, letters. Something you'll remember but something that takes a while to type in. Trust me, you're not really gonna use this that often so make it inconvenient for yourself...but memorable!! Then write it down on tape and put it on your computer (just kidding).19. Now you're done.Post installation is not that impressive. It just kind of loops back to the setup menu and you can select EXIT, and then it drops you down to your root shell account again. And that's pretty much it.Wasnt' that easy? Congratulations. You've installed Slackware. Best of luck getting your system up and running.(read my next post on HOWTO configure Slackware Userland)

xKLAATUx

I was looking at Slackware based distros last night, just to broaden my knowledge of what's out there aside from Slackware proper, Slackintosh, and Slax, and came across NimbleX. They are having a logo competition. I was itching for an excuse to play around in inkscape. So I whipped up some logo ideas. I don't know if they'll want them, but maybe they will like them.The idea here was "nimble" which means spry, active, energetic. And X, which refers, presumably, to X.org or LinuX or something. So I thought a cartwheel would be just the thing to represent such a concept, because when someone is nimbly performing a cartwheel, they are also at one point making the shape of an X. I broadened the idea to include breakdancers, who sort of do cartwheels, I guess.

xKLAATUx

HOWTO use scp

WHATIS:scp is a Secure CoPy, akin to ssh. A convenient but encrypted way to move files from machine to machine on your network.A REALLY GOOD HOWTO:Linux Tutorials Blog...or you can read my very brief but-it-does-the-trick HOWTO:(I do recommend you check out the HOWTO on Linux Tutorial Blog at some point for all the cool tricks you can do with scp)The syntax for the scp command is as follows: scp [options] [[user@]host1:]filename1 ... [[user@]host2:]filename2 For example, if user klaatu is on a computer called fedora.laptop, and wants to copy a file called file.txt to slackware.com, he would enter the following: scp file.txt klaatu@slackware.comif he wanted to place file.txt specifically into a directory called destination/ then he would do this:scp file.txt klaatu@slackware.com:destinationor to be extra safe, you could give the complete path, like so:scp file.txt klaatu@slackware.com:/home/klaatu/DocumentsLikewise, if he wanted to copy the entire contents of the destination/ directory on slackware.com back to his fedora.laptop (so that's FROM a remote machine TO the machine you're sitting in front of), he would enter:scp -r klaatu@slackware.com:/home/klaatu/directory destinationSimilarly, if he is working on an entirely different computer, but wanted to copy a file called file.txt from his home directory on fedora.laptop to a directory called desitination in his account on slackware.com, he would enter: scp klaatu@fedora.laptop:file.txt klaatu@slackware.com:destinationWhen using wildcards (e.g., * and ? ) to copy multiple files from a remote system, be sure to enclose the filenames in quotes...because the shell expands unquoted wildcards.