• entries
    98
  • comments
    26
  • views
    87,821

About this blog

memory.dump

Entries in this blog

xKLAATUx

A few months ago, maybe, a company named Fixstar acquired Terra Soft (the makers of Yellow Dog Linux). There is no visible change really, it's just that now the company seems to be called Fixstar instead of Terra Soft.For some reason...probably because for the entirety, or most of, my computing life I have used PowerPC chips, I am often drawn back to yellow dog, the one of, maybe, two or three distros that specializes in linux-for-powerPC. So I tend to install it every once and a while and see how it's going for them...and to be honest it's a pretty solid little distro with lots of cool features for their default e17 desktop environment, and everything seems to be pretty much auto-detected and easily configured right away.The one thing they might not have finessed quite yet is the repo issue. I don't know how a user is supposed to know what version of Fedora, for instance, Yellow Dog x.x is equivalent to, and without knowing this, making use of rpmfusion or any similar extra repo, is a bit tricky. I don't want to add the wrong repo, and Yellow Dog doesn't make it terribly obvious as to what extra repos I should be looking for.And their support pages, from what I can find, seem to be consistently a little confusing. This was both with Terra Soft and Fixstar. I think they may really be trying to sell support, and the community support is so far fairly difficult to find.But all that means is that his isn't the proverbial "noob linux distro" for powerPC. I think I had come to it early on thinking that it was supposed to be a noob distro...not sure why I would think that. I guess the absence of certain geek tools from the default config suggested that this wasn't really a "pro" distro...but that is only because I am judging it off what I'm more used to: the full feature set of slack[intosh / ware]. No, in the end, this is a good distro that is really fun to have on a spare powerPC machine. I am still trying to figure out what repo to use but I guess I'll just start adding repos and seeing what works (hey I never said I WAS a "pro", just that I was used to a "pro" level distro!).e17 on Yellow Dog is fantastic, by the way. It's nicely themed to fit the blue flavour of YDL (yes, I know, that makes no sense...you would expect yellow...but it's the DOG that's yellow, not the distro, apparently). It has quite a few epplets available for the e17 shelf (including a weather forcast epplet, a cpu monitor, screenshot, and network monitor...oh and of course an analog clock...) and comes with the usual good stuff installed; Firefox, Thunderbird (I love that combo!!), pidgin, rhythmbox, open office, wicd, ekiga, gimp, glade, dictionary, et cetera. The codec installer seems to be the one from Fedora 9 (hey I think I just figured out what repo to add!) and is out of date...and I mean, it no longer functions. You try to add the free mp3 codec and it returns a 404 error or something similar. But once I get rpmfusion going, I don't see why this will matter.There are just enough animations and effects in e17 to make you feel like you're running a sleek modern OS.....um, and you are! You are running a lightweight blingy desktop environment that really ROCKS. I have install YDL 6 on an iBook G4 (so, integrated graphics) and it performed pretty well...although to be fair, integrated graphics are just so bad that I guess I'm never going to be happy with it. But this time I chose a PowerBook G4 (so, separate graphic card)...the 12" version, I think around 933mhz chip with 256mb RAM. YDL runs on it like a charm. I haven't tried anything TOO intensive yet but so far, this is really making me happy. I'm not saying Debian or straightup Fedora PPC or Slackintosh would do any worse -- they are all great -- but I am happy to see that YDL 6.1 is a cool distro with a nicely configured e17 environment. So I guess in Ubuntu-terms YDL would have been called eDora or something like that because basically, as far as I can tell, it's Fedora with a e17 environment. So, it's cool, I like it. I dig it. YDL 6.1---edit on 01/08/09 -- I still can't figure out what repo to use. It's such an annoyance in fact that I have cleared YDL off and loaded Fedora 10 onto the computer, which is working as expected. So I'm not sure what YDL is intending people to do about repositories, but they certainly don't make it obvious. Granted, I am not dedicating much time trying to find out; it's just a spare computer at work that I have set up so I can use Linux for some tasks. It's not like I have a whole lot of time to sit around and explore; in this case, I really just need a distro that "just works". So while I am still impressed with YDL, in terms of it being a quick-fix I would say that it is...well, not. I'm sure with a bit more effort I'd find the repo I needed...

xKLAATUx

I was making a little tutorial on a really cool audio app called Qtractor the other day, and for this I was doing quite a few screenshots. Some of the screenshots were pretty big so I went into GIMP to scale them down. To my surprise, the images looked terrible when scaled down. I understand about interpolation and I understand that an image in anything but its original form is technically compromised, but the text that looked great on my real screen looked embarrassingly bad in the scaled-down screenshot, and I'd only scaled it down by 10 or 15 percent. Something was definitely wrong.So I opened the original image in Krita and scaled it down to the same size...and it looked great. Looked like it hadn't been scaled down at all.So then I tried scaling the original image down with ImageMagick's Mogrify. This was better than GIMP but not as good as Krita.So, back to GIMP, and I messed around with the default scaling algorithm being used (to be fair, I could probably do this with ImageMagick as well -- there's surely an option to change the algorithm). Turns out that the default for GIMP is Linear Interpolation, otherwise known as /p/tarded interpolation, and looks terrible. Why this is the default, I cannot say; maybe it really does have its uses for pictures done, say, in 8-bit graphics.... Anyway, I changed it to "Sinc (Lanczos3)" and tried my experiment again. Miserably failed again -- sort of. For some reason, even though I'd just set the default Interpolation to Sinc (Lanczos3), the Scale dialog box was set to use Linear and I still had to manually change the algorithm being used. It seems to retain that setting, though, and I have not had to re-set the interpolation since.So, if you're using GIMP, set your Interpolation to Sinc (Lanczos3) for best results. Frankly it's still not as good as Krita's results, but it's certainly better than the default.I'm attaching screenshots of each example, with the exception of ImageMagick because I am pretty sure with some more complex commands (like quality control and such) I could get ImageMagick's results to be as good as GIMP+Sinc or maybe even Krita.

xKLAATUx

whatf or

% dmesg | tailMy wiki went down because of bad hosting. Lucky for me I'd backed up all the good posts I'd made to the wiki, so I am going to first place all those old posts here in this blog, and then I'll be able to start posting new (and perhaps useful to more people than just myse) thingslf.% whoamiklaatu% echo $HOMEthebadapples.infoa little podcast i do when i can. chekc it out if u like linux.

xKLAATUx

What is "intuitive"?

What is really intuitive, anyway? A lot of us seem to have some idea of what an Intuitive interface is...but really, everything we call intuitive usually translates to "this is like something I have used before". I mean, even simple stuff like trashing a file.... is it intuitive or are we all just really used to the idea of having a Trash Can icon into which we can drag a file? Well, because we are all so used to that concept, it IS intuitive, but what if we were all used to having an icon in a panel or kicker that meant "zero out space occupied on the harddrive by the currently selected file"...then the first thing we would all look for such an icon on a new system that we started using, and a system set before us with a trash can on the desktop would baffle us. We'd think it was a folder, maybe, for junk mail or just a funny icon for a folder. We wouldn't associate it with a method of erasing a file from our computer because "as everyone knows," we would say quite sensibly, "you don't put digital bits into a trash can."For me, "intuitive" is a process, not something tangible. Intuitive interface design is the collection of a series of logical steps, but it is also the collection of all the different applications on a system - the way they all work in similar ways so that to learn a few basic concepts is to learn a whole variety of more complex applications for those concepts, and it is the consistency of interface so that when my hand automatically goes to click a button, that button is where it would be regardless of what application i am in.Let's look at a simple example: I have a window with a red button and a blue button. Is that intuitive?Well, yeah, it is...sort of. You're supposed to click one of the buttons, right? Um...but what do they do? It's not so intuitive any more is it? Now it's absolutely counter-intuitive. If I tell you what you are doing, the context shifts, and suddenly it does become intuitive. So intuitiveness is not just simplicity; it is simplicity and context.Let's look at something that is frequently considered not intuitive: line commands. If I sit someone in front of a black screen with some green text on it and say, ok, find the file called needle.txt they are not going to know what to do. It is not intuitive. If I sit a geek in front of the screen and tell her the same thing, however, it is pretty intuitive; she will simply type ls | grep -i needle or something like that, and the problem will be solved. Now what if it turns out that I didn't sit that geek in front of a unix-like terminal and in fact she's starting at an EFI shell? Well, even that is intuitive to this geek, because she will know commands to try, and commands to try to get help, and sure enough, eventually she would be able to find the document I requested.So really, intuitive is not in the design of something, but in the similar design of a collection of things. It is the basis of knowledge of concepts that are consistent across many applications. And it is consistency of interface design. That is what it is, and don't forget it.

xKLAATUx

I was at a used bookstore the other day looking for old sci-fibooks, and on a whim I thought I should look through the computer sectionas well. So I asked the shop proprietor if he had a computer book shelf,and he said well, yes he did, but it was all very out of date, and I said"Good!" -- because the very reason I wanted to look through the computerbook section was to see if I could find any old gems from the yesteryearsof computing.So I looked through the obligatory "Word 95 for Dummies" and "Visual BasicProgramming Guide" books, and finally started coming across a few oldMac-related books, which were nifty, and then onto some really big "Fortranfor VAX" tomes, and then finally, tucked between a COBOL and an ElectricalEngineering book I found a small-ish yellow wirebound book with the AT&Tlogo on it, and the title: "UNIX System User's Handbook". And sure enough,it was a handbook on how to use the [already] decade-old AT&T OperatingSystem, UNIX. It is pretty cool; it's got a lot of commands that are stillrelevant today in it (in fact I've learned a few new nifty tricks), andsome that were apparently specific enough to AT&T not to have survived pastwhenever AT&T finally sold UNIX off. Almost as neat is the fact that thereis a Xerox'd copy of a "Vi Cheat Sheet" in the front flap of the handbook,probably left there by Christopher Aiken (the former owner of the book) --the neat thing about this, aside from being a slice of history in itself,is that "vi" is now "vIM" (vi-improved) and happens to be my text editor ofchoice, and it's kind of neat to see a cheat sheet for its former incarnation.In the back is a pamphlet published by some place called SSC,called "UNIX System Command Summary for Berkeley 4.2 & 4.3 BSD" --obviously the handbook itself is for System V unix.So, basically, it's just a neat curiousity item find, as well as being apretty darned helpful review of essential UNIX concepts. The handbookitself dates back to 1982 so it's not like it's ancient (i guess by ancienti mean "1970") but it feels old. Certainly it represents an older *nix, soit's cool to have.

xKLAATUx

Turning Touchpad Tapping Off so it stays off in Fedora 8 The default touchpad settings of Fedora 8 "Werewolf" on an iBook G4 are frighteninly sensitive. The merest brush of the touchpad sends the cursor flying to the opposite corner of the screen. A slightly heavier brush against it and you've clicked on something by accident. It is enough to drive a former Mac user nuts. Under Ubuntu, it is quite simple to configure the touchpad settings with Gsynaptics. But for some reason, with Fedora+iBook it was quite difficult. Adding "SHMConfig" "on" to my xorg.conf rendered no results, and GSynaptics would not start. In the end, the answer lies in some serious xorg.conf modification, and since this is the only iBook I've tried Fedora on, I can't really say whether duplicating the following xorg.conf settings will definitely work for any Apple laptop or just the iBook G4 models or all iBooks but not PowerBooks...et cetera. However, this is my new xorg.conf, which seems to properly configure my touchpad so that it does not take Taps as Clicks. The first time I did this, it also seemed to have the side effect of disabling my fancy Desktop Effects (wobbly windows, desktop on a cube, and so on). I was willing to sacrifice the desktop effects since it really can't hurt to have that spare memory for more important things....but it was odd and annoyed me. I backed up the xorg.conf file, screwed it up to force an auto re-generation of the file, and then just pasted in the touchpad section. From then on, the touchpad worked properly and I also had my desktop effects. Here is my working xorg.conf: --------------------------(BEGIN) # Xorg configuration created by system-config-display Section "ServerLayout" Identifier "single head configuration" Screen 0 "Screen0" 0 0 InputDevice "Keyboard0" "CoreKeyboard" EndSection Section "InputDevice" Identifier "Keyboard0" Driver "kbd" Option "XkbModel" "pc105" Option "XkbLayout" "us+inet" EndSection Section "Device" Identifier "Videocard0" Driver "radeon" Option "UseFBDev" "true" Option "UseFBDev" "true" EndSection Section "Screen" Identifier "Screen0" Device "Videocard0" DefaultDepth 24 SubSection "Display" Viewport 0 0 Depth 24 EndSubSection EndSection ------------(END)

xKLAATUx

This is Avant-Garde

Random films that are, in varying degrees, "avant-garde"...whatever that means. Compiled by Dr. Terri Ginsberg, my avant-garde film professor.

Impressionism, Vorticism, Photogenie:

The Smiling Madame Beudet (Dulac, 1923)

The Fall of the House of Usher (Watson/Webber, 1928)

J'Accuse (Gance, 1919)

Dada, Graphic Cinema, Futurism:

Ballet Mecanique (Leger/Murphy, 1924)

Anemic Cinema (Duchamp, 1927)

Paris Qui Dort (Clair, 1924)

Constructivism and Formalism:

Kino-Eye (Verov, 1924)

Battleship Potempkin (Eisenstein, 1925)

Surrealism:

L'Etoile de Mer (Man Ray/Desnos, 1927)

Un Chien Andalou (Bunuel/Dali, 1929)

Le Sang d'un Poete (Cocteau, 1930)

Beat:

Shadows (Cassavetes, 1959) + all other Cassavetes films....

Pull My Daisy (Alfred Leslie, 1959)

Trance:

At Land (Deren, 1944)

Guns of the Trees (Mekas, 1961)

Flaming Creatures (Smith, 1963)

Lucifer Rising (Anger, 1964)

Mythopoeic and Lyrical Films:

Dog Star Man (Brakhage, 1961-1962)...and all other Brakhage films

Castro Street (Braillie, 1966)

Structural and Matieralist Films:

Eat (Warhol, 1963)

Word Movie (Sharits, 1966)

Wavelength (Snow, 1969)

Zorns Lemma (Frampton, 1970)

Radical & Art Cinema:

Land without Bread (Bunuel,1932)

David Holzman's Diary (McBride, 1967)

Unsere Afrikareise (Kubelka, 1961-66)

In the Year of the Pig (de Antonio, 1969)

Gently Down the Stream (Friedrich, 1983)

Invisible Adversaries (Export, 1976)

Dyketactics (Hammer, 1974)

Tongues Untied (Riggs, 1989)

Final Solutions (Tartaglia, 1990)

Mujeria: Primitive and Proud (Hildalgo, 1992)

Zyklon Portrait (Schogt, 1998)

xKLAATUx

OK OK Apple is often known for its glitzy interface design. Yay. I think it's over-the-top and annoying, but some people lick it.Is it intuitive? Well, it's intuitive now because the whole "your computer as a desktop" paradigm has pretty much permeated computing society, such that, for instance, when we see the icon of a folder, we understand that our little document icons are supposed to go into. Get it? The documents are kinda like Paper and the folder icon is like a Dossier, and so one goes "inside" of another. And you set it down on your "Desk". Yes, it mirrors the real world. Incredible....ly inaccurate.What about a paradigm more accurately reflecting what's going on in that there computer? Do away with the trash can and establish an icon or button that will reallocate the space previously occupied by a file as "empty space"....and yet the file still exists until it is ACTUALLY overwritten with real data. How about representing files in relation to one another? such that a file that was created in vim or kate or kwrite is a direct associate of vim or kate or kwrite....whilst a file that could be opened in vim or kate or kwrite could be farther removed "cousins" of these applications... and to locate a file in your GUI, one of the ways you could actually find it is by selecting the application you wish to actually use. So if I knew that I'd created a text document in vim, but now want to open it in Open Office and do some fancy formatting, I could select Open Office as my destination app, and I could see the documents that were created in it, and then the documents taht could be opened in it. And so on. New paradigms. it'll blow your mind!

xKLAATUx

I speak of course of Blender. Blender is one of my favourite apps ever. I use it, I love it, I am constantly amazed by it.But the one thing I'm really looking for in Linux, lately, is a really solid video editor. Yes, Blender can edit video...but..just because it can, doesn't mean it should -- at least in its present state. Let's get a few things straight and then move on to the pretty pictures:1. Blender is solid code, a robust and stable app, and absurdly powerful.2. Blender's current Video editor is technically sufficient to edit, but does not really have an interface designed exclusively to that purpose.3. As such, Blender would pale next to an Avid or Final Cut Pro workstation.The good news: in order to become the best video editing app for Linux/osX/Windows all Blender needs is a UI designed for the video editor, and a few patches to provide a few new functions that any professional video editor would expect.The bad news: I can design interfaces, but I can't actually program [yet]. Therefore, this is a post all about vaporware -- until a Blender dev (I am in contact with a few but can always talk to more!!) jumps on this idea.The idea is essentially this: design two interfaces -- one for the home video hobbyist (the iMovie, if you will, of Linux) and one for the video professional (the Final Cut Pro or Avid Express of Linux). Do not FORK Blender, as such, but simply provide an alternate interface for it, geared toward video editing.And now the pretty pictures:First, the home user version.Proposed Title: "Blender Movie Maker" or "Video Blender Lite"Features:1. Upper left quadrant is the preview window where you can audition video clips and lift good segments out of your hours of bad footage.2. Left quadrant also doubles as a file browser so that you can find your footage on your harddrive3. Upper Right Quadrant is your Target window (sometimes called a "canvas") where you get to see your movie as you edit it together.4. Middle of the screen is the timeline with audio and video and effect regions. You can make this as simple or complex as you wish; if you are getting close to being a professional editor, you have the capabilities to do multi-track editing. If you are just interested in stringing together the good parts of your home movies, then you can do a simple one-track edit.5. At the very bottom, we have thumbnails of all the cool effects you can put on your footage, like glows, blurs, fades, distorts, et cetera. Most of these effects already exist either in Blender or from independent programmers but can be downloaded and used for free (you can find them from the Blender site). The one thing we might want to look into is a simple and easy-to-use text generator but we could also argue that generating text in Inkscape and bringing it in as .png's would make more sense, too, which works for me.6. And that's it. Easy, elegant, and satisfying.blenderMovieEditor.pngNow, the professional version.Proposed Title: "Video Blender" or "Video Blender Pro"Features:1. pro editing environment with screen presets for rough cutting (would have easy access to video preview of raw footage), editing (seen in the picture), color correction (easy access to effects and color filters), and a screening room (intended for viewing the cut in a larger movie window, with fewer distractions on screen but with text editor open to make notes as you watch).2. video editor, not audio editor. Audio needs to be functional and in sync but trying to copy Final Cut's bloatware tendency to include audio editing capability is plain silly; it doesn't work well in FCP and it doesn't belong in a video editor!3. no video capture. Again, Avid and FCP include video capturing in the editing app. Bad idea. ffmpeg imports video quite well so Blender has no need to bother with that.4. SMPTE timecode given preference - video and film editors work in SMPTE not in an endless count of frames like many animators and motion graphic designers do. So videoBlender needs to give preference to SMPTE, and it will have counters so that the editor has quick reference to timecode.5. Customizable timline - video editors stare at strips of video all day long and it all starts to look the same. It seems silly, but color coding the video clip in the timeline is hugely helpful yet no video editing app has this as a feature. Let's put it into videoBlender.6. Screen Real Estate - Most video applications like to leave lots of windows open so you can be impressed by all their neat buttons blinking lights. videoBlender will conserve your screen real estate by using the upper left quadrant as a multi-purpose window (it can be your file browser when you need to look at files, it will be effect editor when you need effects, it will be node compositor when you composite, it will be the preview window when you need to preview a clip). The interface will still be customizable as in Blender, but the preset at least will be conservative on space.7. Intuitive interface for noobs, keyboard shortcuts for pros. There is a button row in the middle of the screen so that newcomers ca learn the tools. We can have keyboard shortcuts married to these buttons so that they are not necessary after you get to know the app.8. Easy Export - it's easy to render out to a file in Blender now, but it does involve navigating through a lot of mysteriously named buttons. This will be made simpler by excluding the 3d-modeling specific options.videoBlenderSpec.pngHere are some major features pointed out:videoBlenderFeatures.pngAnd here are the buttons explained:videoBlenderButtonTips.png----Comments, critique, further suggestions are all welcome. Yes, I'll be working on more UI specs later, to further detail various aspects of the application.Please spread the word about this idea if you like it, especially to all the super savvy Blender dev types out there! I have been told that the current Blender code is almost ready to be able to do this kind of "interface remix", and with just a few simple patches (some of which already exist, from discussions I've had with devs) the little extra functions that I think a video editor should have can be a reality.

xKLAATUx

...has been found.My friend "sooka" and I have almost identical computers; I have a black macbook and she has a black macbook. When sitting in front of it there is no distinguishable difference (viewing the back of the screen on mine would reveal a whole host of linux and FSF stickers, but from front view they are the same).Sooka regularly sits down in front of my computer, thinking it's hers, and starts using it to check her gmail and facebook accounts, etc, and I thought for a few weeks that it was kind of cool that she was so open to using Linux.Then I realized that for two weeks straight, she never even realized she was using my computer and not her own. Yes, hers runs MacOS X. Yes, mine runs only Fedora 10 + KDE 4.2 ...and yet, she never noticed the difference.Yes, ladies and gentlemen, the proverbial average Joe User has been found, and he is a she, and she is named sooka. Firefox on Linux and Firefox on MacOS X are apparently similar enough (although to me they look completely different) that she never noticed that on my computer there is a blue kicker at the bottom of the screen and on hers there is a fancy-looking dock at the bottom. It was only after she tried to watch a youtube video on mine (I keep flash off my system, thank you) and I mentioned that I didn't like Flash, that she realized she had been using my computer quite frequently for the past two weeks. And now she knows to look up in the upper-left corner of the screen to see if there is an apple logo or not. That is the one indicator for her as to which computer she is using.Is she oblivious? No. Sooka holds a bachelors degree and is a writer and has a vocabulary that has me scrambling for contextual hints to decipher what she's saying. This girl is S.M.A.R.T. But outside of a web browser (she's a longtime internet junkie), the concept of an operating system and things like that...well, it just isn't something she thinks about. So.....my guinea pig has finally been found. This is that mythical average user I have been looking for. And amazingly, she does FINE on Fedora 10. Granted, she doesn't do MUCH on my computer, but when I tell her to go to Firefox, she knows to click on the task manager button with the firefox logo on it to bring it to the front (she's also a Windows user so the task manager concept is not as foreign to her as it was to me when I started with KDE), and she seems to be able to navigate her way around the system well enough. Word is something I have yet to convince her to try on either Mac or Windows; she seems convinced that Word is only Word when run on Windows. And no, Word 2007 or 09 or whatever the latest one is, doesn't count. It has to be the previous version (whatever that one was) or it just isn't Word. Um, whatever. But overall, I told her to just pretend like Linux was windows, and I think that solved a lot of usability questions for her; the Right-Click habit took over and everything became obvious. Now for me, the idea of Right-Clicking is STILL something I'm trying to get used to, but for her it is a familiar old tradition. So, Fedora 10 and KDE 4.2 appear to be winners for Average User, and Firefox...once again....as always....F T WIn fact, cross platform free software FTW. Get them hooked on the app in OS X or Windoze and then do a fast switch of OS's, and they will be using Linux in no time.

xKLAATUx

I've been trying to ascertain whether or not the Average Joe actually even notices this kind of thing, but I am coming to the belief that in fact yes, they do....and of course I'm talking about integration among different applications on their system. Whilst at work, I get to see a lot of third party Mac apps as well as official Mac apps, and I started taking note of how well the design and the functionality integrated both back to the base system as well as to each other.So..what did I just say? Well let's break it down:APIIf a GUI framework has a strong set of API's for programmers, the programmers will use them. If the API's reach enough of a high-level function, they will greatly add to the sense of consistency on that platform. For instance, the Mac TEXT palette and the COLOR PICKER are both obviously cocoa API's that every programmer can use in their app. And because of this, any time a user looks to pick a font or a color, they always get the same exact dialogue box.BUTTON LOCATIONSThs is the great ideal that no one ever reaches, but the idea is that an OK button or a CANCEL button or whatever, will always be in roughly the same place. Or a BOOKMARKS button or HOME button or whatever.

xKLAATUx

So I got round to thinking it'd be cool to have portable slackware. first checked out zipslack, the official minimal install of slackware......except that it isn't. It's a way to get the basic installer onto a USB drive or other small media so you can boot into an installer, then continue installing via network or whatever.

Next option, obviously, was Slax. By coincidence, a new version was just released - Slax 6.0.2 - which has an installer especially designed for USB thumb drives.

Initial install went great, everything worked fine. Hanging around in ##slax on irc.freenode.net, however, someone asked me for installation help. I tried an installation again and utterly failed several times.

So it turns out that there are a few pitfalls here and there during installation; here's what they are and how to avoid them:

1. extracting

> the way you want to extract what you download is as recommended:

in the terminal:

$ cd /media/usbdrive // or wherever you have your usb thumb drive mounted

$ tar -xvf ~/path/to/slax-6.0.2.tar // that is, where ever you have the slax tarball

$ sudo ./boot/bootinst.sh // running the installation script for vfat (more on this in a moment)

and from there, ideally, it just installs itself! If you don't set it up that way, however, the paths of certain files aren't going to resolve and you could have installation problems.

A successful install is fairly verbose. It tells you that the installation is complete; upon error, it tells you what error it ran into.

2. File Systems

You can put Slax onto a drive formatted a number of different ways. I guess one of the most typical formats is vfat, created by:

$ umount /dev/sdb1 // you may have to be root to do that

$ mkfs.vfat /dev/sdb1 // or whatever the path to your usb drive is

If you use a vfat formatted drive, you will need to use the ./boot/bootinst.sh method of installing.

You can also put Slax onto an ext2 or xfs formatted drive. To create this you'd do:

$ umount /dev/sdb1 // again, you may need root...and /dev/sdb1 would be whatever your usb location is

$ mkfs.ext2 /dev/sdb1 // or, if you have xfs capabilities installed, mkfs.xfs /dev/sdb1

This is important: if you use these filesystems you MUST use run ./boot/liloinst.sh during installation -- not ./boot/bootinst.sh

If you try bootinst.sh with ext2 or xfs or anything but vfat, your installation will fail.

3. Booting from USB on a Mac.

> Probably only 95% of people reading this care, but some people, like me, are stuck around Macs at work and occasionally would like to boot into a sensible OS like Slax, from USB. It's easy from Slax/CD - you pop in the CD, reboot holding the "C" key. But I like USB keys...but that's too bad, because Macs don't. An Intel Mac will not boot from USB. Possible exceptions? The Apple TV might, given that its sole USB port is by default looking out for a USB drive with all kinds of interesting updates for it. Whether it will actually BOOT or not, I don't know yet, but there's a chance. Another idea I've had is to get a physical USB-to-Firewire adapter, and seeing if I can trick the Mac into booting off the drive that way. Seems unlikely, but it'll be worth a shot sometime. Maybe.

4. Where's my AIM?

> Pidgin on slax don't got AIM or ICQ. You'll have to recompile it to get it in there.

5. How can I make it persistent?

> Actually, my install is just magically persistent. I don't know why...I think the Slax guys might have made it persistent by default with 6.0?

But supposedly, you can make a directory on your flash drive. Let's call it "slaxrc" for kicks. When we get to Slax's Lilo screen, we can use the boot parameter:

changes=/slaxrc

and then slax will know where to put all of our changes and where to find them again later. I suppose you could even add this boot param to your Lilo settings in Slax....haven't bothered doing it myself but maybe i will sometime.

xKLAATUx

Some time ago, I realized that to be a good little anarchist, there were certain things in my life I'd have to start to do without. After I got out of the proprietary OS trap, and stopped playing the whole "must have a job, must have good credit" financial scam, and stopped voting, and ditched some of those false ethics that capitalistic society needs for us to believe in so that their whole 10%-rich-vs-90%-poor social model to work, I started focusing my attention to entertainment.

Now, I'm not that difficult to entertain. I read a lot, I mess around with Linux a lot, and I'll make whatever kind of art I'm inspired to make at any given moment. But sometimes one wants to sit back and, say, watch a movie or listen to an album or something. The problem with the latter forms of entertainment is that they support the broken business model that is Time Warner, Vivendi, EMI, and, what, a couple other big companies?

So, in short, I figured out I had to start really being serious about local and independent art.

The problem there is, how do we define "independent"? It's always been a problem with art, because sometimes "independent" simply means "not in the same vein as the current competition" (which is why some people will define bands like "Bat For Lashes" as "independent" even though they're signed with Astralwerks >> Virgin/EMI), but sometimes it is a more objective statement meaning that an artist is independent of any "big" established business....and of course then you get into the question of what "big" really means. Is an artist not independent if their records are being sold via K Records? they <em>are</em> on a record label, after all. If a group of three independent artists band together to create a cooperative organization to promote their art, are they no longer independent? And so on.

This was the eternal question for me until at last I started really getting familiar with Free Software and that most marvelous document, the GPL. If we judge Free Software to be free if it is GPL'd, then I reckon the way to judge Free Art is by way of its Creative Common status.

This makes a lot of sense, but the problem is that there's actually not all that much art out there that is creative commons.

xKLAATUx

So whilst watching Star Wars The Empire Strikes Back for the nth time, I was relishing the scene in which Darth Vader and Boba Fett are discussing what might happen if Han Solo is killed by the Carbon Freeze process. And it struck me that with all the Empire's wealth, why didn't the Emperor just cut Boba Fett a big fat cheque so they wouldn't have to bother with the whole Han Solo thing, much less spend time arguing over who's gonna deal with Jabba the Hutt should Han Solo die during being frozen in carbonite. Well, I guess teh Empire was probably just like any other governing power and had a lot of red tape to get through. Vader was probably improvising when he brought in Boba Fett and wasn't sure if he could get the proper tax forms and stuff to actually employ Boba Fett. So I understand.And I still say that Boba Fett got out of that pit in ROTJ. We didn't see it, but he flew right back out and went on to have quite a few anarchistic, mercenary kind of adventures. Or am I stepping on someone's expanded universe?Well, back to the movie.

xKLAATUx

su + environment

Everyone knows that$ su fubar<password>switches user over to, in this case, a user named fubar.However, this doesn't bring along with it fubar's user environment; so, for instance, if you have su'd over to fubar and an app you are using needs to write a file into /home/fubar/.kde file, then that app will not be able to do it because you are fubar but you are not in fubar's user environment.OK, so to switch over to fubar + fubar's world, you must do this:# su - fubar<password>Note the - (dash) between the su and the fubar Now you can do everything the user fubar would normally be able to do without any unexpected permission errors.(I have to thank Popey for that tip; he saved my life with it while I was flirting with postfix. I was amazed I'd never encountered that seemingly basic yet vital distinction in all the beginning UNIX books and courses I've taken........)

xKLAATUx

Spotlight Search

I never liked Spotlight, the Mac search tool. I use it basically just to launch Applications when Quicksilver is not available.

I always suspected it was not being accurate...or at least not relevant. And I've tweaked it and set up Do-Not-Search folders and so on and so on..but in terms of the concept of a Sematic Desktop, Spotlight just doesn't seem to be quite working for me.

Today it really didn't work for me. Notice the discrepancy in the screenshots.

xKLAATUx

small community

Here's the thing. Right now the Linux community is / feels small. You subscribe to a few blog planet feeds, you use the usual software and glance at who is maintaining it, you subscribe to your local LUG and LoCo email lists, you troll IRC a bit,you listen to a few (or more than a few) podcasts, you attend an expo or confernece... and pretty soon you start actually getting to know people. At first you just recognize the name. Then you make a few comments on their blog, maybe find them on facebook, and eventually meet them at a conference, and you can justifiably call them a friend or at least a solid acquaintance.And that's nice; I like it. It's kind of cozy.The other side of the coin is the proverbial "we need/want more developers to code more/better apps" and "we want more support from big companies so we can go out and buy a wifi card or a webcam without fearing driver issues" and so on.So, can we just have our cake and eat it, too?

xKLAATUx

Sleep Mode on an iBook G4 + Fedora 8Getting laptops to properly go to sleep is a notoriously difficult hurdle, but at least on my iBook G4 with Fedora 8 "Werewolf" it was as simple as installing a single little app. # yum install apmud apmud is the power management system for the PowerPC computers, and works like a charm. I close the lid. The iBook sleeps. I open the lid. The iBook awakens. === Bonus BinRev blog ONLY! material: ====One bug I have noticed, although have not really sat down to analyze when and why exactly it happens, is that some times the iBook won't be able to get back onto the network it was on before sleeping. Going into the terminal and typing % su% (enter your root password)# ifconfig wlan0 down# ifconfig wlan0 upgets you back online within seconds. Still, it's a bug, and I'm trying to follow the pattern so I can actually make the bug known to Fedora. All in all, it's no more bothersome than the little bugs Mac OS had when it would sleep and occasionally decide not to wake up.......in fact I'd much rather have to reset the wireless card than to have my computer just screw me out of any unsaved changes to data. So I guess in that way I'm much better off.

xKLAATUx

Called out sick today because I didn't feel like going in to work, and as a result got A LOT done! Further proof that without pointless employment, a person can be quite productive:1. Played with mplayer, read lots of documentation (prep for next HPR episode..?)2. Did two or three spec boot screens and wallpaper art for slast, the live asterisk linux distro.3. Did a boot splash for the KDE 4 version of Fedora 9 and submitted that to the Fedora art team.4. Did a quick and very fun Phone Losers of America wallpaper...no reason...just did it.5. Posted episode 2x14 of Bad Apples.6. Got an email from a guy who once had a Fedora podcast; I may be taking that over.7. Got my NAB tickets in the mail, arranged for a cheap hotel.Yeah, it's good to not go to work.

xKLAATUx

slackware v13

Slackware.com seems to be down atm. With version 13 just around the corner -- with the big official switch to KDE 4 and the new official 64 bit version -- well, my imagination is running wild. Will the site re-appear tonight with all the new iso's one could ever hope for?

Nah, probably not. I probably just need to re-set my router. But anyway, I'm going to pretend like it's much more exciting than that.

xKLAATUx

slackware 12 on sony vaio vgn-n250n - a love story _________INSTALLATION ___________ So I downloaded and installed Slackware 12. First, I backed up the stuff I had on the computer just in case I screwed it all up. I didn't have much personal data on there, so it all fit onto one CD-RW. My harddrive was already partitioned, so I didn't have to do anything except define for the installation which partition I would be using. In my case, it is the /dev/sda1 partition. Linux also wants a SWAP partition; that is, a small partition for, what we in the Mac world would call Virtual Memory. I already had a swap partition, so I just pointed Slackware 12 to it. It is worth noting that I might have three distros of Linux running on my notebook but I only need one SWAP. I also have a tiny little partition at the front of my drive to serve just as the Master Boot Partition. This is where the boot loader exists, so that I can choose what partition I actually want to boot into. This is akin to holding the OPTION key down during starting Mac OS X and choosing whether one wants to boot into one partition or another, or into OS 9 back in the old OS X days. Other than these details, installation was as easy and friendly as installation on any system, minus the pretty graphics. __________SETTING UP X________________ The system was installed. I logged in as root and began setting up a GUI environment because I figured it’d be somthing easy that I could get out of the way quickly. Because of my NeXTbook project, I was really familiar with X11. And setting it up in Slackware 12 was, as expected, pretty easy. Compared to what I was having to do with my NeXT project, it was actually really easy. Slackware 12 includes a xorgsetup script that prompts the user for screen resolutions and refresh rates. Sony does not publish any of this information - I have read through all their documentation and can attest that it is nowhere on their site or in anything I received with the computer itself. To find it all out, I had to reboot into Ubuntu, look at the auto-detected settings that Ubuntu had generated, write those down, and enter them in as my set up in Slackware. Thanks, Sony. As I mention in my previous post, the “FINDER” post, in Mac OS X the Window Manager is quartzWM. I guess we would generally or flippantly call it Aqua. Anyway, whatever it’s called it generates and controls everything we see onscreen. If one tries to run X11 on the Mac, quartzWM does its best to control X11, and getting X11 away from quartzWM is a real trick (which I have figured out and will detail in the forthcoming NeXThack episode of The Bad Apples). We generally think of everything we see as THE DESKTOP or THE FINDER, but they are very separate programs; see my previous post for details. The Finder, proper, is the “File Manager” of OS X and simply gives us access to graphic representations of our files. There is a published hack to Quit the Finder and have no access to one’s files except through line commands in the Terminal. So, on my Slackbook my Window Manager is Fluxbox (which, unlike many window managers for linux, does not model itself at all after Wind0ze but is much more like NeXTstep). I have not configured a file manager for it yet, because I happen to know that I have many choices, so for now I will access my files via my xTerm (Terminal). __________WIRELESS CARD DRIVER_________ Now I had to install the wireless drivers. As I said above, I found that the drivers I needed were included on the Slackware DVD, as were some very clear and helpful instructions (much more helpful than Intel’s documentation included with the drivers). So I installed the drivers easily, without a hitch. Well almost: By now I was familiar with the usual Unix installation commands: % ./configure % make % make install Intel’s documentation told me to install the ipw3945d daemon by simply entering %make But that was wrong. I trusted them at first, and it didn’t work, so I went back and typed % make % make install And that worked. Otherwise, it all went smoothly. I rebooted to verify that the ipw3945abg card was really being recognized, and by reading the screen during bootup, I saw that everything was loading fine. Very exciting! But, strangely, when I tried to telnet into my freeshell account, nothing happened. Well, obviously my card was being recognized, but it wasn’t actually being used; it wasn’t on my LAN. Hm. _________GETTING NETWORKD_____________ I did a lot of research and found out that there were three commands relating to getting one’s networking device up and running. These are: % iwconfig # which is wireless-specific % ifconfig # which is for all network devices % modprobe # which loads a “module” into the kernel; in Mac terms, it would load an “Extension”. So I learned from a 2004 posting on a linux forum that once a wireless card driver is installed, all you need to do to bring it to life is to type this series of commands: % modprobe ipw3945 # which brings the module into the kernel. I know the name of the module is ipw3945 from the driver documentation % iwconfig eth1 essid XXXXX # assigns the card to a network; name is defined by me in the Airport Setup Utility % iwconfig eth1 channel 10 # because I set my Airport to be on Channel 10 % iwconfig eth1 key XXXXXXX # where key = the HEX code (or whatever) and NOT the ascii text I typed into my Airport Setup Utility. This, I discovered only after much poking around in the Airport software, in which there is a small, insignificant-seeming button that tells you “Oh, and by the way, if you’re not using an Apple you need to enter THIS code, not the passphrase you just created”. Oh. OK. % ifconfig eth1 up # to bring the network device up % dhcpcd eth1 # to receive the DHCP information from the wireless router. And this series of commands worked perfectly. I was suddenly online; I started the GUI, took a look at Firefox - and sure enough, everything was fine. I was ecstatic, and decided to take it one step further and create a shell script that would do all of those commands for me so that all I’d have to do is type one word. And so I did; I wrote a little script, made it executable: % chmod u+x ipwscript and tried it out. All I hade to do was type “ipwscript” and I was online in milliseconds. Well, at this point I pretty much figured I’d reached the pinnacle. Little did I know...... _____________ADD USER ACCOUNT______________ There’s a script program included with Slackware that prompts you as root to create a user account. I looked up in my Unix reference book to see if there was another way of doing this - I’m sure there is, but it doesn’t really matter. Obviously any usable Unix system is going to provide you a way to create a user account, so I just used the Slackware script. It made creating a user account very easy; as easy as doing it in Mac OS X except, again, without the graphics. To test everything out, I rebooted and logged in as user. X started up fine, but when I opened up Firefox, nothing happened; I was not online. So I typed in my magic script “ipwscript” and....again, nothing. Apparently the commands contained in my script were root-only commands. I struggled with the “sudoers” file in an attempt to give myself as User permission to initiate iwconfig, ifconfig, and modprobe — but it didn’t work. So I need to study “sudoers” permissions more. But in the meantime, I had the choice of either learning sudoers or just fixing the whole wireless problem altogether; obviously one shouldn’t have to type in those iwconfig commands (even if I did hack it down into a one-word trigger) if one doesn’t want to. So I did some research and discovered that what we Mac pros would call our “Login Items” is, in Linux, a collection of configuration and init files contained in the /etc/rc.d directory. ___________AUTOMATION________________ The /etc/rc.d directory contains two kinds of files. There are rc.XXXXXX files, and there are rc.XXXXXX.conf files. The conf files are what we edit, providing data that will be read by the rc.XXXXX files, which are basically scripts themselves and are executed during bootup. The first thing to do is to tell the computer that there is a wireless card in existance. To do this, add to /etc/rc.d/rc.modules this: /sbin/modprobe ipw3945 OK, that loaded the module or the Extension. The next thing to be loaded during bootup are the iwconfig The default /etc/rc.d/rc.wireless.conf looked like this: INFO="Any ESSID" ESSID="Any" ;; And so I changed it to read: INFO="Any ESSID" ESSID="XXXXXX" KEY=XXXXXXXXX ;; These changes essentially knocked out the need to do all of my iwconfig settings. So I rebooted and <Either I cannot spell or I am so unoriginal that I re-used a lame internet meme that has no value whatsoever to these forums and have been wordfiltered>ched as it booted. Everything seemed to be loading just fine. It was detecting the card, it was bringing it into the kernel....but when I tried to get online, it didn’t work. I typed: % iwconfig and looked at the results. It was all perfect; everything that was there when I was online was there now. So the problem had to be with the ifconfig and dhcpcd steps of my little getting-online command sequence. So I typed: % ifconfig eth1 up % dhcpcd eth1 and sure enough that brought me online. So, how to get THESE commands to occur automatically during boot? Further research was required, so I typed % ifconfig and compared the results of “ifconfig” while I was online to the results of it while I could not get online. Everything looked the same, except that when I couldn’t get online there was an entire line missing; this line contained the INET ADDR, the BCAST, and MASK. To fix this, I opened /etc/rc.d/rc.inet1.conf and - sure enough - noticed that the variables reserved for eth1 were all empty. So...... I plugged in the numbers for: IPADDR (ip address; not really sure if I need this because it’s overridden I think by DHCP but...whatever) NETMASK (the usual 255.255.255.0...whatever that means) and I changed USE_DHCP="" to read: USE_DHCP="yes" Save. Reboot. And I'm online automatically as Root and as User. It was a beautiful, wonderful thing.

xKLAATUx

Setting up OpenPGP

To spare myself from going into great technical detail of how it all works, this article assumes you're ready to set up an OpenPGP key so that you can encrypt your email and files, and also ensure that the people you think you are emailing are really the people you are emailing. The way that this is done is to create for yourself a Public Key. The person on the other end also creates a Public Key. You trade Public Keys with one another. When you encrypt email destined for that other person, your system encrypts it in such a way that only that person's system, with their special Private Key, can decrypt it. This is all made possible by OpenPGP, specifically on most Linux systems with a Gnu software program called GPG. So, here's how you set up an OpenPGP system on your system: ''Note that % means a regular user and # means root.'' __Create your Public and Private Key__ In your terminal, type this: ^% gpg --gen-key^ A text menu pops up, giving you a choice of encryption methods or something like that; I used the default by typing in 1 You are then asked how many bits you'd like in your key. The default is 2048. You can go lower or higher. You then must choose if and when you'd like this key to expire. The default is Never (0) but you can do anything you feel necessary. Confirm all of these choices with "y", and then you'll need to assign a user, email address, and an optional comment to that key. It prompts you for each of these, so enter the email account information you wish to use with this key. We will go over adding more accounts to this key later in this article. Your system then sets about generating a random number -- and at least in the case of a long key it may literally ask you to do something else on the computer so that the random number generator has data to work off of. Eventually, it will generate enough bits for your key, and returns this information: ^gpg: /home/klaatu/.gnupg/trustdb.gpg: trustdb created gpg: key 12345678 marked as ultimately trusted public and secret key created and signed. gpg: checking the trustdb gpg: 4 marginal(s) needed, 3 complete(s) needed, PGP trust model gpg: depth: 0 valid: 1 signed: 0 trust: 0-, 0p, 0m, 0r, 0f pub 2034D/12345678 2007-12-25 Key fingerprint = 4C72 DEAD E45F F314 8929 FD67 EF23 6B33 3779 2739 uid Klaatu (thebadapples) <gort.klaatu@gmail.com> sub 2368g/DF66E34E 2007-12-25^ Note, on the second line, the key "12345678". That is your Key ID, which you'll use to configure your system. (It is not your public key that you will send to friends with whom you wish to have encrypted conversations.) __To Add Users and Accounts to Your Key__ I have at least three email accounts in my desktop email client, and I hardly want to have a separate key for each account, so I need to add these accounts to my key. To do this, simply type % gpg --edit-key 12345678 You will be given a prompt, at which you'll need to type "adduid" and then you simply have to follow the prompts. You can do this as many times as you need. This is what it looks like, with some content edited out for readability: ^% gpg --edit-key 12345678 gpg (GnuPG) 1.4.7; Copyright © 2006 Free Software Foundation, Inc. This program comes with ABSOLUTELY NO WARRANTY. This is free software, and you are welcome to redistribute it under certain conditions. See the file COPYING for details. Secret key is available. [content edited out for readability] Command> adduid Real name: Gort Email address: gort@ncc1701.com Comment: thebadapples You selected this USER-ID: "Gort (thebadapples) <gort@ncc1701.com>" Change (N)ame, ©omment, (E)mail or (O)kay/(Q)uit? O [edited for readability; your key password will be required here] Command> quit Save changes? (y/N) Y^ __Exporting Your Public Key__ Now you've set up the GPG system. Note that the GPG information that your system uses and refers to has been saved to your home folder, in a hidden directory called .gnupg ^/home/username/.gnupg^ Now you need to extract your Public Key from this information so that you can have the key as a physical file that you can send to your friends. ^% gpg --armor --output klaatukey.asc --export^ This creates a file called klaatukey.asc, which I can attach to emails that I send to people. If they are also GPG users, they will import this key into their trusteddb file and from then on you can email back and forth with encrypted messages that will be able to be read by you both, but no-one in between. You can set Evolution and Thunderbird to encrypt your messages automatically as well as attach the actual klaatukey.asc file, but if you're using webmail you'll probably have to attach it manually, so you may want to either upload this to your own server or put it on a USB drive or your Nokia N800 or something that you keep on you. __To Import Someone Else's Key to Your Trusted Database__ If someone has attached their key in their email, you can download it and then run this in your terminal: ^% gpg --import pubkeyfile.asc^ In Evolution or Thunderbird, you can simply choose to import the key to your trusteddb from menu options. There's also a way to go get public keys from key servers, but you need to know the address of the keyserver. You can go to the keyserver, search for the person's email address, and download their Public Key. You are then able to encrypt your email using their Public Key so that only they will be able to decrypt it. ^% gpg --keyserver http://www.KeyServerUrl.com --keyserver-options honor-http-proxy --search-keys Email@Address.com^ __Transporting Your GPG Information to Another Computer__ The days of one computer per person are in the past. In the past, I have had up to 6 active computers at a time. Now I am down to 3 or 4 (2 personal laptops, 1 work laptop, another work laptop, and a fixer-up soon to be donated to someone who needs a computer). Anyway, the point is that if I set up GPG on one system, I probably have at least two other environments I'll want that GPG infrastructure installed. Luckily, all you'll need is the .gnupg directory from your $HOME. So, either copy this directory to a USB drive and sneakernet it over to your other system, or send it over your LAN, or whatever, but it really is as simple as that. ^ user@desktop: % cp -r ~/.gnupg /media/jumpdrive/ user@laptop: % cp -r /media/jumpdrive/.gnupg ~/ ^ Once you've copied the .gnupg directory to the other system (in the example above, from one's desktop to one's laptop), the GPG system on the second computer detects the .gnupg information and now it's automagically configured. Nice, huh? If you don't have GPG installed on the second computer, you should be using Linux. __HOWTO set this all up in Evolution__ On my Fedora iBook, I use Evolution as my mail client. Setting up GPG is simple: ^Edit > Preferences > Accounts^ I have three accounts set up here, so for each account I would do this: - Click on the account you wish to add the GPG key to. - Click EDIT - The last tab in the new menu that appears is "Security"; click on this - In the SECURITY tab, the top selection is OpenGPG, so enter into the KEY ID field your key ID...that's the 8 number thing that you were given earlier. - Click on whatever selections you want; I usually have the automatic options turned on so that my emails are always signed. - Click OK, and then either repeat these steps for other accounts or click OK to leave preferences. That's it. __Setting This Up in Thunderbird__ On my Ubuntu and Slackware laptop, I use Thunderbird. First you must install the [https://addons.mozilla.org/en-US/thunderbird/addon/71|EnigMail] Add-on for Thunderbird. ''Note: When I did this, I had not yet set my system environment to recognize Thunderbird as its default mail reader, so Firefox didn't know what to do with the install file and kept trying to install Enigmail into itself. To get around this, I did this: '' ^% wget https://addons.mozilla.org/en-US/thunderbir....95.5-tb+sm.xpi ^ ''I think I had to send an option along with wget to bypass a secure connection, or something, in order for mozilla.org to let me get the file...although I just tried it again and it worked with a normal wget. Anyway, the point is, get the .xpi file onto your computer, then go to Thunderbird > Tools > Add-ons > Install and select the .xpi file. Thunderbird installs it and offers to restart. '' Restart Thunderbird. Now there will be an OpenPGP menu available to you in the main window of Thunderbird. There's not much to do here, although I do go into OpenPGP > Preferences > Show Advanced Options. As long as you've imported your .gnupg folder, frankly EnigMail seems to just pick it up without any further settings from you. It's fairly transparent. __Revoking a Key__ So what happens when your arch-enemy's robotic minions discover your Private Key? Well, you'll need to revoke that key and get a new one. And be more careful next time ED-209 comes knocking at your door asking to see your Private OpenPGP Key. ^% gpg --output revoke.asc --gen-revoke 12345678^ You will be asked why are revoking the key, and then it will generate a revoke certificate. Now, what do you do with this? I have no idea, because I've never had to revoke one before. I reckon I'll cross that bridge when we get to it.

xKLAATUx

A friend of a friend contacted me and asked where a laptop could be recycled.

I told him I would be glad to "recycle" the laptop for him and explained that I could put linux on it and it would be great. He warned me it was in bad shape but I didn't listen. People think computers are in bad shape the minute they can't sign onto AOL.

So I show up to pick up the latop and he brings out a brown paper shopping bag with the laptop in it and I look inside to see pieces of laptop. Shattered, crushed, torn asunder. Totally smashed. It was gruesome.

I asked him what had he done to it?

He told me that his computer expert friends told him to smash the hard drive to protect himself from internet hackers who might steal his identity I said oh.

Funny thing...someone dumb enough to smash a perfectly fine laptop instead of donating it to someone who can put it to good use is also too dumb to know wtf a harddrive is. Turns out he smashed everything BUT the harddrive. As I sorted through the pieces of the poor dead Dell, i find the ram chips and the harddrive both utterly untouched. Perfect condition.

Next step? Plug the harddrive into a sled and steal that guys identity. Now he's asked for it!

Well maybe not, but come on.... should we really be telling people to destroy their computer equipment for fear of the evil haxxors? There aren't college students out there who could use the computer? or kids in some part of your own town that could use it? What losers.

xKLAATUx

Further adventures in being a noob and trying to play on networks:So I've got Fedora 11 running in Qemu and I'm out at this cafe and I can't get online in Qemu. My host OS can get online fine, just not the [Q]emulated OS.So I do the usual network troubleshooting...

bash$ ping google.comHost unknown

Well that means I'm not even getting outside of my virtual machine, because if it could get out of the machine it would at least have told me the host was unreachable. But this message is telling me that it can't even take a stab at who or what I mean when I say to ping "google.com"OK, well since hostnames are pretty much the sole domain of DNS, I figure there's one place to look: /etc/resolv.confWell, first I do an ifconfig just to make sure I'm all configured. Turns out I didn't even have an IP address...lol. What a noob. But that's easily fixed:

bash$ ifconfig eth0	  Link encap:Ethernet  HWaddr 01:1F:23:F4:2B:19		  UP BROADCAST MULTICAST  MTU:1500  Metric:1		  RX packets:0 errors:0 dropped:0 overruns:0 frame:0		  TX packets:0 errors:0 dropped:0 overruns:0 carrier:0		  collisions:0 txqueuelen:1000		  RX bytes:0 (0.0   TX bytes:0 (0.0 		  Interrupt:16

Now, don't be fooled...I'm not really hardwired in. I'm just virtually hardwired from my Qemu machine to my real machine's wifi connection.Anyway, to get the IP address:

bash$ su -c 'dhclient'bash$ ifconfig eth0	  Link encap:Ethernet  HWaddr 01:1F:23:F4:2B:19		  inet addr:10.0.2.17  Bcast:10.0.2.255  Mask:255.255.255.0		  inet6 addr: fe70::22e:44aa:fec8:29c2/64 Scope:Link		  UP BROADCAST MULTICAST  MTU:1500  Metric:1		  RX packets:0 errors:0 dropped:0 overruns:0 frame:0		  TX packets:0 errors:0 dropped:0 overruns:0 carrier:0		  collisions:0 txqueuelen:1000		  RX bytes:0 (0.0   TX bytes:0 (0.0 		  Interrupt:16

OK, now I'm back on track. I have IP address, I still have no inets. Just to be sure, I pinged again and got the same response so, yeah, I really do have DNS problems.So we need to look at what /etc/resolv.conf says:

bash$ less /etc/resolv.conf: generated by something-or-anothernameserver 10.0.1.1nameserver 10.0.1.2

...or something like that. Totally unfamiliar and obviously not working. Well, my host OS is getting out onto the www so why not look at its resolv.conf file:

bash-hostOS_$ less /etc/resolv.confdomain freeUnsecureWifi.netsearch freeUnsecureWifi.netnameserver 10.61.32.1nameserver 1.1.1.1

So I just copy all that information into the /etc/resolv.conf of my virtual machine's /etc/resolv.conf and...I'm online.End of story.Alternate Ending:Then I thought, well, maybe I should try using openDNS's nameservers just for kicks.

bash$ vi /etc/resolv.confdomain hackerpublicradio.comsearch hackerpublicradio.comnameserver 208.67.222.222nameserver 208.67.220.220

And well whaddya know, it still works. I like Linux.