Jump to content


Photo
- - - - -

Linphone anyone?


  • Please log in to reply
17 replies to this topic

#1 dual

dual

    BinRev veteran

  • Agents of the Revolution
  • 1,196 posts
  • Gender:Male

Posted 12 March 2003 - 05:39 AM

As posted on Cattle Call, I'm looking for someone to use/learn Linphone with. Alsa drivers are needed and I think a co-authored article could come of it.

#2 JHVH-1

JHVH-1

    DDP Fan club member

  • Members
  • 56 posts

Posted 12 March 2003 - 09:57 AM

Have you ever tried gnomemeeting? It's basically a netmeeting clone for windows that is even compatible I think.

Anyways, I have exams this week but after friday night I am on spring break finally so we can mess with Lunix stuff (maybe get heretic II working on your machine :D )

#3 M_from_S

M_from_S

    elite

  • Members
  • 105 posts

Posted 12 March 2003 - 03:28 PM

I might not be the best candidate since i'm new to the linux world but i'd be willing to give ol' linphone a try. I figure it would be a great way to learn some of the ins and outs of redhat linux. Or after i run down to staples today, maybe mandrake. Regardless, if you don't mind providing some potential help with the setup i'll give it a try.

#4 dual

dual

    BinRev veteran

  • Agents of the Revolution
  • 1,196 posts
  • Gender:Male

Posted 12 March 2003 - 08:49 PM

I'll help anyway I can. Hopefully, I can try it out this weekend.

#5 dual

dual

    BinRev veteran

  • Agents of the Revolution
  • 1,196 posts
  • Gender:Male

Posted 13 March 2003 - 10:46 PM

Ok, Linphone is just not working. So I gave GnomeMeeting a shot and it was a snap to get working. Now I just need to make a call. Are there any issues with getting GM through my Linksys router? I'm assuming I have to foward the port GnomeMeeting uses.

#6 dual

dual

    BinRev veteran

  • Agents of the Revolution
  • 1,196 posts
  • Gender:Male

Posted 13 March 2003 - 10:51 PM

Yep, TCP 1720. Now, to make a call.

#7 M_from_S

M_from_S

    elite

  • Members
  • 105 posts

Posted 14 March 2003 - 12:28 AM

Too bad about linphone, it seemed so straightforward. I'll give the gnomemeeting a try but it won't be until this weekend, probably sunday. If i get it setup correctly we can try a call.

#8 BoBB

BoBB

    SUP3R 31337

  • Members
  • 155 posts

Posted 14 March 2003 - 08:55 AM

Did you try compiling it from source dual? I compiled with the options --enable-alsa and --enable-gnome-ui=no and it worked fine, you dont get some pretty graphic interface though. I compiled version 0.10.0 with libosip 0.9.3, its the only way I could get it to install. And dont listen to the readme you can install it to /usr/local/ you dont have to install it to /usr/

#9 dual

dual

    BinRev veteran

  • Agents of the Revolution
  • 1,196 posts
  • Gender:Male

Posted 14 March 2003 - 02:20 PM

Nope, I was messing w/ rpms. I'll try the source shortly.

#10 dual

dual

    BinRev veteran

  • Agents of the Revolution
  • 1,196 posts
  • Gender:Male

Posted 15 March 2003 - 07:43 AM

./configure needed pkgconfig and glib > 2.0, so I added them. Now I get this:

checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.0, but GLIB (2.0.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files

I seem to remember someone having a similar problem on the board. I'm looking into the fix now.

#11 BoBB

BoBB

    SUP3R 31337

  • Members
  • 155 posts

Posted 15 March 2003 - 11:36 AM

So, pkg-config returned 2.2.0 but you only have 2.0.6 installed? Or you have 2.2.0 installed and configure isn't finding it?

#12 dual

dual

    BinRev veteran

  • Agents of the Revolution
  • 1,196 posts
  • Gender:Male

Posted 15 March 2003 - 02:22 PM

Apparently, I already had 2.0.6 installed and then I proceeded to install 2.2.0.

#13 BoBB

BoBB

    SUP3R 31337

  • Members
  • 155 posts

Posted 16 March 2003 - 07:46 AM

did you install it from rpm or from source? If you installed from source make sure /usr/local/lib is in /etc/ld.so.conf and if you installed from rpm make sure you installed with the -U(upgrade) switch instead of -i

#14 dual

dual

    BinRev veteran

  • Agents of the Revolution
  • 1,196 posts
  • Gender:Male

Posted 16 March 2003 - 10:22 AM

Thanks, BoBB! I ran ldconfig /usr/local/lib and linphonec is running. Now to configure...

#15 BoBB

BoBB

    SUP3R 31337

  • Members
  • 155 posts

Posted 16 March 2003 - 11:36 AM

cool :) Its pretty easy to configure, first make sure the if_name= is set to the right eth device, and put in a username and hostname under the [sip] section, make sure it is your global hostname not your local hostname, most likely will be your ip adress. After that you can run the sipomatic program and then open up linephonec and make a call to robot@127.0.0.1:5064 ... You should here some wierd message, I couldn't tell what it said but if you hear something then that means it works.

#16 dual

dual

    BinRev veteran

  • Agents of the Revolution
  • 1,196 posts
  • Gender:Male

Posted 16 March 2003 - 12:30 PM

It's working and I heard the message. Sounds like a French accent... I feel so unpatriotic using Linphone. Thanks again, BoBB.

#17 dual

dual

    BinRev veteran

  • Agents of the Revolution
  • 1,196 posts
  • Gender:Male

Posted 18 March 2003 - 09:03 AM

BoBB, I actually read the Linphone manual and found that I need to forward port 7000 (RTP) as well as 5060 (SIP). Next time it should work.

#18 BoBB

BoBB

    SUP3R 31337

  • Members
  • 155 posts

Posted 18 March 2003 - 12:56 PM

cool, let me know when :)




BinRev is hosted by the great people at Lunarpages!