Jump to content


Photo
- - - - -

trying to set up a web server on my home network


  • Please log in to reply
6 replies to this topic

#1 nyphonejacks

nyphonejacks

    Dangerous free thinker

  • Members
  • 793 posts
  • Gender:Male
  • Location:718

Posted 10 February 2013 - 12:50 AM

i have set up a CNAME record for a subdomain name ********* to point to my DDNS provider *******  (found a tutorial online that you could still get ddns.com free thru dlink)

 

once that was done I was able to log into my router with this sub-domain, so i know those steps have been done properly. I have since changed the default router password to prevent unauthorized access.

 

my router is a netgear WNDR3400 (n600)

 

i have set port forward to the IP of the system that I want to use. when i check the logs of the router it shows that my public IP address is attempting to access the LAN IP that I set port forwarding to go to.... so the port forwarding settings have to be set properly.

 

I set the IP for the server as DMZ and have made attempts to disable any other forms of firewall for right now. 

 

I am currently using IIS7 on a vista box for the webserver. 

 

i set sharing for the folder that I want to serve, and AFAIK there is no software firewall still running on the system. I am trying to serve a directory and not an HTML file (at least for now) 

 

when i browse the LAN IP address for the server the directory comes right up... when i try to do it by the domain name(s) above i can not access anything - the router logs however show my WAN IP attempting to access the LAN IP 

.

I assume that the problem probably lies in the configuration of the IIS software, although it is possible it might be a firewall issue. 

 

if anyone can help give any advice it would me much appreciated. Once i get this figured out, i eventually want to set up several boxes for different purposes. only problem is that most of my PCs are in need of repairs before I can get them back in working order. 

 

EDITED to remove domain names since i got it sort of figured out... 


Edited by nyphonejacks, 10 February 2013 - 02:45 PM.


#2 dinscurge

dinscurge

    "I Hack, therefore, I am"

  • Members
  • 936 posts
  • Country:
  • Gender:Male
  • Location:the bunker

Posted 10 February 2013 - 10:46 AM

if havent tried, i would try accessing it from external network probably, could always try apache or nginx or something similar. if its the first time trying webhosting from your own connection the isp could be blocking your 80

edits: if you try from an external and they are blocking the 80, shouldnt even get router log for the attempt or anything so should be fairly obvious


Edited by dinscurge, 10 February 2013 - 10:48 AM.


#3 Bit Viper

Bit Viper

    SCRiPT KiDDie

  • Members
  • 28 posts
  • Country:
  • Gender:Male

Posted 10 February 2013 - 01:37 PM

Some routers will prevent looped connections -- i.e. connecting FROM your internal interface TO your external. Try accessing your public URL from outside your home network, as you would if you were someone who wasn't you. Could also try browsing via your public IP address instead of the DNS name, to see if there is any difference there.

 

It may be as dinscurge said, that your ISP is blocking inbound port 80 (many do by default for non-business accounts). In that case, you'd need to enable port forwarding on your router (e.g. direct public port 8080 to port 80 on your internal server) and have the outside world throw the port number on the URL. Less than ideal, but not uncommon.



#4 systems_glitch

systems_glitch

    Dangerous free thinker

  • Moderating Team
  • 1,652 posts
  • Gender:Male

Posted 10 February 2013 - 01:51 PM

You can use one of the many online port scanning tools to figure out if port 80 is open from the outside. Proxies are another option.



#5 nyphonejacks

nyphonejacks

    Dangerous free thinker

  • Members
  • 793 posts
  • Gender:Male
  • Location:718

Posted 10 February 2013 - 02:53 PM

port 80 is open from the ISP since i subscribe to the boost service... 

 

looks like a problem was happening with how IIS was set up... i changed the binding and it seems to work now.. will need to test with a different public IP 

 

err,,, ok still can not get in with my cell phone internet nor my google apps proxy 

 

I know that i am getting at least past my router because it shows the external IP attempting to access the internal IP where the server is in the logs... 


Edited by nyphonejacks, 10 February 2013 - 02:54 PM.


#6 TheFunk

TheFunk

    SUP3R 31337

  • Binrev Financier
  • 187 posts
  • Country:
  • Gender:Male

Posted 11 February 2013 - 12:58 PM

If you get too fed up with IIS, try installing Apache (You could even use XAMPP if you wanted). I've had some experience troubleshooting Apache, but as far as IIS goes, I got nothin'.



#7 nyphonejacks

nyphonejacks

    Dangerous free thinker

  • Members
  • 793 posts
  • Gender:Male
  • Location:718

Posted 12 February 2013 - 10:34 PM

just used IIS because it is what i had installed on the box already.. and it is pretty much my everyday system.. 

 

just wanted proof of concept before i went all out building an actual server.. i actually got it set up better than i could have wanted - the actual subdomain gets to the web server, while the ddns domain and actual IP address do not go to the server... think it has something to do with the bonding feature.. 

 

eventually i will have an apache box and an asterisk box on the network... but that all comes down to when i have the time.. the systems need to be fixed.. and i would probably want to build some kind of multi PC watercooling system so I can keep everything in the cabinet... i tested just 1 of the 5 PCs that I want to store in the cabinet over night and the heat is just too much, so need to build something for cooling.. its all just for fun and to learn






BinRev is hosted by the great people at Lunarpages!