Jump to content


Photo
- - - - -

Windows 7 Wifi Problem


  • Please log in to reply
4 replies to this topic

#1 Ptolemy

Ptolemy

    Will I break 10 posts?

  • Members
  • 4 posts
  • Country:
  • Gender:Male

Posted 28 October 2012 - 05:45 PM

Hi all. I have a Lenovo laptop running Windows 7. I have it set to sleep every time I shut the lid. When I open it up again I have to reconnect to my WiFi router. I was wondering if anyone knew how to fix this.

#2 Bit Viper

Bit Viper

    SCRiPT KiDDie

  • Members
  • 28 posts
  • Country:
  • Gender:Male

Posted 28 October 2012 - 07:25 PM

Hi all. I have a Lenovo laptop running Windows 7. I have it set to sleep every time I shut the lid. When I open it up again I have to reconnect to my WiFi router.

You mean you have to manually tell it to re-connect (it doesn't do it automatically)?

#3 TheFunk

TheFunk

    SUP3R 31337

  • Binrev Financier
  • 187 posts
  • Country:
  • Gender:Male

Posted 28 October 2012 - 07:31 PM

It sounds like your computer is shutting off your NIC when it goes to sleep in order to conserve power. This would explain why your adapter disconnects and needs to be manually reconnected. Try this:

Go to Device manager and look for "Network Adapters" double click on your wireless card and then click on the tab in the window that pops up that says "Power Management".

From this window all you need to do is uncheck "Allow the computer to turn off this device".

If that doesn't work, just let me know.

#4 Ptolemy

Ptolemy

    Will I break 10 posts?

  • Members
  • 4 posts
  • Country:
  • Gender:Male

Posted 30 October 2012 - 03:03 PM

It sounds like your computer is shutting off your NIC when it goes to sleep in order to conserve power. This would explain why your adapter disconnects and needs to be manually reconnected. Try this:

Go to Device manager and look for "Network Adapters" double click on your wireless card and then click on the tab in the window that pops up that says "Power Management".

From this window all you need to do is uncheck "Allow the computer to turn off this device".

If that doesn't work, just let me know.

Well, I tried that and tried restarting after doing that and it didn't work. It may be something with my router. Maybe my laptop or router is timing out the connection after so much time of inactivity?

#5 TheFunk

TheFunk

    SUP3R 31337

  • Binrev Financier
  • 187 posts
  • Country:
  • Gender:Male

Posted 31 October 2012 - 10:25 PM

Does this only happen after your computer goes to sleep? Does it happen to any other computers that sit for extended periods of time? If you can verify that this happens on other computers then you could safely assume that it's a router issue. Typically a wireless IP address lease lasts for 6 hours though, and even if your computer loses it's address and has to request one again, it should automatically connect. Have you made sure that you're set to automatically connect to remembered networks?

If you're not sure, do this: (copied and pasted from another forum)

//

Method 1: Make sure if the WLAN AutoConfig service is set to automatic.

1. Click on the start button, type services.msc and press Enter.
2. Scroll down to the WLAN AutoConfig service, right click on it and select Properties
3. Click on the General tab, select Automatic for startup type.
4. Click on Dependences tab and make sure that all the dependences services are set to Automatic. Then click on the OK button.

//

If that still doesn't work we'll keep trying.




BinRev is hosted by the great people at Lunarpages!