Jump to content


Photo
- - - - -

make error with compat wireless


  • Please log in to reply
3 replies to this topic

#1 ruckus2112

ruckus2112

    DDP Fan club member

  • Members
  • 41 posts

Posted 17 July 2009 - 12:20 PM

Downloaded the compat-wireless source into /usr/src, but when I go into the directory to run make I get this error. I googled it and the common response to it was to install kernel headers (which I did). Anyone have any ideas?

$ sudo make
~/compat_wireless_make_error.txt
/bin/sh: line 0: test: -le: unary operator expected
/bin/sh: line 0: test: -ge: unary operator expected
/bin/sh: line 0: test: -le: unary operator expected
/bin/sh: line 0: test: -le: unary operator expected
/bin/sh: line 0: test: -le: unary operator expected
make: Warning: File `Makefile' has modification time 4e+04 s in the future
make: *** /lib/modules/2.6.27.5-117.fc10.i686/build: No such file or
directory.  Stop.
make: *** [modules] Error 2


#2 robo_geek

robo_geek

    I broke 10 posts and all I got was this lousy title!

  • Members
  • 14 posts
  • Gender:Male

Posted 01 August 2009 - 12:46 AM

Downloaded the compat-wireless source into /usr/src, but when I go into the directory to run make I get this error. I googled it and the common response to it was to install kernel headers (which I did). Anyone have any ideas?

$ sudo make
~/compat_wireless_make_error.txt
/bin/sh: line 0: test: -le: unary operator expected
/bin/sh: line 0: test: -ge: unary operator expected
/bin/sh: line 0: test: -le: unary operator expected
/bin/sh: line 0: test: -le: unary operator expected
/bin/sh: line 0: test: -le: unary operator expected
make: Warning: File `Makefile' has modification time 4e+04 s in the future
make: *** /lib/modules/2.6.27.5-117.fc10.i686/build: No such file or
directory.  Stop.
make: *** [modules] Error 2


What *nix are you running?

on most posix compliant systems you have to run ./configure before make

http://tldp.org/LDP/...rent/smith.html

#3 Ohm

Ohm

    I could have written a book with all of these posts

  • Members
  • 3,209 posts
  • Gender:Male
  • Location:Maine, USA

Posted 01 August 2009 - 03:42 AM

Yes, run configure. It looks like it's setting your shell as /bin/sh, when it should be using /bin/bash.

#4 livinded

livinded

    Dangerous free thinker

  • Agents of the Revolution
  • 1,942 posts
  • Location:~/

Posted 05 August 2009 - 12:38 PM

you also shouldn't be running make as root(sudo).




BinRev is hosted by the great people at Lunarpages!