Jump to content


Photo
- - - - -

OpenSUSE 11.1


  • Please log in to reply
1 reply to this topic

#1 furox

furox

    SCRiPT KiDDie

  • Members
  • 22 posts

Posted 27 March 2009 - 06:16 PM

I just installed OpenSUSE 11.1. I can't find a way to make my video card work (NVIDIA GeForce 8400M GS).
First I installed the development tools (kernel source, gcc, make, etc) and then I installed the driver from the repositories. After running sax2 -r -m 0=nvidia I get this error (logged in /var/log/Xorg.99.log)

(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

So I decide to download the NVDIA driver.
What I did first was (to get version.h):

cd /usr/src/linux
make oldconfig
make prepare

And then run the driver, but I get the fallowing error:

"unable to determine the version of the kernel sources"

The video card works perfect in Ubuntu, but I don't know what's wrong with OpenSUSE.

#2 furox

furox

    SCRiPT KiDDie

  • Members
  • 22 posts

Posted 31 March 2009 - 10:26 AM

I made the video card work. Here is what i did:

Reinstalled OpenSUSE and updated it.
From YaST I installed:
Base Development
kernel-source
kernel-syms

After that I downloaded the nvidia driver and installed it manually and it worked!




BinRev is hosted by the great people at Lunarpages!