Jump to content


Photo
- - - - -

Encrypted Hard Drive


  • Please log in to reply
4 replies to this topic

#1 zefa

zefa

    Will I break 10 posts?

  • Members
  • 2 posts

Posted 21 January 2009 - 02:23 AM

Hey so i encrypted my portable hard drive using trucrypt on a windows system but now i have come to access it through linux when i run truecrypt to mount the drive i get this error message

[codebox]$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/mapper/truecrypt1': Operation not supported
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
clicking on the 'Safely Remove Hardware' icon in the Windows
taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
your own responsibility. For example type on the command line:

mount -t ntfs-3g /dev/mapper/truecrypt1 /media/truecrypt1 -o force

Or add the option to the relevant row in the /etc/fstab file:

/dev/mapper/truecrypt1 /media/truecrypt1 ntfs-3g force 0 0[/codebox]

any help on what to do ive tryed a few things but .....

thanks!

#2 R4p1d

R4p1d

    Hakker addict

  • Members
  • 840 posts
  • Country:
  • Gender:Not Telling
  • Location:Space

Posted 21 January 2009 - 04:08 AM

Hey so i encrypted my portable hard drive using trucrypt on a windows system but now i have come to access it through linux when i run truecrypt to mount the drive i get this error message

$LogFile indicates unclean shutdown (0, 0)Failed to mount '/dev/mapper/truecrypt1': Operation not supportedMount is denied because NTFS is marked to be in use. Choose one action:Choice 1: If you have Windows then disconnect the external devices by          clicking on the 'Safely Remove Hardware' icon in the Windows          taskbar then shutdown Windows cleanly.Choice 2: If you don't have Windows then you can use the 'force' option for          your own responsibility. For example type on the command line:            mount -t ntfs-3g /dev/mapper/truecrypt1 /media/truecrypt1 -o force    Or add the option to the relevant row in the /etc/fstab file:            /dev/mapper/truecrypt1 /media/truecrypt1 ntfs-3g force 0 0

any help on what to do ive tryed a few things but .....

thanks!


I ran across the same problem, honestly, the simple way of doing this is just safely removing it from Windows Xp.
Do it twice, that will failsafe your drive. This problem really got the best of me at times, just plug it to a windows machine and you'll be cool.

#3 zefa

zefa

    Will I break 10 posts?

  • Members
  • 2 posts

Posted 21 January 2009 - 09:51 AM

ok thanks !

#4 R4p1d

R4p1d

    Hakker addict

  • Members
  • 840 posts
  • Country:
  • Gender:Not Telling
  • Location:Space

Posted 21 January 2009 - 06:39 PM

ok thanks !


No problem, glad I could help.

#5 grahamboree

grahamboree

    The phorce is with me!

  • Members
  • 71 posts
  • Location:Worcester Mass

Posted 17 February 2009 - 02:56 PM

for those interested, NTFS uses a journal file, and when you don't "properly" remove something from windows, the journal file is left open and incomplete. Apparently running "ntfsfix" will fix your journal file, and let you mount it, though the easiest and safest way imo is what R4pi1d suggested: "safely remove hardware" from windows.




BinRev is hosted by the great people at Lunarpages!