Jump to content


Photo
- - - - -

can't connect to AP after spoofing MAC


  • Please log in to reply
8 replies to this topic

#1 .solo

.solo

    Gibson Hacker

  • Members
  • 80 posts

Posted 10 October 2008 - 12:35 PM

I was really getting fed up with wireless connectivity issues in backtrack and I think I've found the problem. After I change my mac address with macchanger or ifconfig I can't connect to any access points. I have a Atheros chipset card and a RT73 usb NIC, neither work after I change the mac address. Does anyone else have this problem, or even heard of it?

#2 Spyril

Spyril

    Hakker addict

  • Members
  • 588 posts
  • Location:North Dakota

Posted 10 October 2008 - 09:03 PM

Well apparently it's a problem for other people on both Windows and Linux:
http://www.google.co...amp;btnG=Search
But all of the replies in those threads are so worthless, I wouldn't even bother looking at them. Could you start wireshark or tcpdump while trying to associate with an AP, and post the resulting .cap file here? Have you tried spoofing with another NIC or operating system?

#3 .solo

.solo

    Gibson Hacker

  • Members
  • 80 posts

Posted 11 October 2008 - 01:55 PM

I've tried with two different Atheros chipset mini-pci cards and the RT73 usb NIC. None of them work. I will definitely try to capture the traffic.

#4 TripleP

TripleP

    the 0ne

  • Members
  • 1 posts

Posted 20 October 2008 - 06:20 PM

I have the same problem, please let me know if you find out what's wrong :)
There is another thread about the problem here:
http://bluelight.ru/...ad.php?t=399967

#5 Cryptik Hex

Cryptik Hex

    elite

  • Members
  • 101 posts
  • Location:Pasadena CA

Posted 28 October 2008 - 05:08 AM

First you would want to make sure you are following all the steps correctly, maybe post how you do it, like the commands you put in order.
One thing that happened with my card when i tried to associate was i had to add the AP's MAC to the command for my wireless card to connect
Also if you are trying to connect from a GUI, i suggest using CLI instead.

i used this to connect once i cracked the WEP key:

iwconfig wlan0 essid <essid> ap <ap's mac>
iwconfig wlan0 key (open) <key>
dhcpcd wlan0

this may be different on your card though.

#6 ansichart

ansichart

    SUP3R 31337 P1MP

  • Members
  • 282 posts

Posted 20 November 2008 - 06:37 PM

I had this exact same problem with Atheros cards... here was my solution:
http://madwifi-proje...ngviaSubversion

After downloading the madwifi drivers, make sure you read the installation instructions... and you may have to restart for the changes to take effect.

#7 biosphear

biosphear

    SUPR3M3 31337 Mack Daddy P1MP

  • Members
  • 327 posts
  • Country:
  • Gender:Male
  • Location:SD

Posted 20 November 2008 - 06:46 PM

I have found loading up the newest drivers has worked for me.

I still have a hard time once in a wile when I try to connect to any AP, but I do not worry, because that laptop is used for cracking mostly.

Uninstall your drivers then reinstall the latest Mad WiFi drivers.
Also try to use --mac instead of -m. I do not know why but it works better for me. I have only ran into your problem a few times since I have been using the command --mac, even though it is the same command and does the same thing.
Don't ask me why it seems to work. :wacko:

#8 friendless

friendless

    SUPR3M3 31337 Mack Daddy P1MP

  • Members
  • 336 posts
  • Gender:Male
  • Location:Indiana

Posted 20 November 2008 - 07:21 PM

I have had this problem using Intel 3945ABG with the MAC80211 (iwl3945) drivers, believed due to the MASTER interface still holding onto the older mac address, I am unable to get a positive answer on this from any source though.

Had to revert back to ipw3945 from both latest Ubuntu and Backtrack.

#9 Cryptik Hex

Cryptik Hex

    elite

  • Members
  • 101 posts
  • Location:Pasadena CA

Posted 14 January 2009 - 11:33 PM

I have that same card too friendless and it works FANTASTIC for me! I am using Ubuntu 8.10, and with the default drivers that work out of the box. I just installed the aircrack-ng suite and injection works flawlessly and fast. Just letting you know, haha doesn't seem like you're having too hard a time :]




BinRev is hosted by the great people at Lunarpages!