Jump to content


Photo
- - - - -

Digital audio problem


  • Please log in to reply
1 reply to this topic

#1 PurpleJesus

PurpleJesus

    Dangerous free thinker

  • Members
  • 1,578 posts
  • Gender:Male
  • Location:800

Posted 20 May 2008 - 10:37 PM

I'm at a loss. I've googled but can't seem to find a solution

Since I updated from ubuntu 7.10 to 8.04 I have this strange little problem...

I have the coax digital audio out from my motherboard piped to my home stereo and analog out to a set of computer speakers.
When playing a song it comes out both the D and A.
When a system sound happens, like a chat request, or I do a "test" in system/preferences/sound the digital audio stops but the analog keeps playing w/o missing a beat.
Then when I restart the song from amarok it starts up like nothing was wrong.

If I am playing something from Amarok then say, go to jamendo.com and play a song with their embedded player simultaneously.. Firefox will stall out, the amarok player is still heard out the coax. Then close amarok, firefox resumes but no audio at all.

but If I am playing from amarok and go to say... .. they mix fine and play over as expected..

It's not just Amarok, it's any player I've tried.

I'm scratching my head trying to figure out where to start with this one.. Something is conflicting somewhere... I'm still a bit of a linux noob, so if you ask for the dump of some file, tell me the command to issue to get it.

Motherboard: Intel 975XBX2

Default drivers.


EDIT:

Nevermind. Got it.. set it to: "ALSA PCM on front 0" and it cleared it up.

Edited by PurpleJesus, 21 May 2008 - 11:55 PM.


#2 PurpleJesus

PurpleJesus

    Dangerous free thinker

  • Members
  • 1,578 posts
  • Gender:Male
  • Location:800

Posted 10 March 2010 - 07:58 PM

About a week ago I stumbled on this site

At the bottom it has a few extras..
using this one, now firefox doesn't hang when flash plays audio..
Firefox – Share audio with Flash and other applications

sudo gedit /etc/firefox/firefoxrc

Change FIREFOX_DSP=”none” to FIREFOX_DSP=”aoss” and save.

Been working great for a week now.. So I thought I'd pass it along.




BinRev is hosted by the great people at Lunarpages!