Jump to content


Photo
- - - - -

kismet trouble


  • Please log in to reply
11 replies to this topic

#1 GONZO

GONZO

    HACK THE PLANET!

  • Members
  • 65 posts
  • Location:Missouri

Posted 01 February 2008 - 04:34 PM

This what happens when I run kismet:

gonzo@gonzo-laptop:~$ kismet
Launching kismet_server: /usr/local/bin/kismet_server
FATAL: Could not find user 'your_user_here' for dropping priviledges. Make sure you have a valid user set for 'suiduser' in your config file. See the 'Installation & Security' and 'Configuration' sections of the README file for more information.
Done.
gonzo@gonzo-laptop:~$

I hope some one can help me thanks.

#2 Nicholas Brady

Nicholas Brady

    I broke 10 posts and all I got was this lousy title!

  • Members
  • 16 posts

Posted 02 February 2008 - 12:19 AM

Need to be root to run kismet so it can put your WiFi card into Monitor mode.

#3 I-baLL

I-baLL

    T0tal n00b

  • Agents of the Revolution
  • 1,373 posts
  • Country:
  • Gender:Male
  • Location:New york

Posted 06 February 2008 - 01:09 PM

Edit your kismet.config file and put in "gonzo" where it says "your_user_here" then run kismet as root.

#4 GONZO

GONZO

    HACK THE PLANET!

  • Members
  • 65 posts
  • Location:Missouri

Posted 07 February 2008 - 04:33 PM

Ok I had to reinstall my OS's but I reinstalled kismet and changed my name and what driver or card I have also this is what I ended up with:

anonymous@anonymous:~$ sudo su
[sudo] password for anonymous:
root@anonymous:/home/anonymous# ifconfig wlan0 up
root@anonymous:/home/anonymous# iwconfig wlan0 mode monitor
root@anonymous:/home/anonymous# kismet
Launching kismet_server: /usr/local/bin/kismet_server
Will drop privs to anonymous (1000) gid 1000
No specific sources given to be enabled, all will be enabled.
Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
Enabling channel hopping.
Enabling channel splitting.
FATAL: Support for capture source type 'rt2500' was not built. Check the output from 'configure' for more information about why it might not have been compiled in.
Done.

I guess I put the wrong thing for my card in backtrack I put source=rt2500,rausb0,RT73 but in the ubuntu I put source=t2500,wlan0,RT73 I installed RT73 drivers see:

wlan0 RT73 WLAN ESSID:""
Mode:Monitor Frequency=2.457 GHz Bit Rate=54 Mb/s
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality=0/100 Signal level:-121 dBm Noise level:-115 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

so whats wrong thank for the help.

Edited by GONZO, 07 February 2008 - 05:44 PM.


#5 seven

seven

    SUP3R 31337 P1MP

  • Members
  • 285 posts

Posted 07 February 2008 - 10:48 PM

Use what you used in backtrack to make it work.
Check the kismet documentation for help on configurations to kismet.conf or use google. People usually put their config for the same chipset on forums.





post-script: you can write a small script to put your card in monitor mode for you. If you have the aircrack-ng suite, it comes with a script to do it.

man airmon-ng

Good luck!

#6 GONZO

GONZO

    HACK THE PLANET!

  • Members
  • 65 posts
  • Location:Missouri

Posted 07 February 2008 - 11:06 PM

I guess I forgot the rt2500 driver so I install it and this is what I get now:

anonymous@anonymous:/home$ kismet
Launching kismet_server: /usr/local/bin/kismet_server
Will drop privs to anonymous (1000) gid 1000
FATAL: Unable to set up pidfile /var/run//kismet_server.pid, unlink() failed: Permission denied
Done.


Hope some one can help thanks. :huh:

#7 seven

seven

    SUP3R 31337 P1MP

  • Members
  • 285 posts

Posted 08 February 2008 - 10:31 AM

I guess I forgot the rt2500 driver so I install it and this is what I get now:

anonymous@anonymous:/home$ kismet
Launching kismet_server: /usr/local/bin/kismet_server
Will drop privs to anonymous (1000) gid 1000
FATAL: Unable to set up pidfile /var/run//kismet_server.pid, unlink() failed: Permission denied
Done.


Hope some one can help thanks. :huh:

You need to be root.
The errors usually give you a good clue as to what's wrong. :mellow:

Edited by seven, 08 February 2008 - 10:32 AM.


#8 GONZO

GONZO

    HACK THE PLANET!

  • Members
  • 65 posts
  • Location:Missouri

Posted 08 February 2008 - 04:08 PM

This is what I get as root:

root@anonymous:/home/anonymous# kismet
Launching kismet_server: /usr/local/bin/kismet_server
Will drop privs to anonymous (1000) gid 1000
No specific sources given to be enabled, all will be enabled.
Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
Enabling channel hopping.
Enabling channel splitting.
FATAL: Support for capture source type 'rt2500' was not built. Check the output from 'configure' for more information about why it might not have been compiled in.
Done.

Why cant everything you need come with kismet.

#9 Lord Wud

Lord Wud

    SUPR3M3 31337 Mack Daddy P1MP

  • Members
  • 423 posts
  • Location:New Jersey

Posted 08 February 2008 - 04:19 PM

Why cant everything you need come with kismet.



That has to do with the Unix way of thinking. Meaning that programs are designed to do one specific task as well as they can, so they can be relied upon by other programs. This is different from windows where every program tries to do everything on its own. The error that you're getting is that kismet doesnt know what to do with your card. Plus you're not specifying it in the config file. In any case your answer might lie in this direction. http://rt2x00.serialmonkey.com/ or this one http://www.kismetwir...mentation.shtml

#10 GONZO

GONZO

    HACK THE PLANET!

  • Members
  • 65 posts
  • Location:Missouri

Posted 08 February 2008 - 04:24 PM

It is in the kismet.conf file. source=rt2500,rausb0,RT73


when I do ifconfig it says wlan0 but some one said to type rausb0 instead of wlan0 becouse I have to change the kismet.conf file in backtrack 3.

Thanks for the help.

#11 .solo

.solo

    Gibson Hacker

  • Members
  • 80 posts

Posted 31 July 2008 - 11:00 PM

I know this topic is old, however i thought you might be interested in some insight.

The reason someone told you to use rausb0 is because they were using p_larbig's drivers for rt73 based on the serialmonkey drivers which will give you the wlan0. It is all explained in this ubuntu forum:

http://ubuntuforums....ad.php?t=502526

#12 PurpleJesus

PurpleJesus

    Dangerous free thinker

  • Members
  • 1,578 posts
  • Gender:Male
  • Location:800

Posted 31 July 2008 - 11:15 PM

I know this topic is old, however i thought you might be interested in some insight.

The reason someone told you to use rausb0 is because they were using p_larbig's drivers for rt73 based on the serialmonkey drivers which will give you the wlan0. It is all explained in this ubuntu forum:

http://ubuntuforums....ad.php?t=502526


I also had some recent problems with Kismet and Ubuntu.. Was working fine until I got a wild hare up my ass and decided to install the most recent kismet from source. It stopped working. I have a belkin f5d9050 v3002. Got it working last night after following this:http://blog.mcnicholl.com/2008/03/11/ubuntu-710-gutsy-and-belkin-usb-wireless-networking/

Just thought I'd add it for the two cents.




BinRev is hosted by the great people at Lunarpages!