Jump to content


Photo
- - - - -

Slackware 12 and lack of internet


  • Please log in to reply
15 replies to this topic

#1 Sensayshun

Sensayshun

    Gibson Hacker

  • Members
  • 79 posts

Posted 17 August 2007 - 10:38 AM

Clean install of Slackware 12 to check it out. Havn't got internet, not even wired let alone wireless.

I've run netconfig and that all appears to be in order. ifconfig eth0 tells me that something-or-other cannot be found. I can manage to pink 127.0.0.1.

Just need some ideas on what kind of things I should be trying, and if possible an explanation of how to do them.

Thanks.

#2 seven

seven

    SUP3R 31337 P1MP

  • Members
  • 285 posts

Posted 17 August 2007 - 11:25 AM

can you print the output of the error when doing ifconfig?

#3 regret

regret

    SUPR3M3 31337 Mack Daddy P1MP

  • Members
  • 472 posts
  • Location:Are any of us ever in one place at any give time?

Posted 17 August 2007 - 03:27 PM

And the model of ethernet card you are using and if it is actually a card, or if it is a eth->usb adapter type connection. I've been running Slack12 for about 3 weeks now and I haven't had ethernet (or wireless) problems on any of the three computers I have it on.

#4 Sensayshun

Sensayshun

    Gibson Hacker

  • Members
  • 79 posts

Posted 17 August 2007 - 05:58 PM

lspci: listed quite alot of stuff, but mostly about USB devices, so i thought only the last 3 were relevant? Can get the rest if you'd like.

02:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
02:06.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
02:08.0 Ethernet controller: Intel Corporation PRO/100 VE Network Connection (rev 03)


I then did ifconfig and got the following:

Link encap: Local Loopback
inet addr: 127.0.0.1 Mask: 255.0.0.0
inet6 addr: ::1/128 Scope: Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX Packets: 0 errors: 0 dropped: 0 overruns: 0 frame: 0
TX Packets: 0 errors: 0 dropped: 0 overruns: 0 carrier: 0
collisions: 0 txqueuelen: 0
RX bytes: 0 (0.0 B) TX bytes: 0 (0.0 B)


I then did ifconfig eth0 and got:
eth0: error fetching interface information: Device not found



@ regret: It's an HP 510 laptop - it has wired ethernet and has wireless. Both are using an intel chipset (Pro/100 VE and Pro/Wireless 2200BG, respectively)

#5 Dirk Chestnut

Dirk Chestnut

    SUP3R 31337 P1MP

  • Members
  • 268 posts
  • Location:248

Posted 17 August 2007 - 11:13 PM

The system recognizes the hardware, but are the proper kernel modules (aka drivers) loaded?

Your Intel wired card is pretty common, and uses the module "e100" I *think*. Make sure the kernel module is actually installed: Run "/sbin/lsmod | grep e100" If nothing comes back, it means it wasn't loaded at boot. If this is the care, try to run: "/sbin/modprobe e100". If it comes back with a "Module not found" error, the issue is that the kernel module isn't even on your system.

If the modprobe command runs without complaint, run the lsmod command again. If it returns something this time, now try to run your /sbin/ifconfig eth0. I'm not sure of the Slackware method for configuring network devices to start properly on boot, so you'll want to consult their docs.

#6 seven

seven

    SUP3R 31337 P1MP

  • Members
  • 285 posts

Posted 17 August 2007 - 11:37 PM

Correct, it is e100. Like he said, load that module and you should be golden for 802.3 (ethernet). As for your wireless. Follow the previous method and check if ipw2200 is loaded
if you don't remember here.
$ lsmod | grep ipw2200
If it is not listed then do this
modprobe ipw2200

You should be set.

Edited by seven, 17 August 2007 - 11:47 PM.


#7 livinded

livinded

    Dangerous free thinker

  • Agents of the Revolution
  • 1,942 posts
  • Location:~/

Posted 18 August 2007 - 12:46 AM

intel NICs are some of the best supported cards in linux, the e100 driver has been around forever.

#8 Sensayshun

Sensayshun

    Gibson Hacker

  • Members
  • 79 posts

Posted 18 August 2007 - 05:33 AM

I did /sbin/lsmod | grep e100
and nothing came back
so I did /sbin/modprobe e100

now if I do /sbin/lsmod | grep e100 it comes back with:
e100 35464 0
mii 8576 1 e100

I also did the same with ipw2200 in place of the e100 and now if I do grep with the ipw2200 I get:
ipw2200 145480 0
ieee80211 34248 1 ipw2200

Now If I do ifconfig eth0 I do get sensible results back. But I thought i'd post here to see if there were any ideas for the wireless before I checked if the wired worked (just going to reboot now)

#9 seven

seven

    SUP3R 31337 P1MP

  • Members
  • 285 posts

Posted 18 August 2007 - 06:17 AM

modprobe ipw2200 should have loaded the module for your wireless.

try iwconfig and see what you get.

#10 Sensayshun

Sensayshun

    Gibson Hacker

  • Members
  • 79 posts

Posted 18 August 2007 - 06:38 AM

[codebox]root@Root:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:16:D4:C1:75:45
inet addr:192.168.0.126 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::216:d4ff:fec1:7545/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:80 errors:0 dropped:0 overruns:0 frame:0
TX packets:96 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:53786 (52.5 KiB) TX bytes:16350 (15.9 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

root@Root:~# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.[/codebox]



Also whenever slackware boots up I have to do /sbin/modprobe e100 before I can get the wired ethernet working.
This was written from slackware, on the wired ethernet

#11 livinded

livinded

    Dangerous free thinker

  • Agents of the Revolution
  • 1,942 posts
  • Location:~/

Posted 18 August 2007 - 12:27 PM

Read this, http://slackwiki.org...c.modules.local, section on rc.modules.local, this is the correct way to load extra modules on boot. Once you create the file (as root) enter those few lines to have it run the rc.modules file and then add the modprobe lines underneath it to load any extra modules you would like loaded on boot.

Edit: Forgot to include the link :D

Edited by livinded, 18 August 2007 - 12:28 PM.


#12 s25

s25

    Gibson Hacker

  • Members
  • 80 posts

Posted 18 August 2007 - 03:14 PM

Have you tried doing dhcpcd ?

#13 seven

seven

    SUP3R 31337 P1MP

  • Members
  • 285 posts

Posted 18 August 2007 - 03:27 PM

yeah, once your wired interface is up, you usually have to determine how you will obtain your IP. Via it being static or dynamic. Most likely you have DHCP enabled so you can do( i'm not sure if this works in slackware ) dhclient eth0. Or you can do, dhcpcd eth0

i'm pretty sure dhcpcd works in slax so it probably would work in slackware.

#14 regret

regret

    SUPR3M3 31337 Mack Daddy P1MP

  • Members
  • 472 posts
  • Location:Are any of us ever in one place at any give time?

Posted 18 August 2007 - 04:40 PM

You actually have the exact same wired and wireless network card that I have on this laptop...are you using the default kernel when you're installing or are you using a different one.

#15 s25

s25

    Gibson Hacker

  • Members
  • 80 posts

Posted 19 August 2007 - 07:33 AM

dhcpcd works on slackware ;) I am connecting to the net right now after doing that!

#16 Sensayshun

Sensayshun

    Gibson Hacker

  • Members
  • 79 posts

Posted 19 August 2007 - 12:10 PM

I was using the standard kernel yes :)

Thanks guys, got it working just doing what you said :D

Greatly appreciated.




BinRev is hosted by the great people at Lunarpages!