Jump to content


Photo
- - - - -

2.6 kernel


  • Please log in to reply
6 replies to this topic

#1 hacnslash

hacnslash

    Banisher of n00bs

  • Agents of the Revolution
  • 2,454 posts

Posted 13 October 2003 - 07:24 PM

has somebody gotten the 2.6 kernel to install any modules?
it boots up every time but there are NO modules compiled anywhere. there is no /lib/modules/2.6.0-test7 (or whatever number) directory either.
alas i have tried to replace the 2.4.22 kernel in the slack iso with 2.6 and i got a kernel panic (expectable, but worth a shot), so if anybody can send me any 2.6 bzImages please do, i guess they should be small enough to be emailed, thanks.
edit: yes, i do have the new module init utils.

#2 psychopuppy

psychopuppy

    Hakker addict

  • Members
  • 508 posts

Posted 13 October 2003 - 08:51 PM

what commands did you use to compile? i know make now includes make dep, make bzImage and make modules. but im not sure if you have to do make modules_install separately :unsure:

also, did you translate your modules.conf into modprobe.conf?

#3 vooduHAL

vooduHAL

    SUPR3M3 31337 Mack Daddy P1MP

  • Agents of the Revolution
  • 415 posts

Posted 13 October 2003 - 09:58 PM

I did work with the 2.6.0 alpha 1 kernel, and from what I remember you have to recompile the kernel tools for that particular build.

#4 White_Raven

White_Raven

    That's so raven!

  • Banned
  • 1,597 posts

Posted 14 October 2003 - 04:39 AM

All the tools have new version and code and as such need to be recompiled; the entire subsystem has been changed for many key pionts, from what I understand and as such allot will not work unless your working with the bleeding edge.. and then its still beta..

#5 hacnslash

hacnslash

    Banisher of n00bs

  • Agents of the Revolution
  • 2,454 posts

Posted 14 October 2003 - 02:54 PM

allright, to answer questions
you dont need to do a make dep anymore, just make bzImage make modules make modules install

and i did just that.

i also had the module init tools that 2.6 needs (the latest stable version 0.9.14), i am not aware of any other programs i need to change??

#6 hacnslash

hacnslash

    Banisher of n00bs

  • Agents of the Revolution
  • 2,454 posts

Posted 14 October 2003 - 03:36 PM

WOW AM I A FUCKING RETARD OR WHAT!?????????

when i recompiled I said "make modules install" instead of "make modules_install" wow how fucking retarded am I!?! so thats prolly why it didna install modules..

yup...that was it, anyway i recompiled again with everything in the kernel, so i dont have any modules anyway...can't wait till 2.6 final comes out...w00t w00t

#7 hacnslash

hacnslash

    Banisher of n00bs

  • Agents of the Revolution
  • 2,454 posts

Posted 18 October 2003 - 09:12 AM

by the by, at test7 linus issued a "stability freeze", so from now on only bug fixes and neccessary updates will be accepted, no extra "goodies". and also, test8 is out now.




BinRev is hosted by the great people at Lunarpages!