Jump to content


Photo
- - - - -

Gentoo Console Resolution


  • Please log in to reply
7 replies to this topic

#1 natas

natas

    De La Natas

  • Agents of the Revolution
  • 4,273 posts
  • Gender:Male
  • Location:The Old Skool

Posted 06 January 2006 - 09:32 PM

I only run command line on my Gentoo box, so when I boot up it doesnt start a graphical login screen or anything of that sort. So how do I change the resolution of the console at startup? I think its only at like 800x600 right now. It'd be nice if I could have it at like 1024x786 and get more screen space.

#2 kitche

kitche

    Hakker addict

  • Members
  • 549 posts

Posted 06 January 2006 - 11:34 PM

I am not complete sure about this but it could be in your .profile

#3 b8zs

b8zs

    The phorce is with me!

  • Members
  • 76 posts
  • Location:64 Kbps x24

Posted 07 January 2006 - 05:06 AM

compile support for the proper frame buffer into your kernel (if not done already)

then append the correct configuration settings to your bootloader config(example):

kernel /kernel-2.6.12-r2 root=/dev/sdb3 video=vesafb:mtrr,ywrap,1024x768-32@75

#4 brain_shifter

brain_shifter

    Will I break 10 posts?

  • Members
  • 6 posts

Posted 07 January 2006 - 12:17 PM

/(boot)/grub/grub.conf
[...]
kernel /boot/kernel-genkernel-x86-2..... [...] vga=0x31A
[...]
(or 0x317 for 1024x8..)

Edited by brain_shifter, 07 January 2006 - 12:17 PM.


#5 nenn

nenn

    SUPR3M3 31337 Mack Daddy P1MP

  • Members
  • 459 posts
  • Location:New York City

Posted 14 January 2006 - 07:42 AM

for lilo uncoment the line vga=791 or whichever you want for your screen resolution (i belive thats for 1024x768x24

#6 hdcase

hdcase

    SUP3R 31337

  • Members
  • 156 posts
  • Location:127.0.0.1

Posted 16 January 2006 - 02:05 AM

I had the same problem... played around with grub.conf and got it fixed up.

The Gentoo Installation docs were my best friends for this issue. See the section on setting up grub (or LILO).

#7 nexis

nexis

    SUP3R 31337 P1MP

  • Members
  • 285 posts
  • Location:Iowa

Posted 19 January 2006 - 03:58 PM

you NEED to have frame buffer support in your kernel for any of that to work, just fyi. if you see a nice lil logo at the upper left hand when booting, your set, just change your lilo.conf file to reflect the changes.

#8 systems_glitch

systems_glitch

    Dangerous free thinker

  • Moderating Team
  • 1,656 posts
  • Gender:Male

Posted 19 January 2006 - 06:58 PM

Of course, don't forget to reinstall lilo to the MBR/primary partition/wherever...I spent a few months trying to write CDs in regular ATAPI mode because I didn't know to reinstall lilo after adding my ide-scsi specs!




BinRev is hosted by the great people at Lunarpages!