Jump to content


Photo
- - - - -

logged in as root and cant acess /mnt/cdrom


  • Please log in to reply
13 replies to this topic

#1 ragweed

ragweed

    SUPR3M3 31337 Mack Daddy P1MP

  • Members
  • 484 posts

Posted 21 June 2003 - 02:10 PM

I am currently running mandrakelinux 9.0, I am logged in as root, and I can not acess /mnt/cdrom. I am receving the error "Unable to enter file:/mnt/cdrom. You do not have acess right to this location." I have also tired running the following command: chmod -R a+rx /mnt/cdrom but when I execute this command i get an Input/output error
How can I gain acess to /mnt/cdrom? :help: :wacko:

#2 White_Raven

White_Raven

    That's so raven!

  • Banned
  • 1,597 posts

Posted 21 June 2003 - 02:35 PM

you mount it correctly or have the automountd installed and working? Does the file/folder really exist? Did you install everything needed? Did you experiance something strange during the install? Is the hardware older or newer? What are the hardware specs? Are the correct rpms for your cpu ARCH installed?

#3 ragweed

ragweed

    SUPR3M3 31337 Mack Daddy P1MP

  • Members
  • 484 posts

Posted 21 June 2003 - 02:38 PM

the hardware isnt even a yr old its mounted and installed fine and the folder does exist but its locked

#4 feend

feend

    microphone commander

  • Members
  • 497 posts

Posted 21 June 2003 - 03:37 PM

Hmm was it working before and now it's not?

Do you have multiple cdrom drives?

#5 ragweed

ragweed

    SUPR3M3 31337 Mack Daddy P1MP

  • Members
  • 484 posts

Posted 21 June 2003 - 03:41 PM

nope its a fresh install of mandrake i only have on cdrom drive

#6 White_Raven

White_Raven

    That's so raven!

  • Banned
  • 1,597 posts

Posted 21 June 2003 - 04:37 PM

can you delete the symlink, delete teh folder, mkdir a new folder with the same place and name, and mount it correctly?

This is a new install? As in "brand new not a hour ago" or as in "yestday I have been hacking it all night"?

#7 ragweed

ragweed

    SUPR3M3 31337 Mack Daddy P1MP

  • Members
  • 484 posts

Posted 21 June 2003 - 07:31 PM

i installed it yesterday but didnt do anything with it but i fixed the problem i went into /dev and moved the folder cdroms to /mnt and walla the cdrom drive became unlocked

#8 BoBB

BoBB

    SUP3R 31337

  • Members
  • 155 posts

Posted 21 June 2003 - 11:43 PM

wait a minute, you moved /dev/cdrom to /mnt??????

#9 ragweed

ragweed

    SUPR3M3 31337 Mack Daddy P1MP

  • Members
  • 484 posts

Posted 22 June 2003 - 12:56 AM

no i moved /dev/cdroms i dont get it either i just figured what the hell its worth a shot

#10 White_Raven

White_Raven

    That's so raven!

  • Banned
  • 1,597 posts

Posted 22 June 2003 - 01:30 AM

Interesting, lol

#11 feend

feend

    microphone commander

  • Members
  • 497 posts

Posted 22 June 2003 - 05:42 AM

/dev/cdrom is just a symlink which was probably broken. Sometimes programs will look for files in a list chronologically. By seeing that the symlink no longer existed in /dev the actual device file may have then been found. Otherwise I don't have an explanation for why that would have worked :huh: .

#12 vooduHAL

vooduHAL

    SUPR3M3 31337 Mack Daddy P1MP

  • Agents of the Revolution
  • 415 posts

Posted 22 June 2003 - 09:02 AM

Have you tried mounting the actual device? /dev/hdb, /dev/hdc, /dev/hdd, depending on your IDE jumper settings.

#13 vooduHAL

vooduHAL

    SUPR3M3 31337 Mack Daddy P1MP

  • Agents of the Revolution
  • 415 posts

Posted 22 June 2003 - 09:03 AM

NM. Just saw where you fixed it.

#14 ragweed

ragweed

    SUPR3M3 31337 Mack Daddy P1MP

  • Members
  • 484 posts

Posted 25 June 2003 - 08:19 PM

uhhh its doing it again this time i copied /mnt/cdrom then pasted /mnt/cdrom and it worked but each time i shut down something fukked up happens and it gets locked down :angry:




BinRev is hosted by the great people at Lunarpages!